Bug 36814 - S3->S4 inplace migration: lp_int(): is called with NULL!
S3->S4 inplace migration: lp_int(): is called with NULL!
Status: VERIFIED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 3.2
Other Linux
: P5 minor (vote)
: ---
Assigned To: Arvid Requate
Stefan Gohmann
: interim-4
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-18 15:21 CET by Arvid Requate
Modified: 2015-01-19 21:24 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2014-11-18 15:21:05 CET
During migration from samba3 to samba4 the follwing error messages are shown:

lp_int(): is called with NULL!
set_variable_helper(): value is not boolean!
ERROR(runtime): uncaught exception - Unable to load file /var/lib/samba3/etc/samba/smb.conf
  File "/usr/lib/python2.7/dist-packages/samba/netcmd/__init__.py", line 175, in _run
    return self.run(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/samba/netcmd/domain.py", line 1458, in run
    s3conf.load(smbconf)

The issue seems to be caused by two parameters "os level" and "wins support" set empty in /var/lib/samba3/etc/samba/smb.conf.



+++ This bug was initially created as a clone of Bug #33261 +++

log.smbd shows on a UCS 3.2 DC Slave:

=======================================================================
  doing parameter wins support = 
[2013/11/09 02:26:01.739943,  0] ../source3/param/loadparm.c:1319(lp_bool)
  lp_bool(): value is NULL or empty!
=======================================================================

The corresponding template line should be adjusted to cope with empty values:

smb.conf.d/51univention-samba_domain: wins support = @%@windows/wins-support@%@
Comment 1 Arvid Requate univentionstaff 2014-11-18 15:36:14 CET
After fixing this the in-place migration succeeded.
Changelog added.
Comment 2 Stefan Gohmann univentionstaff 2015-01-19 21:24:38 CET
OK, that was a last minute 4.0-0 fix.