Bug 37028 - Blocked update message
Blocked update message
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Software update
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-4-errata
Assigned To: Dirk Wiesenthal
Florian Best
:
Depends on:
Blocks: 37327 37363 40458
  Show dependency treegraph
 
Reported: 2014-11-26 08:43 CET by Stefan Gohmann
Modified: 2016-07-27 16:07 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Screenshot (41.24 KB, image/png)
2014-12-15 19:02 CET, Florian Best
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-11-26 08:43:35 CET
If I open the online update module on a UCS 3.2-4 system, I see the following message:
-------------------------------------------------------------------------------
The currently installed release version is 3.2-4 errata241
Version 3.0 of the application 7iApp-123 is not available for the new release. Use the "7iApp-123" module to upgrade this application if possible.
-------------------------------------------------------------------------------

It is not clear which upgrade is meant. Suggestion:
-------------------------------------------------------------------------------
The currently installed release version is 3.2-4 errata241. An update to UCS 4.0-0 is available. 

The upgrade to UCS 4.0 is currently blocked on this system because the appliacation 7iApp-123 is not available in the version 3.0 for UCS 4.0. Please check if an application upgrade is available in the Univention App Center. Alternatively, you can wait for an App upgrade or uninstall the application if it is no longer needed.
-------------------------------------------------------------------------------
Comment 1 Dirk Wiesenthal univentionstaff 2014-12-13 23:36:35 CET
Fixed in

  univention-updater 9.0.44-11.1352.201412132328

Let me know what you think about the wording
Comment 2 Florian Best univentionstaff 2014-12-15 19:02:15 CET
Created attachment 6534 [details]
Screenshot

With univention-updater 9.0.44-14.1357.201412151526.

The wording looks wrong / not nice:
* missing dot after the first sentence
* Why not listing every component in the list instead of only the second ("this holds also for")
* What does "Version is available but cannot be installed." mean?
Comment 3 Dirk Wiesenthal univentionstaff 2014-12-15 23:14:50 CET
(In reply to Florian Best from comment #2)
> * missing dot after the first sentence

Fixed

> * Why not listing every component in the list instead of only the second
> ("this holds also for")

Because my guess is that in most cases only one component is missing. Putting it in a paragraph looks nicer. Listing them looks awkward if you repeat every detail in every bullet and is confusing if the details are explained before the list.

> * What does "Version is available but cannot be installed." mean?

Guess I was using a bug in UniventionUpdater which is fixed by today. Friday it was: "Version 4.0-0 is available but cannot be installed.". I found a way to get at least "Version 4.0 is available". I guess that this is enough because components available for 4.0-0 should be available for 4.0-1, too (so no "You have installed 4.0-1. The new version 4.0 cannot be installed")
Comment 4 Florian Best univentionstaff 2014-12-16 16:15:32 CET
YAML: OK
Fix: OK, IMHO some little strings from Stefans suggestions are more clear, nevertheless VERIFIED.
Comment 5 Moritz Muehlenhoff univentionstaff 2014-12-17 12:54:03 CET
http://errata.univention.de/ucs/3.2/253.html