Bug 37363 - Blocked update message
Blocked update message
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Software update
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-0-errata
Assigned To: Dirk Wiesenthal
Florian Best
:
: 37327 (view as bug list)
Depends on: 37028
Blocks: 37327
  Show dependency treegraph
 
Reported: 2014-12-16 16:17 CET by Florian Best
Modified: 2015-01-29 11:47 CET (History)
5 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2014-12-16 16:17:30 CET
For UCS 4.0.
When merging please keep in mind that appcenter now has the flavor 'appcenter' for the link!

+++ This bug was initially created as a clone of Bug #37028 +++

If I open the online update module on a UCS 3.2-4 system, I see the following message:
-------------------------------------------------------------------------------
The currently installed release version is 3.2-4 errata241
Version 3.0 of the application 7iApp-123 is not available for the new release. Use the "7iApp-123" module to upgrade this application if possible.
-------------------------------------------------------------------------------

It is not clear which upgrade is meant. Suggestion:
-------------------------------------------------------------------------------
The currently installed release version is 3.2-4 errata241. An update to UCS 4.0-0 is available. 

The upgrade to UCS 4.0 is currently blocked on this system because the appliacation 7iApp-123 is not available in the version 3.0 for UCS 4.0. Please check if an application upgrade is available in the Univention App Center. Alternatively, you can wait for an App upgrade or uninstall the application if it is no longer needed.
-------------------------------------------------------------------------------
Comment 1 Stefan Gohmann univentionstaff 2015-01-20 20:33:29 CET
Please merge the fix
Comment 2 Dirk Wiesenthal univentionstaff 2015-01-21 00:39:47 CET
*** Bug 37327 has been marked as a duplicate of this bug. ***
Comment 3 Dirk Wiesenthal univentionstaff 2015-01-21 01:11:39 CET
Fixed in
  univention-updater 10.0.51-15.1365.201501210102
Comment 4 Florian Best univentionstaff 2015-01-21 11:55:16 CET
OK, the merge is nice and fixed also some textual typos.
There are minor differences in the javascript code (due to the UCS 4.0 release) but they are fine (also tested with jshint).
.po translation files are also fine.

YAML: OK
Comment 5 Janek Walkenhorst univentionstaff 2015-01-29 11:47:48 CET
<http://errata.univention.de/ucs/4.0/53.html>