Bug 37033 - Show warning dialogue upon page reload during and update
Show warning dialogue upon page reload during and update
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Software update
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-1-errata
Assigned To: Alexander Kläser
Florian Best
:
: 36551 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-26 09:38 CET by Stefan Gohmann
Modified: 2015-03-11 15:06 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-11-26 09:38:50 CET
The upgrade via UMC is not always transparent for the Administrator. If one starts the upgrade via UMC and no reload or something else is done, the upgrade runs normally smooth. But a reload could break it, for example if apache is not available at that point. And if I remember correctly, we advise a reload if the connection is disrupted.

In the first step we should re-check all possible notes and informations given by the module before and during the upgrade. We should add a note that it is possible that the connection could break for some time.

See also:  Bug #36551 and Bug #36943
Comment 1 Alexander Kläser univentionstaff 2014-11-27 17:33:09 CET
... especially the note that is shown when the connection to apache is interrupted for a longer while should be adapted.
Comment 2 Alexander Kläser univentionstaff 2014-11-27 17:35:53 CET
We could also add the following warning dialogue:

> http://stackoverflow.com/questions/7317273/warn-user-before-leaving-page-with-unsaved-changes
Comment 3 Stefan Gohmann univentionstaff 2014-12-05 06:57:47 CET
*** Bug 36551 has been marked as a duplicate of this bug. ***
Comment 4 Alexander Kläser univentionstaff 2015-02-11 18:19:14 CET
Some texts have already been clarified in Bug 37254.
Comment 5 Alexander Kläser univentionstaff 2015-02-11 18:22:51 CET
(In reply to Alexander Kläser from comment #2)
> We could also add the following warning dialogue:
> 
> > http://stackoverflow.com/questions/7317273/warn-user-before-leaving-page-with-unsaved-changes

This would be the only change that seems reasonable to me at this moment.
Comment 6 Alexander Kläser univentionstaff 2015-02-27 16:36:20 CET
Done. A handler to prompt a confirmation dialogue is registered for the update period. After the update is finished, the handler is removed again.

YAML file has been adjusted [r58526]..

QA: Please check different browser types.

univention-updater (10.0.53-9) [r58525]:
* Bug #37033: prompt a confirmation dialogue when the browser window is
  closed or reloaded during an update process
Comment 7 Florian Best univentionstaff 2015-03-02 12:32:14 CET
REOPEN: The message is not displayed in Firefox.
Chromium: OK
Comment 8 Florian Best univentionstaff 2015-03-02 12:38:04 CET
IE9: OK

"bis zu mehrere Minuten" → "bis zu mehreren Minuten" ?!
Comment 9 Florian Best univentionstaff 2015-03-02 12:55:46 CET
Android-Firefox, Android-Chromium, Android-native: does not work but also does not break anything.
Comment 10 Alexander Kläser univentionstaff 2015-03-03 17:18:02 CET
(In reply to Florian Best from comment #7)
> REOPEN: The message is not displayed in Firefox.
> Chromium: OK

I cannot do anything about that, this seems to be a "feature" in FF4+:
http://stackoverflow.com/a/14776747/3116268

(In reply to Florian Best from comment #8)
> IE9: OK
> 
> "bis zu mehrere Minuten" → "bis zu mehreren Minuten" ?!

It should be fine in this case, "bis zu" + accusative if word does not have a definite article.

(In reply to Florian Best from comment #9)
> Android-Firefox, Android-Chromium, Android-native: does not work but also
> does not break anything.

Yep, this is fine as not all browsers support this features.
Comment 11 Florian Best univentionstaff 2015-03-04 08:47:18 CET
OK
YAML: OK
Comment 12 Moritz Muehlenhoff univentionstaff 2015-03-11 15:06:59 CET
http://errata.univention.de/ucs/4.0/106.html