Bug 38140 - Logrotate error because of duplicate entry for connector-tracebacks.log
Logrotate error because of duplicate entry for connector-tracebacks.log
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: S4 Connector
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.2-3-errata
Assigned To: Arvid Requate
Felix Botner
:
Depends on:
Blocks: 46798
  Show dependency treegraph
 
Reported: 2015-03-26 15:50 CET by Jan Christoph Ebersbach
Modified: 2018-04-11 13:49 CEST (History)
7 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 4: Will affect most installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.137
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number: 2018020521000638
Bug group (optional):
Max CVSS v3 score:
best: Patch_Available+


Attachments
Patch for logrotate conffiles of univention-ad-connector and univention-s4-connector (1.29 KB, patch)
2016-09-30 17:12 CEST, Julius Hinrichs
Details | Diff
bug38140.patch (711 bytes, patch)
2016-10-04 15:02 CEST, Arvid Requate
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Christoph Ebersbach univentionstaff 2015-03-26 15:50:26 CET
When univention-s4-connector and univention-ad-connector are installed at the same time, logrotate produces the following error and sends a daily email message to root:

# logrotate /etc/logrotate.conf
error: univention-s4-connector:11 duplicate log entry for /var/log/univention/connector-tracebacks.log
error: found error in /var/log/univention/connector-tracebacks.log , skipping

This is caused by a duplicate entry for /var/log/univention/connector-tracebacks.log in both connectors.

I was able to reproduce the error with UCS 3.2-5.  In UCS 4.0 the very same logrotate configuration is used.
Comment 1 Julius Hinrichs univentionstaff 2016-09-30 17:12:39 CEST
Created attachment 8060 [details]
Patch for logrotate conffiles of univention-ad-connector and univention-s4-connector
Comment 2 Arvid Requate univentionstaff 2016-10-04 15:02:49 CEST
Created attachment 8064 [details]
bug38140.patch

Hmm, where did you get those file names from? I just grepped through the source code for the term "tracebacks" and it turns out that neither univention-ad-connector nor univention-s4-connector write this file "connector-tracebacks.log" any longer. I would propose the attached patch instead. If you agree we should clone this bug to do the same for univention-ad-connector.
Comment 3 Moritz Bunkus 2018-04-09 12:52:21 CEST
The duplicate entry has a much more severe impact than just the error messages in the mail. The whole file `/etc/logrotate.d/univention-s4-connector` is ignored due to that error. The result is that the logs from the S4 connector aren't rotated at all.

I just noticed this on a system where the S4 connector's log file was > 10 GB in size.
Comment 4 Arvid Requate univentionstaff 2018-04-09 15:39:30 CEST
18a8f128fb | fix
6591356ac9 | Advisory
56c27621f6 | Advisory version
Comment 5 Felix Botner univentionstaff 2018-04-10 12:28:19 CEST
OK - logrotate
OK - YAML
Comment 6 Arvid Requate univentionstaff 2018-04-11 13:49:38 CEST
<http://errata.software-univention.de/ucs/4.2/322.html>