Bug 46798 - [4.3] Logrotate error because of duplicate entry for connector-tracebacks.log
[4.3] Logrotate error because of duplicate entry for connector-tracebacks.log
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: S4 Connector
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Arvid Requate
Felix Botner
:
Depends on: 38140
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-09 15:43 CEST by Arvid Requate
Modified: 2018-04-11 13:25 CEST (History)
8 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 4: Will affect most installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.137
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2018-04-09 15:43:38 CEST
We should also fix this in UCS 4.3


+++ This bug was initially created as a clone of Bug #38140 +++

When univention-s4-connector and univention-ad-connector are installed at the same time, logrotate produces the following error and sends a daily email message to root:

# logrotate /etc/logrotate.conf
error: univention-s4-connector:11 duplicate log entry for /var/log/univention/connector-tracebacks.log
error: found error in /var/log/univention/connector-tracebacks.log , skipping

This is caused by a duplicate entry for /var/log/univention/connector-tracebacks.log in both connectors.

I was able to reproduce the error with UCS 3.2-5.  In UCS 4.0 the very same logrotate configuration is used.
Comment 1 Arvid Requate univentionstaff 2018-04-09 15:48:15 CEST
2bacd6da0f | fix
1ffa12b832 | Advisory
Comment 2 Felix Botner univentionstaff 2018-04-10 09:54:01 CEST
FAIL - YAML

-> git show 1ffa12b832
fatal: ambiguous argument '1ffa12b832': unknown revision or path not in the working tree.

pushed?


OK - logrotate univention-s4-connector
Comment 3 Arvid Requate univentionstaff 2018-04-10 11:08:26 CEST
Yes, pushed now:
2be6d889fc | Advisory
Comment 4 Felix Botner univentionstaff 2018-04-10 12:29:43 CEST
OK - logrotate univention-s4-connector
OK - YAML
Comment 5 Arvid Requate univentionstaff 2018-04-11 13:25:20 CEST
<http://errata.software-univention.de/ucs/4.3/12.html>