Bug 39929 - Repository settings and package management modules cannot be opened
Repository settings and package management modules cannot be opened
Status: CLOSED DUPLICATE of bug 40991
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-x
Assigned To: UMC maintainers
:
Depends on: 39688
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-13 11:44 CET by Florian Best
Modified: 2016-04-19 09:55 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2015-11-13 11:44:00 CET
This is still broken and happens after page refresh in the package management (e.g. after successful installation).
Access /univention-management-console/#module=appcenter:packages:0:
and the traceback occurs, nothing happens anymore:

TypeError: Cannot read property '_searchSidebar' of undefined
    at declare._getModuleStateAttr (https://10.200.27.32/univention-management-console/js_$20151311112354$/umc/modules/appcenter.js:131:45)
    at c.get (https://10.200.27.32/univention-management-console/js_$20151311112354$/dojo/dojo.js:1339:159)
    at declare._setModuleStateAttr (https://10.200.27.32/univention-management-console/js_$20151311112354$/umc/modules/appcenter.js:100:28)
    at c.set (https://10.200.27.32/univention-management-console/js_$20151311112354$/dojo/dojo.js:1339:329)

+++ This bug was initially created as a clone of Bug #39688 +++

When opening either the package management or the repository settings module, I received the following error and the package remains empty:

"TypeError: Cannot read property '_searchSidebar' of undefined at declare.postCreate (http://192.168.0.188:8011/univention-management-console/js_$20153010154401$/umc/modules/appcenter.js:88:23)
Comment 1 Florian Best univentionstaff 2016-04-19 09:55:30 CEST
<http://errata.software-univention.de/ucs/4.1/146.html>

*** This bug has been marked as a duplicate of bug 40991 ***