Bug 40631 - Welcome screen turns off and error message is shown on black screen
Welcome screen turns off and error message is shown on black screen
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-1
Assigned To: Felix Botner
Erik Damrose
:
Depends on:
Blocks: 40715
  Show dependency treegraph
 
Reported: 2016-02-10 14:42 CET by Sönke Schwardt-Krummrich
Modified: 2016-02-17 14:56 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Error message on black text console (37.58 KB, image/jpeg)
2016-02-10 14:43 CET, Sönke Schwardt-Krummrich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2016-02-10 14:42:03 CET
Current UCS 4.1-0 DVD from 20160210-084623:
The installed DC master system has been rebooted and the splash and next the welcome screen is shown. After a few seconds, the welcome screen disappears and the black text console shows only the following error message:

(process:273) GLib-WARNING **: getpwuid_r(): failed due to unknown user id (0)

If any key is pressed, /etc/issue and login prompt is shown.
Comment 1 Sönke Schwardt-Krummrich univentionstaff 2016-02-10 14:43:57 CET
Created attachment 7467 [details]
Error message on black text console
Comment 2 Felix Botner univentionstaff 2016-02-15 13:05:15 CET
I can not reproduce this, nevertheless i changed univention-welcome-screen to use vt7 (that is what the bootsplash plymouth is using) and added some log messages (/var/log/univention/welcome-screen.log).
Comment 3 Erik Damrose univentionstaff 2016-02-15 15:29:01 CET
OK: univention-bootsplash 7.0.2-12.100.201602151254 (i did not reproduce it, but it works with this version)
OK: changelog
Verified
Comment 4 Stefan Gohmann univentionstaff 2016-02-16 16:49:43 CET
UCS 4.1-1 has been released:
 https://docs.software-univention.de/release-notes-4.1-1-en.html
 https://docs.software-univention.de/release-notes-4.1-1-de.html

If this error occurs again, please use "Clone This Bug".