Bug 40715 - Welcome screen turns off and error message is shown on black screen
Welcome screen turns off and error message is shown on black screen
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.1-1-errata
Assigned To: Felix Botner
Eduard Mai
:
Depends on: 40631
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 14:56 CET by Felix Botner
Modified: 2016-04-20 15:42 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2016-02-17 14:56:24 CET
+++ This bug was initially created as a clone of Bug #40631 +++

Current UCS 4.1-0 DVD from 20160210-084623:
The installed DC master system has been rebooted and the splash and next the welcome screen is shown. After a few seconds, the welcome screen disappears and the black text console shows only the following error message:

(process:273) GLib-WARNING **: getpwuid_r(): failed due to unknown user id (0)

If any key is pressed, /etc/issue and login prompt is shown.
Comment 1 Felix Botner univentionstaff 2016-02-17 15:00:06 CET
reproducible on hardware (laptop coach3).

Seems to be a problem with drm/kms framebuffer driver. These new frame buffer driver (radeondrmfb) no longer support copying raw images from/to the framebuffer device. So the whole concept of the univention welcome screen (let plymouth display the messge, copy framebuffer raw image, stop plymouth, copy raw image to framebuffer) does not work here.
Comment 2 Alexander Kläser univentionstaff 2016-02-17 15:30:56 CET
Another observation, if the welcome screen is shown, the screen will turn black after a while (i.e., the standard screen saver). The frame buffer will then be overwritten and a consequent any-key press will hide the welcome screen. I.e., the welcome screen is only visible for short while.
Comment 3 Felix Botner univentionstaff 2016-02-23 09:44:52 CET
(In reply to Alexander Kläser from comment #2)
> Another observation, if the welcome screen is shown, the screen will turn
> black after a while (i.e., the standard screen saver). The frame buffer will
> then be overwritten and a consequent any-key press will hide the welcome
> screen. I.e., the welcome screen is only visible for short while.

=> Bug #40750


The other problem.

On some hardware, if availbale, the drm/kms framebuffer drivers are used for rendering the bootsplash/welcome screen. With these drivers the low level operations (cp to and cp from) on the framebuffer device are not working correctly.

I patched plymouth to use the old-school framebuffer as default.

product: ucs
release: "4.1"
version: [0,1]
scope: ucs_4.1-0-errata4.1-1
src: plymouth
fix: 0.8.5.1-5.18.201602181308
desc: |
 This update addresses the following issue(s):
 * Plymouth now uses the framebuffer renderer as default.
bug: [40715]
Comment 4 Eduard Mai univentionstaff 2016-04-14 16:36:22 CEST
Changes: OK, fix looks and works fine on coach3.
Comment 5 Janek Walkenhorst univentionstaff 2016-04-20 15:42:09 CEST
<http://errata.software-univention.de/ucs/4.1/154.html>