Bug 41685 - AD Connector: Extend syncmode options
AD Connector: Extend syncmode options
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: AD Connector
UCS 4.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1-3-errata
Assigned To: Stefan Gohmann
Felix Botner
:
: 42525 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-28 14:15 CEST by Michael Grandjean
Modified: 2016-09-28 14:40 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Feature Request
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): External feedback, Forked for project
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Grandjean univentionstaff 2016-06-28 14:15:59 CEST
The S4 connector can have a different "syncmode" (write, read, sync) for every object type it can sync. This means I could do sth. like this:

connector/s4/mapping/container/syncmode: sync
connector/s4/mapping/user/syncmode: write
connector/s4/mapping/computer/syncmode: read

The AD connector is much more limited in this case, as it checks only two variables, a global one and one especially for computer objects:

connector/ad/mapping/syncmode
connector/ad/mapping/computer/syncmode

We should extend the feature set of the AD connector to the feature set of the S4 Connector. The code exists in the AD connector mapping, but it always checks "connector/ad/mapping/syncmode" for each and every object type (except computer objects), instead of an object type specific UCRV.
Comment 1 Stefan Gohmann univentionstaff 2016-09-13 11:55:55 CEST
UCS 4.1-3: r72533
UCS 4.2: r72534
YAML: r72535

The following UCR variables have been added:
   - connector/ad/mapping/user/syncmode
   - connector/ad/mapping/group/syncmode
   - connector/ad/mapping/container/syncmode
   - connector/ad/mapping/ou/syncmode

Not yet tested.
Comment 2 Stefan Gohmann univentionstaff 2016-09-13 13:46:55 CEST
(In reply to Stefan Gohmann from comment #1)
> UCS 4.1-3: r72533
> UCS 4.2: r72534
> YAML: r72535
> 
> The following UCR variables have been added:
>    - connector/ad/mapping/user/syncmode
>    - connector/ad/mapping/group/syncmode
>    - connector/ad/mapping/container/syncmode
>    - connector/ad/mapping/ou/syncmode
> 
> Not yet tested.

My tests were successful.
Comment 3 Felix Botner univentionstaff 2016-09-14 11:33:11 CEST
syncmode sync, read, write, none tested with
 * ou (connector/ad/mapping/ou/syncmode) - OK
 * container (connector/ad/mapping/container/syncmode) - OK
 * group (connector/ad/mapping/group/syncmode) - OK
 * users (connector/ad/mapping/user/syncmode) - OK


OK - merged to 4.2-0
OK - yaml
Comment 4 Janek Walkenhorst univentionstaff 2016-09-14 15:38:59 CEST
<http://errata.software-univention.de/ucs/4.1/267.html>
Comment 5 Arvid Requate univentionstaff 2016-09-28 14:40:57 CEST
*** Bug 42525 has been marked as a duplicate of this bug. ***