Bug 42120 - Use Tombstone Reanimation
Use Tombstone Reanimation
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: S4 Connector
UCS 4.2
Other Linux
: P5 enhancement (vote)
: UCS 4.1-4
Assigned To: Arvid Requate
Stefan Gohmann
:
: 42115 (view as bug list)
Depends on: 40661 42624
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-25 10:37 CEST by Stefan Gohmann
Modified: 2017-03-02 13:22 CET (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 2: Improvement: Would be a product improvement
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.023
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2016-08-25 10:37:42 CEST
From https://download.samba.org/pub/samba/rc/samba-4.5.0rc2.WHATSNEW.txt

> Tombstone Reanimation
> ---------------------
> 
> Samba now supports tombstone reanimation, a feature in the AD DC
> allowing tombstones, that is objects which have been deleted, to be
> restored with the original SID and GUID still in place.

We should check if we could use this to solve the re-creation of user objects. See for example Bug #41864 and Ticket #2016082321000589
Comment 1 Arvid Requate univentionstaff 2016-10-31 20:06:03 CET
The feature has been implemented:

===============================================================================
28.09.2016 04:53:49,439 LDAP        (PROCESS): __sync_file_from_ucs: Object with entryUUID 5d2f57d2-1972-1036-92d5-5706ad14fd9e has been removed before but became visible again.
[...]

28.09.2016 04:53:49,480 LDAP        (PROCESS): sync_from_ucs: reanimating conflicting object: cn=schueler4\0ADEL:868e31b2-c07b-430e-b26f-1b9181495639,CN=Deleted Objects,DC=ar41i2,DC=local
28.09.2016 04:53:49,499 LDAP        (INFO   ): sync_from_ucs: sync object: cn=schueler4,cn=schueler,cn=users,ou=school2,DC=ar41i2,DC=local
28.09.2016 04:53:49,499 LDAP        (PROCESS): sync from ucs: [          user] [       add] cn=schueler4,cn=schueler,cn=users,ou=school2,DC=ar41i2,DC=local
===============================================================================

Changelog entry added.
Comment 2 Stefan Gohmann univentionstaff 2016-11-03 10:22:19 CET
Tests: OK, I can remove and re-add a student from one school. The old tobstone object is re-used.

Changelog: OK

UCS 4.2 merge: OK

Code review: OK
Comment 3 Arvid Requate univentionstaff 2016-11-03 20:49:34 CET
*** Bug 42115 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Gohmann univentionstaff 2016-11-08 13:26:35 CET
UCS 4.1-4 has been released:
 https://docs.software-univention.de/release-notes-4.1-4-en.html
 https://docs.software-univention.de/release-notes-4.1-4-de.html

If this error occurs again, please use "Clone This Bug".