Bug 40661 - Samba 4.6 Preview Build for UCS 4.2
Samba 4.6 Preview Build for UCS 4.2
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 4.2
Other Linux
: P5 enhancement (vote)
: UCS 4.2
Assigned To: Arvid Requate
Stefan Gohmann
: interim-1
: 42242 (view as bug list)
Depends on: 42123 42624
Blocks: 42045 42120
  Show dependency treegraph
 
Reported: 2016-02-15 16:55 CET by Stefan Gohmann
Modified: 2017-04-04 18:29 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Feature Request
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2016-02-15 16:55:07 CET
Please build the Samba 4.4 release and release these packages as experimental packages. I guess a samba-experimental scope which can be released as unmaintained.
Comment 1 Stefan Gohmann univentionstaff 2016-08-19 07:14:49 CEST
Samba 4.5 will be part of UCS 4.2.
Comment 2 Arvid Requate univentionstaff 2016-09-05 09:42:34 CEST
*** Bug 42242 has been marked as a duplicate of this bug. ***
Comment 3 Arvid Requate univentionstaff 2016-10-31 17:41:32 CET
We've already built Samba 4.5.1 for UCS 4.1-4 (Bug #42624).

*** This bug has been marked as a duplicate of bug 42624 ***
Comment 4 Stefan Gohmann univentionstaff 2017-01-05 15:24:51 CET
OK, we should switch to Samba 4.6.
Comment 5 Arvid Requate univentionstaff 2017-01-31 13:38:19 CET
I've updated the UCS 4.1 samba source package to 4.6.0~rc2 and adjusted the UCS patches.

Installation, provision, udm user add, windows client join/logon worked.
Changelog adjusted.
Comment 6 Stefan Gohmann univentionstaff 2017-02-03 06:26:09 CET
Update + Installation: OK

DC basics (GPO, DRS, Kerberos, ...): OK

Memberserver: OK

Changelog: OK

My tests were successful. Not every test in Jenkins is green for Samba but that will be another task.
Comment 7 Stefan Gohmann univentionstaff 2017-04-04 18:29:14 CEST
UCS 4.2 has been released:
 https://docs.software-univention.de/release-notes-4.2-0-en.html
 https://docs.software-univention.de/release-notes-4.2-0-de.html

If this error occurs again, please use "Clone This Bug".