Bug 42891 - libxslt: Multiple issues (ES 3.2)
libxslt: Multiple issues (ES 3.2)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-ES
Assigned To: Arvid Requate
Janek Walkenhorst
:
Depends on: 41561
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-08 19:14 CET by Arvid Requate
Modified: 2017-09-28 17:17 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Security
Max CVSS v3 score: 8.8 (CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
requate: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2016-11-08 19:14:00 CET
+++ This bug was initially created as a clone of Bug #41561 +++

The following issues have been fixed in the upstream Debian (Wheezy) package version 1.1.26-14.1+deb7u1:

* The xsltStylePreCompute function in preproc.c in libxslt 1.1.28 does not check if the parent nonfusion" issue. (CVE-2015-7995)

* numbers.c in libxslt before 1.1.29, as used in Google Chrome before 51.0.2704.63, mishandles nssibly have unspecified other impact via a crafted document. (CVE-2016-1683)

* numbers.c in libxslt before 1.1.29, as used in Google Chrome before 51.0.2704.63, mishandles t or resource consumption) or possibly have unspecified other impact via a crafted document. (CVE-2016-1684)
Comment 1 Arvid Requate univentionstaff 2016-11-08 19:14:24 CET
Upstream Debian (Wheezy) package version 1.1.26-14.1+deb7u2 fixes the following issue:

* heap overread can cause arbitrary code execution or denial of service (CVE-2016-4738)
Comment 2 Arvid Requate univentionstaff 2017-04-19 10:13:27 CEST
Upstream Debian (Wheezy) package version 1.1.26-14.1+deb7u3 fixes the following issue:

* integer overflow in libxslt (CVE-2017-5029)
Comment 3 Arvid Requate univentionstaff 2017-04-19 10:39:17 CEST
Package rebuilt with backported patches.

Advisory checked in into my extsec3.2 git repo.
Comment 4 Janek Walkenhorst univentionstaff 2017-05-26 11:00:18 CEST
Tests (amd64): OK
Comment 5 Janek Walkenhorst univentionstaff 2017-05-31 14:20:06 CEST
Advisory: OK
Comment 6 Arvid Requate univentionstaff 2017-09-18 13:16:49 CEST
The advisory is here: https://git.knut.univention.de/arequate/extsec3.2
Comment 7 Philipp Hahn univentionstaff 2017-09-28 17:17:55 CEST
<http://errata.software-univention.de/ucs/3.2/456.html>