Bug 43930 - Uploaded SVGs not visible
Uploaded SVGs not visible
Status: CLOSED WORKSFORME
Product: UCS
Classification: Unclassified
Component: UMC - Domain management (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2
Assigned To: Dirk Wiesenthal
Stefan Gohmann
: interim-4
: 43780 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-17 15:03 CET by Erik Damrose
Modified: 2017-04-04 18:28 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2017-03-17 15:03:58 CET
If i upload a .svg image to umc, it is not displayed in its widget, for example for a udm settings/portal background entry.
Comment 1 Florian Best univentionstaff 2017-03-17 16:15:12 CET
Does it work with JPG?
Comment 2 Dirk Wiesenthal univentionstaff 2017-03-22 13:19:29 CET
I think this has been done when working on the logo bug for the Portal
Comment 3 Florian Best univentionstaff 2017-03-22 13:26:56 CET
On my portal the owncloud admin manual image is not shown.
Comment 4 Dirk Wiesenthal univentionstaff 2017-03-22 13:40:47 CET
From my understanding, the bug was that when managing settings/portal (via UMC-UDM) the widget for the background image does not show anything.

You are describing something else:
  ucs/web/overview/entries/admin/owncloud-admindoc/icon='/owncloud/core/img/favicon.png'

This results in no icon to be displayed, because the Icon is not in the filesystem at
  /var/www/owncloud/core/img/favicon.png

Instead it is somewhere inside the Docker container. It is not even be accessible via
  wget localhost/owncloud/core/img/favicon.png

So I do not know what is "correct" here. The ownCloud App should probably change the UCR variable. But should it also put the image at this place in the join script (which is where the UCRVs are set)?

Or do we have to dig deep in the container?

Anyway, I think this is a different bug.
Comment 5 Daniel Tröder univentionstaff 2017-03-22 14:38:59 CET
UCS@school installs SVGs as icons via "udm settings/portal_entry" and deletes all old UCS@school-overview-UCRVs.

The widget in the portal does not show any icon. In the HTML I see:
------------------------------------------------------------------
<div class="appIcon umcGalleryIcon umcPortal-abs-teacherconsole.png"></div>
------------------------------------------------------------------
Which is weird, because there is no such file.

I did find however /usr/share/univention-portal/icons/entries/teacherconsole.png
Which is stranger still, as the file doesn't belong to any package and is located in /usr/share/...
/usr/share/univention-portal/icons/entries belongs to univention-portal, but its content doesn't. Please use /var for dynamically generated files.

Furthermore there is a line in the console:
------------------------------------------------------------------
.svg Failed to load resource: the server responded with a status of 404 (Not Found)
------------------------------------------------------------------
Comment 6 Alexander Kläser univentionstaff 2017-03-23 11:20:23 CET
I have adjusted some code via Bug 43670, AFAIS, all icons should be displayed properly now. The paths to the icons where incorrect. As we are caching images/css files now, please make sure to delete your browsers cache before checking whether you still experience problems (in Chrome/Chromium, it is possible to check "disable caching" via the developer console in the network tab).
Comment 7 Dirk Wiesenthal univentionstaff 2017-03-23 12:10:11 CET
*** Bug 43780 has been marked as a duplicate of this bug. ***
Comment 8 Stefan Gohmann univentionstaff 2017-03-23 16:00:34 CET
OK, looks good. I can upload SVG files for the background and for the portal entries.

I've created Bug #44047 to allow a PNG or JPG upload.
Comment 9 Stefan Gohmann univentionstaff 2017-04-04 18:28:34 CEST
UCS 4.2 has been released:
 https://docs.software-univention.de/release-notes-4.2-0-en.html
 https://docs.software-univention.de/release-notes-4.2-0-de.html

If this error occurs again, please use "Clone This Bug".