Bug 43670 - Show icons in portal
Show icons in portal
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Portal
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2
Assigned To: Alexander Kläser
Stefan Gohmann
: interim-3
: 43865 (view as bug list)
Depends on: 42175
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-28 12:29 CET by Dirk Wiesenthal
Modified: 2017-04-04 18:28 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
quoting error (46.94 KB, image/png)
2017-03-15 10:18 CET, Erik Damrose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2017-02-28 12:29:34 CET
Icons are not shown in Univention Portal.

/usr/share/univention-portal/portal.json

contains
"entries": [{..., "logo_name": "/portal/icons/entries/myentry.svg"}]

And the icon actually is in
  http://10.200.4.50/univention/portal/icons/entries/myentry.svg

But the Gallery currently creates links to dijit/themes/

We need to adjust the getIconClass method (or similar).

+++ This bug was initially created as a clone of Bug #42175 +++

There should be a graphical user interface to add links to the new portal site.
Comment 1 Alexander Kläser univentionstaff 2017-03-14 22:06:16 CET
I fixed the JavaScript part of the icons and adjusted the styling. I also added French translations with ­ hyphens to allow better word wrapping in the description of the UMC tile (otherwise there was a line too much).

univention-portal (1.0.8-6):
r77717 | Bug #43670: Adjust icons + French labels + styling
Comment 2 Erik Damrose univentionstaff 2017-03-15 10:18:46 CET
Created attachment 8541 [details]
quoting error

reopen: you introduced a quoting error in the joinscript. The overview labels are now wrong, see screenshot
Comment 3 Alexander Kläser univentionstaff 2017-03-15 10:51:50 CET
(In reply to Erik Damrose from comment #2)
> Created attachment 8541 [details]
> quoting error
> 
> reopen: you introduced a quoting error in the joinscript. The overview
> labels are now wrong, see screenshot

Oops, true. Fixed.

univention-portal (1.0.8-7):
r77724 | Bug #43670: adjust quoting of labels
Comment 4 Florian Best univentionstaff 2017-03-15 11:08:04 CET
*** Bug 43865 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Gohmann univentionstaff 2017-03-17 10:51:13 CET
OK, the icons are now available. We still have a general problem with icons in our App Center: Bug #43866.

I've added the bug number to an existing portal changelog entry: r77867
Comment 6 Alexander Kläser univentionstaff 2017-03-23 09:00:13 CET
univention-appcenter ships the apps.json file in which the icon path is still broken.
Comment 7 Alexander Kläser univentionstaff 2017-03-23 09:55:03 CET
Fixed. I moved the apps.json UCR template from univention-appcenter to univention-portal, as it makes more sense here as JavaScript code relies on its existance.

@QA: A simple package update should work just fine as I declared in debian/control that univention-portal replaces files from univention-appcenter.

univention-portal (1.0.10-2):
r78176 | Bug #43670: Move UCR template apps.json into this package+fix icons URL

univention-appcenter (6.0.3-23):
r78175 | Bug #43670: Move app.json UCR template to univention-portal
Comment 8 Stefan Gohmann univentionstaff 2017-03-23 16:02:12 CET
OK, the icons are now visible on slave and member.
Comment 9 Stefan Gohmann univentionstaff 2017-04-04 18:28:51 CEST
UCS 4.2 has been released:
 https://docs.software-univention.de/release-notes-4.2-0-en.html
 https://docs.software-univention.de/release-notes-4.2-0-de.html

If this error occurs again, please use "Clone This Bug".