Bug 44194 - Grid rendering artifacts in UMC network settings
Grid rendering artifacts in UMC network settings
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Network settings
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Jürn Brodersen
Erik Damrose
:
: 44691 45125 (view as bug list)
Depends on: 44431
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-31 15:50 CEST by Erik Damrose
Modified: 2017-08-02 16:16 CEST (History)
6 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 2: Improvement: Would be a product improvement
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.069
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): External feedback, Usability
Max CVSS v3 score:


Attachments
grid after adding a bridge (22.82 KB, image/png)
2017-03-31 15:50 CEST, Erik Damrose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2017-03-31 15:50:37 CEST
Created attachment 8733 [details]
grid after adding a bridge

After adding a network bridge, the grid redraw is not correct, see screenshot
Comment 1 Erik Damrose univentionstaff 2017-03-31 15:55:14 CEST
I even displays this wrong after logging out and back into umc!
Comment 2 Erik Damrose univentionstaff 2017-03-31 15:58:58 CEST
The grid does not expand or show a scrollbar if more than 2 entries are present - network settings become basically unuseable with more than 2 interfaces
Comment 3 Florian Best univentionstaff 2017-03-31 16:02:05 CEST
This has to do with disabling items.
Comment 4 Erik Damrose univentionstaff 2017-05-04 14:38:04 CEST
External bug report:
https://help.univention.com/t/bug-umc-netzwerk-einstellungen/5652
Comment 5 Florian Best univentionstaff 2017-05-24 15:40:55 CEST
*** Bug 44691 has been marked as a duplicate of this bug. ***
Comment 6 Florian Best univentionstaff 2017-07-20 11:01:35 CEST
@Jürn: Please set a target milestone if you are going to fix things.
Comment 7 Jürn Brodersen univentionstaff 2017-07-20 11:26:48 CEST
r81279: YAML
r81277: Fix InterfaceGrid size for more than two entries
Package: univention-system-setup
Version: 10.0.10-36A~4.2.0.201707201114
Branch: ucs_4.2-0
Scope: errata4.2-1
Comment 8 Florian Best univentionstaff 2017-07-20 11:30:12 CEST
Can't this be generically fixed for all grids? Because the UDM grids are also affected in some situations.
Comment 9 Erik Damrose univentionstaff 2017-07-21 14:15:07 CEST
Reopen: As discussed, works for most interface types now, but bridges are still displaying incorrectly.
Comment 10 Jürn Brodersen univentionstaff 2017-07-24 10:53:57 CEST
(In reply to Erik Damrose from comment #9)
> Reopen: As discussed, works for most interface types now, but bridges are
> still displaying incorrectly.

should be fixed with bug 44431
Comment 11 Erik Damrose univentionstaff 2017-07-24 15:19:02 CEST
Yes, works fine now. Thanks for adding bug #44431 to the yaml file.

Verified
Comment 12 Florian Best univentionstaff 2017-07-25 17:34:07 CEST
(In reply to Erik Damrose from comment #11)
> Yes, works fine now. Thanks for adding bug #44431 to the yaml file.
Why is it added? Is it a dependency?

> Verified
I adjusted the YAML description: r81370
Comment 13 Erik Damrose univentionstaff 2017-07-26 14:39:32 CEST
<http://errata.software-univention.de/ucs/4.2/109.html>
Comment 14 Florian Best univentionstaff 2017-08-02 16:16:06 CEST
*** Bug 45125 has been marked as a duplicate of this bug. ***