Bug 44431 - UMC DNS: Zone entry in grid looks broken after adding a TXT record or forward zone
UMC DNS: Zone entry in grid looks broken after adding a TXT record or forward...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - DNS
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Jürn Brodersen
Florian Best
:
: 44651 44746 (view as bug list)
Depends on:
Blocks: 44194
  Show dependency treegraph
 
Reported: 2017-04-21 11:53 CEST by Michael Grandjean
Modified: 2017-07-26 14:39 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 1: Cosmetic issue or missing function but workaround exists
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.034
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Ticket number:
Bug group (optional): Design, External feedback, Usability
Max CVSS v3 score:


Attachments
Screenshot of DNS module (89.85 KB, image/png)
2017-04-21 11:53 CEST, Michael Grandjean
Details
Screenshot of DNS module with reversed sorting (97.09 KB, image/png)
2017-04-21 12:00 CEST, Michael Grandjean
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Grandjean univentionstaff 2017-04-21 11:53:48 CEST
Created attachment 8792 [details]
Screenshot of DNS module

I added a TXT record at the Forward Zone and afterwards the entry of this forward zone in the grid is not displayed completely (see screenshot).
It looks like the height is doubled (because of the additional entry), but only the original height is displayed.

udm dns/forward_zone modify \
  --dn zoneName="$(ucr get domainname)",cn=dns,"$(ucr get ldap/base)" \
  --set txt="kdiscover https://webapp.intranet.example.org/"
Comment 1 Michael Grandjean univentionstaff 2017-04-21 12:00:18 CEST
Created attachment 8793 [details]
Screenshot of DNS module with reversed sorting

If I reverse the sorting, it gets even worse (see screenshot).

I tested with Firefox 53.0 and Google Chrome 58.0
Comment 2 Florian Best univentionstaff 2017-05-22 16:39:02 CEST
*** Bug 44651 has been marked as a duplicate of this bug. ***
Comment 3 Erik Damrose univentionstaff 2017-06-07 12:39:44 CEST
*** Bug 44746 has been marked as a duplicate of this bug. ***
Comment 4 Jürn Brodersen univentionstaff 2017-07-20 18:13:04 CEST
I didn't expected two dimensional arrays as values. Rows with varying height don't look very good. We should try and limit all data to one line.

Maybe we can show additional information as a popup instead?
Comment 5 Florian Best univentionstaff 2017-07-21 11:17:18 CEST
(In reply to Jürn Brodersen from comment #4)
> I didn't expected two dimensional arrays as values. Rows with varying height
> don't look very good. We should try and limit all data to one line.
> 
> Maybe we can show additional information as a popup instead?
I don't think so. Multi rows should also be supported. What if third party UMC modules have them? This shouldn't be fixed with a workaround.
Comment 6 Florian Best univentionstaff 2017-07-21 11:18:01 CEST
Also the information have been added on purpose to improve the whole usability of the DNS/DHCP modules.
Comment 7 Florian Best univentionstaff 2017-07-21 13:19:09 CEST
As discussed, please put these values into a <div> or <span> container with the following CSS properties:
line-height: 1.25; display: block; text-overflow: ellipsis;

You need to modify height to "auto" and min-height to "48px" in .umc .umcGrid .dgrid .dgrid-row.
Comment 8 Jürn Brodersen univentionstaff 2017-07-24 10:52:51 CEST
I was able to use the already existing cell div from the grid. That way only the css needed some changes.

r81326/81327: yaml
r81325: fix multiline entries in grid
Package: univention-web
Version: 1.0.42-24A~4.2.0.201707241035
Branch: ucs_4.2-0
Scope: errata4.2-1
Comment 9 Jürn Brodersen univentionstaff 2017-07-24 11:24:48 CEST
Forgot to test IE... The ellipsis don't work in IE, sorry
Comment 10 Jürn Brodersen univentionstaff 2017-07-24 14:01:11 CEST
(In reply to Jürn Brodersen from comment #9)
> Forgot to test IE... The ellipsis don't work in IE, sorry

This was broken in firefox, too.

I fixed it by adding a height to ".dgrid-row-table" that removed the need for line-height because now vertical-allign works (the tables height was set indirectly through line-height).

Note1: height for tables is interpreted as min-height (https://www.w3.org/TR/CSS21/tables.html#height-layout)

Note2: In IE no ellipses are shown after the first <br> (https://stackoverflow.com/questions/31022769/text-overflowellipsis-does-not-work-with-br-in-ie)

r81339: fix ellipses in grid
Package: univention-web
Version: 1.0.42-25A~4.2.0.201707241347
Branch: ucs_4.2-0
Scope: errata4.2-1
Comment 11 Florian Best univentionstaff 2017-07-25 17:42:10 CEST
Okay, this looks very nice now!
I also had a look at UVMM and various UCS@school modules.

OK: YAML (adjusted in r81371)