Bug 44493 - IOError: [Errno 2] Datei oder Verzeichnis nicht gefunden: u'/var/lib/docker/overlay/.../merged/etc/machine.secret'
IOError: [Errno 2] Datei oder Verzeichnis nicht gefunden: u'/var/lib/docker/o...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-0-errata
Assigned To: Felix Botner
Dirk Wiesenthal
:
: 43278 (view as bug list)
Depends on: 44527 44554
Blocks: 46912 44557
  Show dependency treegraph
 
Reported: 2017-04-27 17:53 CEST by Felix Botner
Modified: 2018-04-27 18:14 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 5: Major Usability: Impairs usability in key scenarios
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 4: A User would return the product
User Pain: 0.229
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017041221001201, 2017050121000436, 2017043021000295, 2017050121000427, 2017050321000236, 2017043021000302, 2017050521000643
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2017-04-27 17:53:32 CEST
Traceback(727ae865e1a48ce4e294abf0145ad34f):
Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 249, in execute
    function.__func__(self, request, *args, **kwargs)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 192, in _response
    return function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 440, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 286, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/mixins.py", line 149, in progress
    ret = progress_obj.poll()
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 309, in _thread
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 192, in _response
    return function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 440, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 286, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/appcenter/__init__.py", line 375, in invoke_docker
    result['success'] = action.call(app=app, username=self.username, password=self.password, **kwargs)
  File "%PY2.7%/univention/appcenter/actions/__init__.py", line 227, in call
    return obj.call_with_namespace(namespace)
  File "%PY2.7%/univention/appcenter/actions/__init__.py", line 233, in call_with_namespace
    result = self.main(namespace)
  File "%PY2.7%/univention/appcenter/actions/install.py", line 70, in main
    return self.do_it(args)
  File "%PY2.7%/univention/appcenter/actions/install_base.py", line 110, in do_it
    self._do_it(app, args)
  File "%PY2.7%/univention/appcenter/actions/docker_install.py", line 67, in _do_it
    ret = super(Install, self)._do_it(app, args)
  File "%PY2.7%/univention/appcenter/actions/install.py", line 87, in _do_it
    if self._install_app(app, args):
  File "%PY2.7%/univention/appcenter/actions/docker_install.py", line 61, in _install_app
    self._start_docker_image(app, hostdn, password, args)
  File "%PY2.7%/univention/appcenter/actions/docker_base.py", line 205, in _start_docker_image
    with open(docker.path('/etc/machine.secret'), 'w+b') as f:
IOError: [Errno 2] Datei oder Verzeichnis nicht gefunden: u'/var/lib/docker/overlay/50016a54f75d9343b43813ce454a9ab4b77409f3d2aacbcae3f3e549c1b66986/merged/etc/machine.secret'
Die Ausführung des Kommandos appcenter/docker/progress ist fehlgeschlagen:
Comment 1 Felix Botner univentionstaff 2017-05-04 13:45:58 CEST
Added a test in _start_docker_image to check whether the container is really started. If not, docker logs, docker inspect and dockerd logs are collected and a new error exception (AppCenterErrorContainerStart -> AppCenterError) is thrown (with the log information).

The appcenter error handling catches this exceptions and sets the appropriate status code, the exceptions is then re-raised.

The UMC backend then also catches AppCenterError and throws a  umcm.UMC_Error with a couple of special result parameters to let the frontend know, that we want a (non-traceback) feedback error dialog (Bug #44527).

All this won't help to fix the cause of the problem, but we may get more information to find the issue.

univention-appcenter: r79047
univention-appcenter.yaml
Comment 2 Florian Best univentionstaff 2017-05-05 15:07:18 CEST
Reported 4 times again:
Version: 4.2-0 errata4 (Lesum)
Comment 4 Florian Best univentionstaff 2017-05-05 15:20:02 CEST
Version: 4.2-0 errata4 (Lesum)
Comment 5 Florian Best univentionstaff 2017-05-08 14:31:58 CEST
Reported again, 4.2-0 errata10 (Lesum)
Comment 6 Dirk Wiesenthal univentionstaff 2017-05-10 02:00:55 CEST
OK, works
Comment 7 Janek Walkenhorst univentionstaff 2017-05-10 15:17:06 CEST
<http://errata.software-univention.de/ucs/4.2/14.html>
Comment 8 Felix Botner univentionstaff 2017-05-17 15:23:51 CEST
*** Bug 43278 has been marked as a duplicate of this bug. ***