Bug 44526 - Favorites do not work
Favorites do not work
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Johannes Keiser
Florian Best
:
: 44233 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-03 10:31 CEST by Philipp Hahn
Modified: 2017-10-18 13:22 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 5: Will affect all installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.229
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
keiser: Patch_Available+


Attachments
patch (2.80 KB, patch)
2017-07-19 15:34 CEST, Johannes Keiser
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2017-05-03 10:31:03 CEST
I noticed that in the technical training 2017-04-28 but also in my VM:
- On the favorites tab selecting 'Remove from favorites' does not remove the favorite immediately
- Same for adding a favorite by selecting "Add for favorites" - the badge is not added immediately
Only after switching between tabs the new/old favorites shown/removed.
Comment 1 Johannes Keiser univentionstaff 2017-07-19 15:34:01 CEST
Created attachment 9045 [details]
patch

I guess this happened with Bug #42291 and a change in the behavior of
dojo/store/Memory but i did not fully trace it back.

One easy fix is to update the search after adding/removing favorites

The css transition that hides/shows the favorites category was also broken
Comment 2 Johannes Keiser univentionstaff 2017-10-13 14:35:22 CEST
> Created attachment 9045 [details]
> patch

Applied patch:

univention-management-console (9.0.80-77):
7e39cf1 Bug #44526: Fix adding/removing modules from favorites not updating immediately

univention-web (1.0.42-50):
0896cfe Bug #44526: Fix CSS transition for showing/hiding Favorites category

bb13845 Bug #44526: YAML(In reply to Johannes Keiser from comment #1)
Comment 3 Florian Best univentionstaff 2017-10-16 15:25:26 CEST
OK: removing favorites is working again.
OK: YAML
Comment 5 Florian Best univentionstaff 2017-10-18 13:22:23 CEST
*** Bug 44233 has been marked as a duplicate of this bug. ***