Bug 44910 - system-activation doesn't show license request form when license request failed in system-setup
system-activation doesn't show license request form when license request fail...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: System setup
UCS 4.1
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Eduard Mai
Erik Damrose
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 13:41 CEST by Eduard Mai
Modified: 2017-07-26 14:39 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 2: A Pain – users won’t like this once they notice it
User Pain: 0.069
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number: Ticket#2017060821000511
Bug group (optional): Appliance, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduard Mai univentionstaff 2017-06-30 13:41:03 CEST
Steps to reproduce:
Install system-activation and enable it or use an App Appliance image. Make sure there is no route to license.univention.de. During system-setup enter an email address. Complete the system-setup.

What you should see:
System-activation shows the license upload form, step 2 of the activation process.

This is mainly a usability problem. Showing step 2 implies, that the license request was successful. Entering step 1 is only possible with the link provided in the explanation text and might be overseen or not taken into account, assuming from the user perspective that step 2 is really only shown when the license mail was sent.
Comment 1 Eduard Mai univentionstaff 2017-06-30 14:33:41 CEST
The issue is slightly different in UCS 4.2. System-activation will enter step 1, regardless of whether a license was requested successfully during system-setup.
Comment 2 Eduard Mai univentionstaff 2017-07-05 13:48:43 CEST
r80701: Fix check for successfully requested license and display explanation in case the license server didn't send a license because of an internal error.

Package: univention-system-activation
Version: 2.0.2-10
svn: dev/branches/ucs-4.2/ucs-4.2-1/base/univention-system-activation
Scope: errata4.2-1
Comment 3 Florian Best univentionstaff 2017-07-05 13:56:24 CEST
Missing YAML!
Comment 4 Eduard Mai univentionstaff 2017-07-06 15:59:14 CEST
Adjusted yaml in r80866.
Comment 5 Erik Damrose univentionstaff 2017-07-19 10:41:35 CEST
OK: mailaddress in system-setup + internet connection: system activation starts on second page
OK: mailaddress in system-setup + no internet connection: system activation starts on first page
OK: No mailaddress in system-setup: system activation starts on first page
OK: yaml
Verified
Comment 6 Erik Damrose univentionstaff 2017-07-26 14:39:37 CEST
<http://errata.software-univention.de/ucs/4.2/107.html>