Bug 44995 - App appliance for UCS 4.2 can't join
App appliance for UCS 4.2 can't join
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-1-errata
Assigned To: Jürn Brodersen
Erik Damrose
:
: 44577 44850 45015 (view as bug list)
Depends on:
Blocks: 44513
  Show dependency treegraph
 
Reported: 2017-07-13 11:17 CEST by Jürn Brodersen
Modified: 2017-08-15 12:00 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Appliance
Max CVSS v3 score:
brodersen: Patch_Available+


Attachments
proposed patch (2.03 KB, patch)
2017-07-13 11:17 CEST, Jürn Brodersen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jürn Brodersen univentionstaff 2017-07-13 11:17:22 CEST
Created attachment 9024 [details]
proposed patch

Before an appliance can join it checks if the master has a valid license.
That currently fails because the self signed ssl certificate from the master is not yet trusted by the appliance.

I changed that so univention-ssh is used instead of directly using umc-command. We still need umc-command on the master because that is afaik the only way to get that information without a root account.
Comment 1 Alexander Kläser univentionstaff 2017-07-13 11:27:38 CEST
You could also perform directly an LDAP search from the host to the master to ensure that the license key ID is set:
univention-ldapsearch -LLL objectClass=univentionLicense  univentionLicenseKeyID
Comment 2 Jürn Brodersen univentionstaff 2017-07-13 17:26:47 CEST
r81156: fix license check in appliance setup
Version: 10.0.10-33A~4.2.0.201707131653
Branch: ucs_4.2-0
Scope: errata4.2-1

r81159: YAML
Comment 3 Florian Best univentionstaff 2017-07-13 17:32:27 CEST
Please fix the error message.
It should contain a human readable description of the problem.
Comment 4 Jürn Brodersen univentionstaff 2017-07-14 14:13:38 CEST
r81175: Improved error message on license check errors
Package: univention-system-setup
Version: 10.0.10-34A~4.2.0.201707141121
Branch: ucs_4.2-0-errata4.2-1
Scope: errata4.2-1
Comment 5 Florian Best univentionstaff 2017-07-17 13:26:22 CEST
*** Bug 45015 has been marked as a duplicate of this bug. ***
Comment 6 Erik Damrose univentionstaff 2017-07-19 14:38:11 CEST
OK: Changed check for valid license on master
OK: join into activated master
OK: Test and warning if joining into not activated master
OK: yaml
Verified
Comment 7 Florian Best univentionstaff 2017-07-20 13:32:59 CEST
*** Bug 42918 has been marked as a duplicate of this bug. ***
Comment 8 Erik Damrose univentionstaff 2017-07-26 14:39:42 CEST
<http://errata.software-univention.de/ucs/4.2/109.html>
Comment 9 Florian Best univentionstaff 2017-08-15 11:56:39 CEST
*** Bug 44850 has been marked as a duplicate of this bug. ***
Comment 10 Florian Best univentionstaff 2017-08-15 12:00:04 CEST
*** Bug 44577 has been marked as a duplicate of this bug. ***