Bug 45185 - dists/ucs420/main list on updates-test differs from apt/ucs_4.2-0/dists
dists/ucs420/main list on updates-test differs from apt/ucs_4.2-0/dists
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Update - Repository administration
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2-errata
Assigned To: Philipp Hahn
Stefan Gohmann
:
Depends on: 43837
Blocks: 41305 42038
  Show dependency treegraph
 
Reported: 2017-08-10 20:03 CEST by Stefan Gohmann
Modified: 2017-09-28 15:56 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 4: Minor Usability: Impairs usability in secondary scenarios
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.114
Enterprise Customer affected?:
School Customer affected?: Yes
ISV affected?:
Ticket number: 2017080921000658
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2017-08-10 20:03:45 CEST
This also happens in net installer environments because the packages are re-created during the repository sync.

Maybe it works after disabling the package recreation:
 ucr repository/mirror/recreate_packages=no
 univention-repository-update net

+++ This bug was initially created as a clone of Bug #43837 +++

Currently I cannot debootstrap a UCS 4.2 image because it considers gcc-4.7-base as required, and gcc4.9-base from jessie/UCS 4.2 conflicts with the UCS 4.0 version of that package. The cause of this issue seem to lie here:


arequate@omar:~$ wget -o /dev/null -O - http://updates-test.software-univention.de/4.2/maintained/4.2-0/dists/ucs420/main/binary-amd64/Packages | grep -A1 "^Package: gcc-4.7-base" 
Package: gcc-4.7-base
Priority: required


arequate@omar:~$ grep -A1 "^Package: gcc-4.7-base" \
  /var/univention/buildsystem2/apt/ucs_4.2-0/dists/ucs420/main/binary-amd64/Packages
Package: gcc-4.7-base
Priority: optional
Comment 1 Philipp Hahn univentionstaff 2017-08-22 15:47:39 CEST
'repository/mirror/recreate_packages=yes' is broken, as `apt-mirror` calls 'apt-ftparchive' internally without any Override file, which is used by Debian (and us) to fix Package Priority distribution wide (the same package can be used in multiple releases, but with different priorities; the override mechanism is used to fix override the Priority as stored inside the .deb header. The files is described at <https://wiki.debian.org/FtpMaster/Override>. Debian ships them in <http://ftp.debian.org/debian/indices/> and they are post-processed (concatenated) before being used internally for UCS. Currently they are not shipped, but stored internally at <svn://billy/dev/branches/ucs-3.2/internal/repo-ng/override/>)

Re-creating the Packages files also breaks Secure-APT: Bug #29434

It would help if our public mirror could be used for PXE installation: Bug #41305
Comment 2 Stefan Gohmann univentionstaff 2017-09-15 20:50:38 CEST
Ok, so I think we should the default of repository/mirror/recreate_packages to no. Maybe, we can also add a note to the documentation?

Anything else we should change at this issue?
Comment 3 Jan Christoph Ebersbach univentionstaff 2017-09-19 15:22:00 CEST
This bug is tagged as an issue for school customers.  How is it related to school customers?
Comment 4 Philipp Hahn univentionstaff 2017-09-20 09:43:56 CEST
0b9bcb0caa..11604e1107

Package: univention-updater
Version: 12.0.11-9A~4.2.0.201709200937
Branch: ucs_4.2-0
Scope: errata4.2-2

1ce67c98da..60d430d207: univention-updater.yaml
Comment 5 Stefan Gohmann univentionstaff 2017-09-27 06:52:14 CEST
(In reply to Jan Christoph Ebersbach from comment #3)
> This bug is tagged as an issue for school customers.  How is it related to
> school customers?

It happened in a school customer environment, see the referenced ticket.
Comment 6 Stefan Gohmann univentionstaff 2017-09-27 06:55:35 CEST
Code review: OK

Tests: OK

YAML: OK
Comment 7 Philipp Hahn univentionstaff 2017-09-28 15:56:44 CEST
<http://errata.software-univention.de/ucs/4.2/189.html>