Bug 46600 - PXE installation broken: Packages overrides not applied - conflicting packages
PXE installation broken: Packages overrides not applied - conflicting packages
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Update - Repository administration
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-3-errata
Assigned To: Philipp Hahn
Stefan Gohmann
:
Depends on: 45185 46167 48424
Blocks: 46366 46420
  Show dependency treegraph
 
Reported: 2018-03-12 13:15 CET by Philipp Hahn
Modified: 2019-02-13 13:27 CET (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.343
Enterprise Customer affected?: Yes
School Customer affected?: Yes
ISV affected?:
Waiting Support: Yes
Ticket number: 2018110721000993
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2018-03-12 13:15:23 CET
Similar to Bug #46167 Debian Overrides must be applied.

PXE installation currently requires a local repository until Bug #41305 is fixed.
The mirroring is done using "apt-mirror" which only mirrors X.Y/[un]maintained/X.Y-Z/$ARCH/, but not the 'dists/' folders.
They are required for the Debian-Installer as they provide an aggregated view of all "*.deb" and "*.udeb" packages.
They are used and parsed by "debootstrap", which selects all Packages with Priority>=standard.
As UCS aggregates multiple Debian-Releases (without the possibility to remove historic packages), this does select conflicting packages:

> libstdc++6:amd64 (6.3-0-18+deb9u1) breaks libsigc++-2.0c2a (<= 2.4.1-1+b1) and is installed

We already disabled it via UCRV repository/mirror/recreate_packages=no in git:639dfdef51d via Bug #5185, but this is not enough as 
 py:univention.updater.mirror.UniventionMirror.update_dists_files() still re-builds the "dists/" hierarchy without considering the overrides.

This breaks as soon as "univention-repository-update" is called the first time, as that one mirrors "UCS-4.[0..2]", which contain the conflicting packages.
It works when the repository is newly created using "univention-repository-create", as that one mirrors the DVD with the correct Packages file and does not add the broken Packages files from previous versions.
Comment 1 Valentin Heidelberger univentionstaff 2018-11-13 16:10:39 CET
Is there a workaround for this?

PXE installation is broken at a customer's site because of this bug. Executing univention-repository-create again does not fix it, because the repo is not "newly created" presumably.
Comment 2 Philipp Hahn univentionstaff 2018-11-13 16:27:38 CET
(In reply to Valentin Heidelberger from comment #1)
> Is there a workaround for this?
> 
> PXE installation is broken at a customer's site because of this bug.
> Executing univention-repository-create again does not fix it, because the
> repo is not "newly created" presumably.

Mirror <https://updates.software-univention.de/4.3/maintained/4.3-2/dists/> manually to <file:///var/lib/univention-repository/mirror/>
Comment 3 Stefan Gohmann univentionstaff 2019-01-29 07:21:47 CET
@Philipp, can this issue be closed as duplicate of Bug #48424?
Comment 4 Philipp Hahn univentionstaff 2019-02-07 09:21:29 CET
(In reply to Stefan Gohmann from comment #3)
> @Philipp, can this issue be closed as duplicate of Bug #48424?

No, Bug #48424 is a DEPENDENCY of this bug:
- your can (theoretically) use "apt-mirror" to mirror distributions other than UCS
- but you strongly should use the patched "apt-mirror" version when you start mirroring the dists/ files as otherwise you may download files multiple times leading to invalid files and/or ENOSPACE errors
- this Bug #46600 is for the massive changes to "univention-updater", Bug #48424 is for small fix to "apt-mirror"


[4.3-3] 3f04f3575f Bug #46600 up: Copyright 2019
[4.3-3] 71a40950ab Bug #46600 up: Merge commit '2176aa2252' into 4.3-3
[4.3-3] b19f6f5c5f Bug #46600 up: changelog
 base/univention-updater/debian/changelog   |  6 ++++++
 doc/errata/staging/univention-updater.yaml | 11 +++++++++++
 2 files changed, 17 insertions(+)

Package: univention-updater
Version: 13.0.1-69A~4.3.0.201902070816
Branch: ucs_4.3-0
Scope: errata4.3-3

[4.3-3] b336f2eed8 Bug #46600: univention-updater 13.0.1-69A~4.3.0.201902070816
 doc/errata/staging/univention-updater.yaml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


[4.4-0] 8c9e60137b Bug #46600: Merge commit '097f5a6b8601feedc19937a47262a6680a234a88' into 4.4-0
[4.4-0] dbaec21ce3 Bug #46600,#29505 up: changelog
 base/univention-updater/debian/changelog | 7 +++++++
 1 file changed, 7 insertions(+)

Package: univention-updater
Version: 14.0.0-10A~4.4.0.201902070917
Branch: ucs_4.4-0
Comment 5 Stefan Gohmann univentionstaff 2019-02-08 08:49:00 CET
See the daily Jenkins tests, for example http://jenkins.knut.univention.de:8080/job/UCS-4.3/job/UCS-4.3-3/job/AutotestUpgrade/lastCompletedBuild/SambaVersion=s4,Systemrolle=backup/testReport/09_updater/22minor/test/


[2019-02-07 20:41:32.672897] (Lese Datenbank ... 111569 Dateien und Verzeichnisse sind derzeit installiert.)
[2019-02-07 20:41:32.678698] Vorbereitung zum Entpacken von .../test-5413-7739_1_amd64.deb ...
[2019-02-07 20:41:32.687418] Entpacken von test-5413-7739 (1) ...
[2019-02-07 20:41:32.752465] test-5413-7739 (1) wird eingerichtet ...
(2019-02-07 20:41:32.840728)   File "/usr/share/univention-updater/univention-updater", line 159
(2019-02-07 20:41:32.840775)     <<<<<<< HEAD
(2019-02-07 20:41:32.840802)      ^
(2019-02-07 20:41:32.840826) IndentationError: expected an indented block
(2019-02-07 20:41:32.842293) **************** Test failed above this line ****************
Comment 6 Philipp Hahn univentionstaff 2019-02-08 08:57:12 CET
(In reply to Stefan Gohmann from comment #5)
> See the daily Jenkins tests, for example
...
> "/usr/share/univention-updater/univention-updater", line 159
> (2019-02-07 20:41:32.840775)     <<<<<<< HEAD

[4.3-3] e7503cdb8e Bug #46600up: Fix merge error
 base/univention-updater/debian/changelog          |  6 ++++++
 base/univention-updater/python/univention-updater | 21 ---------------------
 2 files changed, 6 insertions(+), 21 deletions(-)

Package: univention-updater
Version: 13.0.1-71A~4.3.0.201902080853
Branch: ucs_4.3-0
Scope: errata4.3-3

[4.3-3] d7aae911d2 Bug #46600: univention-updater 13.0.1-71A~4.3.0.201902080853
 doc/errata/staging/univention-updater.yaml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 7 Stefan Gohmann univentionstaff 2019-02-08 20:03:48 CET
Tests: OK - The PXE installation now also works after a repository update.

ucs-test: OK

YAML: OK
Comment 8 Erik Damrose univentionstaff 2019-02-13 13:27:21 CET
<http://errata.software-univention.de/ucs/4.3/422.html>