Bug 45190 - UCS 4.2 net installation
UCS 4.2 net installation
Status: CLOSED FIXED
Product: UCS extended documentation
Classification: Unclassified
Component: Installation
unspecified
Other Linux
: P5 normal (vote)
: UCS 4.3
Assigned To: Philipp Hahn
Richard Ulmer
:
Depends on:
Blocks: 45400
  Show dependency treegraph
 
Reported: 2017-08-11 13:51 CEST by Stefan Gohmann
Modified: 2018-11-08 11:35 CET (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.086
Enterprise Customer affected?: Yes
School Customer affected?: Yes
ISV affected?:
Waiting Support:
Ticket number: 2017080921000658, 2017082121000518, 2018051421000311
Bug group (optional):
Max CVSS v3 score:


Attachments
Patch for the two typos I found (1.49 KB, patch)
2018-04-30 11:01 CEST, Richard Ulmer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2017-08-11 13:51:52 CEST
I was unable to install a UCS 4.2 system via Net Installer. The extended documentation is not up-to-date. I had to replace several UCS 4.1-0 links. In addition, it seems that we changed the preseed file handling in the initrd and we need to add more variables.
Comment 1 Stefan Gohmann univentionstaff 2017-08-18 07:23:37 CEST
It works for me with this example:

#
# This file overwrites /proc/cmdline overwrites preseed.cfg in the InitRamFs!
#
# no live installer
d-i live-installer/enable boolean false

# Package archives
d-i mirror/codename string ucs421
d-i mirror/suite string ucs421
d-i mirror/udeb/suite string ucs421

# Use interfaces with link
d-i netcfg/dhcp_timeout string 60

# Use dummy hostname and domain
d-i netcfg/get_hostname string unassigned-hostname
d-i netcfg/get_domain string unassigned-domain
krb5-config krb5-config/default_realm string UNASSIGNED-REALM
krb5-config krb5-config/kerberos_servers string localhost
krb5-config krb5-config/admin_server string localhost

# Don't create a first user
d-i passwd/make-user boolean false

# LVM
d-i partman-auto/init_automatically_partition select 60some_device_lvm
d-i partman-auto/init_automatically_partition seen false
d-i partman-auto-lvm/new_vg_name string vg_ucs

# Pre-select the standard UCS kernel
d-i base-installer/kernel/image string linux-image-4.9.0-ucs103-amd64
d-i base-installer/includes string less aptitude
d-i base-installer/debootstrap_script string /usr/share/debootstrap/scripts/ucs421

# Only minimal install
d-i apt-setup/use_mirror boolean false
d-i apt-setup/no_mirror boolean true
d-i apt-setup/services-select multiselect none
tasksel tasksel/first multiselect none
d-i pkgsel/include string univention-system-setup-boot univention-management-console-web-server univention-management-console-module-setup univention-kernel-image openssh-server
postfix postfix/main_mailer_type string No configuration
openssh-server ssh/disable_cr_auth boolean false
d-i pkgsel/upgrade select none
popularity-contest popularity-contest/participate boolean false

# Install GRUB in MBR by default on new systems
d-i grub-installer/only_debian boolean true
d-i grub-installer/bootdev string default
grub-pc grub-pc/install_devices multiselect
grub-pc grub-pc/install_devices_empty boolean true

# After installation
d-i finish-install/reboot_in_progress note
d-i cdrom-detect/eject boolean true

#
# The following options are set through the PXE configuration
#
# Delay asking for locale and keyboard layout after pre-seeding via network
#d-i auto-install/enable boolean true
# Only ask for critical questions
#d-i debconf/priority select critical
# Disable graphical installer
#d-i debian-installer/framebuffer boolean false

#
# Select German as default locale and for keyboard layout
#
d-i debian-installer/locale string de_DE.UTF-8
d-i keyboard-configuration/xkb-keymap select de(nodeadkeys)
#d-i keyboard-configuration/modelcode string pc105
d-i ucr/xorg/keyboard/options/XkbModel string pc105
#d-i keyboard-configuration/layoutcode string de
d-i ucr/xorg/keyboard/options/XkbLayout string de
#d-i keyboard-configuration/variantcode string nodeadkeys
d-i ucr/xorg/keyboard/options/XkbVariant string nodeadkeys
#d-i keyboard-configuration/optionscode string
d-i ucr/xorg/keyboard/options/XkbOptions string
#d-i debian-installer/keymap select de-latin1-nodeadkeys

#
# Configure local repository server
#
d-i debian-installer/allow_unauthenticated boolean true
d-i mirror/country string manual
d-i mirror/protocol select http
d-i mirror/http/proxy string
# The host name of the repository server is filled through the PXE configuration generated by UDM
#d-i mirror/http/hostname string ...
d-i mirror/http/directory string /univention-repository/4.2/maintained/4.2-1
d-i mirror/codename string ucs421
d-i mirror/suite string ucs421
d-i mirror/udeb/suite string ucs421

#
# Disable password for user 'root'
#
d-i passwd/root-login boolean true
# Alternative: printf "secret" | mkpasswd -s -m sha-512
d-i passwd/root-password-crypted string $6$WWTYp/iT$L8pM/HEDJdOFLLr34ya1iqvv/nMIXbEpabtpxd3QJzq5aAzDCulOAxMaL6jnlx.QdlMg1BxectWCQW3ga7I4o/

#
# Partition hard disk: Use "lvm" and one big "/" partition
#
# Choices: lvm crypto regular
d-i partman-auto/method string lvm
# Choices: atomic home multi
d-i partman-auto/choose_recipe string atomic
d-i partman-lvm/device_remove_lvm boolean true
d-i partman-md/device_remove_md boolean true
d-i partman-lvm/confirm boolean true
d-i partman-lvm/confirm_nooverwrite boolean true
d-i partman-partitioning/confirm_write_new_label boolean true
d-i partman/choose_partition select finish
d-i partman/confirm boolean true
d-i partman/confirm_nooverwrite boolean true

#
# Disable starting "Univention System Setup Boot"
#
d-i ucr/system/setup/boot/start string false

#
# Univention System Setup profile
#
#univention-system-setup-boot uss/root_password string
#univention-system-setup-boot uss/components string
#univention-system-setup-boot uss/packages_install string
#univention-system-setup-boot uss/packages_remove string
# Choices: domaincontroller_master domaincontroller_backup domaincontroller_slave memberserver base
univention-system-setup-boot uss/server/role string domaincontroller_slave
#univention-system-setup-boot uss/ldap/base string dc=example,dc=com
Comment 2 Philipp Hahn univentionstaff 2018-03-12 15:47:34 CET
[4.3-0] 83a12d0f87 Bug #45747 pxe: Update PXE profile for UCS-4.3

Package: univention-net-installer
Version: 11.0.0-2A~4.3.0.201803121444
Branch: ucs_4.3-0

[4.3-0] cb91c07b49 Bug #45747 pxe: Update PXE profile for UCS-4.3 fox
Comment 3 Philipp Hahn univentionstaff 2018-03-12 15:49:30 CET
QA: I did a successful installation with the profile, but be aware of Bug #46600
Comment 4 Richard Ulmer univentionstaff 2018-04-30 11:00:27 CEST
I had to use a workaround for Bug #45950, but with it the network installation worked and I was able to run "univention-join" successfully.

I have found two typos in the commits. I will append the fix for those in a patch here.

This bug was opened for UCS 4.2, but the changes only update UCS 4.3-0. Is this intended, or should the updates also be applied to UCS 4.2?
Comment 5 Richard Ulmer univentionstaff 2018-04-30 11:01:53 CEST
Created attachment 9519 [details]
Patch for the two typos I found
Comment 6 Philipp Hahn univentionstaff 2018-05-02 10:50:39 CEST
(In reply to Richard Ulmer from comment #4)
> I had to use a workaround for Bug #45950, but with it the network
> installation worked and I was able to run "univention-join" successfully.

OK.

> I have found two typos in the commits. I will append the fix for those in a
> patch here.

Thanks, applied:
[4.3-0] fcf01abaa8 Bug #45190 doc: Fix PXE installation

> This bug was opened for UCS 4.2, but the changes only update UCS 4.3-0. Is
> this intended, or should the updates also be applied to UCS 4.2?

I think UCS-4.3 only is okay: Everybody should use UCS-4.3 by now for new installations and the affected customers already know about this bug and its resolution.
Comment 7 Richard Ulmer univentionstaff 2018-05-02 11:11:31 CEST
OK, everything looks good.
-> VERIFIED
Comment 8 Christina Scheinig univentionstaff 2018-05-17 15:17:29 CEST
We still have customers who are using UCS 4.2. If they have problems, they will have a look in the documentation for their version, and so do we, to reproduce their situation.
Do I have to clone this Bug, for version 4.2.
I think this has to be fixed in the documentation for 4.2, too.
Comment 10 Philipp Hahn univentionstaff 2018-05-18 11:33:01 CEST
As discussed:
[4.3-0] b4b23a856f Bug #45190 doc: Document priority=critical
 doc/extended-docs/installation-4.3.xml | 13 +++++++------
    There is no level "important"; change to "high".
    
    Reference the list of recommended "additional options" instead of
    recommending only "piority=critical".
    
    Fix spelling of "therefore".
    
    IPAPPEND is set by "pxelinux", so it's not DHCP.
    
    Lower case "additional start options" to be in sync with UDMs writing.
Comment 11 Philipp Hahn univentionstaff 2018-05-18 11:39:43 CEST
One more:
[4.3-0] 15c8f5baf2 Bug #45190 doc: Document priority=critical 3
 doc/extended-docs/installation-4.3.xml | 2 +-
    <xref/> does not work for <callouts>, use <link>
Comment 12 Philipp Hahn univentionstaff 2018-05-18 11:55:27 CEST
Typo fix
[4.3-0] a1529474ec Bug #45190 doc: Document priority=critical 4
 doc/extended-docs/installation-4.3.xml | 2 +-
Comment 13 Philipp Hahn univentionstaff 2018-05-18 13:40:17 CEST
(In reply to Christina Scheinig from comment #8)
> We still have customers who are using UCS 4.2. If they have problems, they
> will have a look in the documentation for their version, and so do we, to
> reproduce their situation.
> Do I have to clone this Bug, for version 4.2.
> I think this has to be fixed in the documentation for 4.2, too.

The changes have been merged from the UCS-4.3-0 to the UCS-4.2-4 documentation:
[4.2-4] 55b56777f4 Bug #45190 doc: Document priority=critical
 doc/extended-docs/installation-4.2.xml | 115 +++++++++++++++++++++++++++++++--
 1 file changed, 109 insertions(+), 6 deletions(-)
Comment 14 Richard Ulmer univentionstaff 2018-05-18 13:52:21 CEST
The additional changes seem reasonable and the spelling looks good -> OK
Applied changes to 4.2-4 -> OK
-> VERIFIED