Bug 45280 - Error dialog is shown when applying network settings
Error dialog is shown when applying network settings
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Setup wizard
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-2
Assigned To: Alexander Kläser
Erik Damrose
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-29 12:12 CEST by Alexander Kläser
Modified: 2017-09-11 06:40 CEST (History)
2 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.343
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Ticket number:
Bug group (optional): Appliance, Browser compatibility, Error handling
Max CVSS v3 score:


Attachments
error popup (95.16 KB, image/png)
2017-08-29 12:16 CEST, Erik Damrose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2017-08-29 12:12:48 CEST
With current internal appliance images, we observed that an error dialog is shown when network settings are applied within the setup wizard. This does not happen with current public images as they have an older firefox version.

To circumvent the problem, it seems necessary to use a status polling mechanism when the UMCP command "apply" is called.
Comment 1 Erik Damrose univentionstaff 2017-08-29 12:16:09 CEST
Created attachment 9151 [details]
error popup
Comment 2 Erik Damrose univentionstaff 2017-08-29 17:27:58 CEST
I retested with a fresh appliance that had the old firefox-esr package (45.7.0esr-1~deb8u1), the error popup still occured.
Comment 3 Alexander Kläser univentionstaff 2017-08-30 16:04:32 CEST
This problem is a regression caused by the latest errata for univention-management-console (9.0.80-63A~4.2.0.201708141353)... I tested it with the version before (9.0.80-59A~4.2.0.201707241109) which worked as expected.

Closing as duplicated of 45299.

*** This bug has been marked as a duplicate of bug 45299 ***
Comment 4 Florian Best univentionstaff 2017-08-31 13:07:39 CEST
NO, this is not a regression by Bug #44965. It's not reproducible via an external browser, only via firefox. If I revert the changes from that bug the error still occurs.
Comment 5 Erik Damrose univentionstaff 2017-08-31 13:44:27 CEST
Downgrading firefox and umc is required to fix the error in my test setup

apt-get install univention-management-console-server=9.0.80-59A~4.2.0.201707241109 python-univention-management-console=9.0.80-59A~4.2.0.201707241109 univention-management-console=9.0.80-59A~4.2.0.201707241109  univention-management-console-web-server=9.0.80-59A~4.2.0.201707241109 firefox-esr=45.7.0esr-1~deb8u1
Comment 6 Florian Best univentionstaff 2017-08-31 13:50:10 CEST
(In reply to Erik Damrose from comment #5)
> Downgrading firefox and umc is required to fix the error in my test setup
> 
> apt-get install
> univention-management-console-server=9.0.80-59A~4.2.0.201707241109
> python-univention-management-console=9.0.80-59A~4.2.0.201707241109
> univention-management-console=9.0.80-59A~4.2.0.201707241109 
> univention-management-console-web-server=9.0.80-59A~4.2.0.201707241109
> firefox-esr=45.7.0esr-1~deb8u1

Could you check if instead of the UMC downgrade the patch from Bug #45307 is sufficient?
Comment 7 Erik Damrose univentionstaff 2017-09-01 10:52:47 CEST
(In reply to Florian Best from comment #6)
> Could you check if instead of the UMC downgrade the patch from Bug #45307 is
> sufficient?

The patch worked in my tests, the popup did not appear. But i had to downgrade the firefox version, too. I think alex is working on a patch for this.
Comment 8 Alexander Kläser univentionstaff 2017-09-01 13:58:40 CEST
Applying network settings in the setup wizard is now robust against network timeouts and cancelled requests. The initial setup/net/apply is triggered, however, its outcome is ignored. Instead, setup/net/apply_check_finished is regularly polled until the network scripts have been completed their task.

univention-system-setup (10.0.10-39):
r82583 | Bug #45280: ignore setup/net/apply timeouts and errors
r82581 | Bug #45280: add a progress polling to setup/net/apply command

univention-system-setup.yaml:
r82582 | Bug #45280: added YAML file
Comment 9 Erik Damrose univentionstaff 2017-09-04 12:28:14 CEST
Worked great in my test, applying network settings and joining UCS worked.

reopen:
as discussed, please merge to ucs 4.2-2 and rebuild in that scope.
Comment 10 Alexander Kläser univentionstaff 2017-09-04 12:44:40 CEST
(In reply to Erik Damrose from comment #9)
> Worked great in my test, applying network settings and joining UCS worked.
> 
> reopen:
> as discussed, please merge to ucs 4.2-2 and rebuild in that scope.

Merged to 4.2-2 branch:

univention-system-setup (10.0.10-39):
r82603 | Bug #45280: ignore setup/net/apply timeouts and errors
r82602 | Bug #45280: add a progress polling to setup/net/apply command

I cherry-picked and built the package for the 4.2-2 scope.
Comment 11 Alexander Kläser univentionstaff 2017-09-05 13:15:06 CEST
I added the changelog entry and removed the errata YAML file:

changelog-4.2-2.xml:
r82667 | Bug #45307, Bug #45280: added changelog entry

univention-system-setup.yaml:
r82669 | Bug #45280: removed obsolete YAML file
Comment 12 Erik Damrose univentionstaff 2017-09-05 13:40:45 CEST
OK: Worked in my DVD and appliance installation tests
OK: changelog
Verified
Comment 13 Stefan Gohmann univentionstaff 2017-09-11 06:40:22 CEST
UCS 4.2-2 has been released.