Bug 45754 - libxml-libxml-perl: Multiple issues (4.2)
libxml-libxml-perl: Multiple issues (4.2)
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Security updates
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-3-errata
Assigned To: Philipp Hahn
Arvid Requate
:
Depends on: 44776
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-20 16:06 CET by Arvid Requate
Modified: 2018-05-08 14:56 CEST (History)
1 user (show)

See Also:
What kind of report is it?: Security Issue
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score: 5.6 (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L)
requate: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2017-11-20 16:06:50 CET
Upstream Debian package version 2.0116+dfsg-1+deb8u2 fixes:

* A use-after-free vulnerability was discovered in XML::LibXML, which allows an attacker to execute arbitrary code by controlling the arguments to a replaceChild() call (CVE-2017-10672)
Comment 1 Philipp Hahn univentionstaff 2018-01-25 10:59:37 CET
Mass-import from Debian-Security:
  python -m univention.repong.^Cbmirror -s jessie -r 4.2-3 --override=$HOME/REPOS/repo-ng/mirror/update_ucs42_mirror_from_debian.yml --errata=doc/errata --sql --process=ALL -vvvv --now=201801211553

YAML: git:bd6159834a..449aa5a7cf
Comment 2 Philipp Hahn univentionstaff 2018-02-27 09:16:42 CET
Must be released with or after Bug #44776:
>  The following packages have unmet dependencies:
>     libxml-libxml-perl : Depends: perl (>= 5.20.2-3+deb8u8) but 5.20.2-3+deb8u6A~4.2.0.201702152200 is to be installed

255c983c68 Bug #46158: libxml-libxml-perl 2.0116+dfsg-1+deb8u2
Comment 3 Quality Assurance univentionstaff 2018-05-04 16:55:54 CEST
--- mirror/ftp/4.2/unmaintained/4.2-0/source/libxml-libxml-perl_2.0116+dfsg-1+deb8u1.dsc
+++ apt/ucs_4.2-0-errata4.2-3/source/libxml-libxml-perl_2.0116+dfsg-1+deb8u2.dsc
@@ -1,3 +1,9 @@
+2.0116+dfsg-1+deb8u2 [Sat, 18 Nov 2017 14:14:08 +0100] Salvatore Bonaccorso <carnil@debian.org>:
+
+  * Team upload.
+  * CVE-2017-10672: Use-after-free by controlling the arguments to a
+    replaceChild call (Closes: #866676)
+
 2.0116+dfsg-1+deb8u1 [Fri, 01 May 2015 12:57:49 +0200] Salvatore Bonaccorso <carnil@debian.org>:
 
   * Team upload.
Comment 4 Arvid Requate univentionstaff 2018-05-07 12:56:57 CEST
* No UCS specific patches
* Comparison to previously shipped version ok
* Installation Ok
* Advisory Ok (also references Bug 44776)
Comment 5 Arvid Requate univentionstaff 2018-05-08 14:56:40 CEST
<http://errata.software-univention.de/ucs/4.2/362.html>