Bug 45909 - appbox 4.2 - apache broken
appbox 4.2 - apache broken
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Docker
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Dirk Wiesenthal
Felix Botner
https://git.knut.univention.de/univen...
:
Depends on:
Blocks: 46665
  Show dependency treegraph
 
Reported: 2017-12-20 10:40 CET by Felix Botner
Modified: 2018-05-02 13:31 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Release Management
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2017-12-20 10:40:32 CET
"univention-system-setup" is installed in the docker image univention/ucs-appbox-amd64:4.2-2. This packages enables a apache config with RewriteRules statements but does not enable the rewrite module itself. This is a broken apache config and apache refuses to start.

Workaround:
i added a "a2enmod rewrite" in the setup script of my app.

But why is "univention-system-setup" installed, can we remove this from the appbox image?

And we should update to 4.2-3.
Comment 1 Erik Damrose univentionstaff 2017-12-20 10:43:34 CET
u-system-setup provides UMC modules for e.g. network configuration, ssl settings, ... that package is installed on UCS by default.
Please clarify which config it enables that causes these issues?
Comment 2 Dirk Wiesenthal univentionstaff 2017-12-20 10:45:47 CET
It uses the rewrite module _without_ enabling it. That is the issue.

In Appbox, we do not need network configuration, ssl settings, ... via UMC. In fact, we do not need UMC.
Comment 3 Erik Damrose univentionstaff 2017-12-20 10:49:38 CET
conffiles/etc/apache2/conf-available/univention-system-setup.conf
Comment 4 Dirk Wiesenthal univentionstaff 2018-03-16 15:21:49 CET
Removed univention-system-setup from univention-container-role-common in
  univention-server 13.0.0-3A~4.3.0.201803161509
Comment 5 Arvid Requate univentionstaff 2018-03-19 11:56:10 CET
> It uses the rewrite module _without_ enabling it. That is the issue.

Isn't that a bug to be fixed in univention-system-setup ?
Comment 6 Dirk Wiesenthal univentionstaff 2018-04-15 21:45:30 CEST
(In reply to Arvid Requate from comment #5)
> > It uses the rewrite module _without_ enabling it. That is the issue.
> 
> Isn't that a bug to be fixed in univention-system-setup ?

Yes, but univention-system-setup is not to be installed in appbox anyway.

The problem is:
How do we build "full" Docker images without system-setup? Installing the role package will not pull it via dependency in, e.g., a Docker DC Master.

Fixed this in the install scripts for these images, the dependency is still gone.
Comment 7 Felix Botner univentionstaff 2018-04-16 11:50:45 CEST
(In reply to Dirk Wiesenthal from comment #6)
> (In reply to Arvid Requate from comment #5)
> > > It uses the rewrite module _without_ enabling it. That is the issue.
> > 
> > Isn't that a bug to be fixed in univention-system-setup ?
> 
> Yes, but univention-system-setup is not to be installed in appbox anyway.
> 
> The problem is:
> How do we build "full" Docker images without system-setup? Installing the
> role package will not pull it via dependency in, e.g., a Docker DC Master.
> 
> Fixed this in the install scripts for these images, the dependency is still
> gone.

How do you ensure that u-sy-se is not auto-removed on ucs docker systems?
Where are these " install scripts" changes?
Comment 8 Dirk Wiesenthal univentionstaff 2018-04-24 15:22:20 CEST
univention-system-setup will not be removed because the Docker Images also include univention-server-master (or so) which depends on univention-management-console -> umc-system-setup -> system-setup.

Job is here:

http://jenkins.knut.univention.de:8080/job/UCS-4.3/job/Build%20Docker%20Image%20(including%20Appbox)/

(Please do not QA the Job itself, this is a different task)
Comment 9 Dirk Wiesenthal univentionstaff 2018-04-26 11:22:36 CEST
Git: 0f408d54ec38bc9e96acd86db978829650b85bc7 and 12451f36e1995191dcac40f6bf7b7187e0ff1b79

I just removed univention-system-setup from the list of dependencies of the common container role package. Appbox does not install system-setup after this patch (which makes it smaller and does not have this bug with Apache). As the "full" Docker Images also install univention-role-master etc. system-setup is still required and therefore installed.

So, this should work: Appbox needs to build successfully and without system-setup. You can test it here:
http://jenkins.knut.univention.de:8080/job/UCS-4.3/job/Build%20Docker%20Image%20(including%20Appbox)/
with ERRATA_TESTING_ENABLED=true
Comment 10 Felix Botner univentionstaff 2018-04-26 12:10:15 CEST
OK - univention-system-setup no longer installed in appbox image
OK - YAML
Comment 11 Arvid Requate univentionstaff 2018-05-02 13:31:18 CEST
<http://errata.software-univention.de/ucs/4.3/25.html>