Bug 46665 - fix cron and ifconfig in UCS 4.3-2 appbox docker images
fix cron and ifconfig in UCS 4.3-2 appbox docker images
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Docker
UCS 4.3
Other Linux
: P5 normal (vote)
: UCS 4.3-2-errata
Assigned To: Dirk Wiesenthal
Arvid Requate
:
: 48057 48058 (view as bug list)
Depends on: 44468 45909 46758
Blocks: 47037 48193 41182
  Show dependency treegraph
 
Reported: 2018-03-14 16:10 CET by Arvid Requate
Modified: 2019-05-28 18:11 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.103
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2018-03-14 16:10:45 CET
We should create UCS 4.3-0 appbox docker images and upload them to dockerhub.
Comment 2 Dirk Wiesenthal univentionstaff 2018-03-23 18:45:45 CET
Uploaded
  docker-test.software-univention.de/ucs-appbox-amd64:4.3-0

Using (i.e. testing) it in ucs-test 8.0.28-100A~4.3.0.201803231841

Jenkins job:
  http://jenkins.knut.univention.de:8080/job/UCS-4.3/job/Build%20Appbox%20Image/

Job should work as long as we use stretch (which also means it cannot build appbox:4.2-3). Runs every thursday, as I assume errata updates will be released by then.

Alternatively, we could build it daily and include unpublished errata updates. Not sure yet.

For Jenkins, it would be nice to have a Seed job and put it in 4.3-0, 4.3-1, etc.
Comment 3 Felix Botner univentionstaff 2018-04-24 16:05:52 CEST
Added CreateAppBox to seed jobs (see jenkins/seed-jobs/create_ucs_branch_jobs.groovy). 

Please check the new job (4.3 -> 4.3-0 -> Build Docker Image) and remove the 4.3 -> Build Docker Image job if everything looks good
Comment 4 Felix Botner univentionstaff 2018-04-26 12:10:12 CEST
started new appbox 4.3 image

File: /etc/hostname
: Works only on the DC master
File: /etc/resolv.conf
/sbin/init: line 164: ifconfig: command not found
interfaces/eth0/address: 172.17.0.1
interfaces/eth0/broadcast: 
interfaces/eth0/netmask: 
interfaces/eth0/network: 172.17.0.0
RTNETLINK answers: Operation not permitted
ifup: failed to bring up lo
Create system/setup/boot/force/fqdn
Create gateway
Create interfaces/eth0/address
Create interfaces/eth0/broadcast
Create interfaces/eth0/netmask
Create interfaces/eth0/network
Create interfaces/eth0/type
Create docker/container/uuid
Multifile: /etc/network/interfaces
Multifile: /etc/hosts
File: /etc/dhcp/dhclient.conf
File: /etc/welcome.msg
File: /etc/default/ifplugd
File: /etc/issue
run-parts: executing /etc/univention/docker/preinit.d/fix-cron-hardlinks
INFO: Switching to standard /sbin/init.debian 
Failed to determine whether /sys is a mount point: Operation not permitted
Failed to determine whether /proc is a mount point: Operation not permitted
Failed to determine whether /dev is a mount point: Operation not permitted


is this critical?

/sbin/init: line 164: ifconfig: command not found
...
Failed to determine whether /sys is a mount point: Operation not permitted
Failed to determine whether /proc is a mount point: Operation not permitted
Failed to determine whether /dev is a mount point: Operation not permitted
Comment 5 Philipp Hahn univentionstaff 2018-05-22 10:24:13 CEST
The new image breaks the 4.2-4 tests: Bug #47037
Comment 6 Erik Damrose univentionstaff 2018-06-13 15:21:43 CEST
This bug was previously titled "Create UCS 4.3-0 appbox docker images"

Please clarify as soon as possible: Currently there is a 4.3-0 appbox image. My understanding was that it can be used for apps - is that still true? Then why is this bug not fixed?
Comment 7 Arvid Requate univentionstaff 2018-09-06 18:35:30 CEST
I've adjusted univention-docker-dev to 4.3-2 and built it in errata4.2-3.
I copied the package to out docker build host for inclusion in the newly generated images. Then I've built minbase,stem,master,backup,slave,member,generic with the traditional scripts. I've tagged those images as 4.3-2 and latest.


After that I've built the appbox image via Jenkins and tagged it as 

 univention/ucs-appbox-amd64:4.3-2 and univention/ucs-appbox-amd64:latest

for upload to docker.io/univention.

Then I've pushed all those images to docker.io/univention.


The role images are a bit to big for my taste, especially the member has grown quite a bit. But Dirk seems to have put a lot of work into shrinking the appbox image. That's great!
Comment 8 Daniel Tröder univentionstaff 2018-11-05 12:28:02 CET
The commit c7ece8de3bf7b27a0b158a00c96f43c850155ef5 of this bug has not made its way into the 4.3-2 appbox image.

Thus the UCRVs interfaces/eth0/* are broken in the image and (missing interfaces/eth0/netmask) for example the join script for univention-bind fails.

Currently this blocks the creation of an OX docker app.
Comment 9 Arvid Requate univentionstaff 2018-11-05 13:43:35 CET
The commit you are referring to is in univention-docker-contain-mode and should have gone into an errata-update. The package needs to be built and released, otherwise it will probably not get installed in the image?
Comment 10 Dirk Wiesenthal univentionstaff 2018-11-13 01:07:26 CET
Added ifconfig and cron:
  univention-docker-container-mode 3.0.2-2A~4.3.0.201811130105

Should work with newly built appbox images.
Comment 11 Daniel Tröder univentionstaff 2018-11-13 08:12:44 CET
Why is this "resolved"? There is no new 4.3-2 image at hub.docker.com. Or is that a different bug?
Comment 12 Erik Damrose univentionstaff 2018-11-13 09:11:52 CET
appbox docker images are available at our docker registry:
docker pull docker.software-univention.de/ucs-appbox-amd64:4.3-2
Comment 13 Daniel Tröder univentionstaff 2018-11-13 09:19:10 CET
(In reply to Erik Damrose from comment #12)
> appbox docker images are available at our docker registry:
> docker pull docker.software-univention.de/ucs-appbox-amd64:4.3-2
docker pull docker.software-univention.de/ucs-appbox-amd64:4.3-2
docker images
docker inspect 6c8beae72a6d
→ "Created": "2018-10-25T08:18:23.982361203Z"
Comment 14 Arvid Requate univentionstaff 2018-11-20 19:58:11 CET
Ok, looks good, shouldn't we also push do docker hub?
Comment 15 Daniel Tröder univentionstaff 2018-11-22 20:57:35 CET
The new image does still contain the broken /sbin/init.
Comment 16 Dirk Wiesenthal univentionstaff 2018-11-22 23:28:52 CET
The broken /sbin/init is fixed with this bug. This was an error. Maybe we should open a new bug and let it depend on this one. Anyway, currently, this bug needs to be VERIFIED for /sbin/init to be published. Afterwards, the image can be updated.

You should be able to test it with
  *docker-test*.software-univention.de/ucs-appbox-amd64:4.3-2
Comment 17 Daniel Tröder univentionstaff 2018-11-23 10:34:12 CET
(In reply to Dirk Wiesenthal from comment #16)
> The broken /sbin/init is fixed with this bug. This was an error. Maybe we
> should open a new bug and let it depend on this one. Anyway, currently, this
> bug needs to be VERIFIED for /sbin/init to be published. Afterwards, the
> image can be updated.
> 
> You should be able to test it with
>   *docker-test*.software-univention.de/ucs-appbox-amd64:4.3-2
That is the image that I checked, and it contains the broken /sbin/init.

I created a new bug that depends on this one, so that the image gets updated with the fixed /sbin/init: Bug #48193.
Comment 18 Arvid Requate univentionstaff 2018-11-23 11:53:24 CET
root@master10:~# docker pull docker-test.software-univention.de/ucs-appbox-amd64:4.3-2
4.3-2: Pulling from ucs-appbox-amd64

root@master10:~# docker inspect 5184ab36aa84 | grep Created
        "Created": "2018-11-08T18:33:44.74892795Z",


Can't we already fulfill Daniels wish to push the images now to the official repos, between verification and errata-release of the Debian package? Any danger in that?
Comment 19 Daniel Tröder univentionstaff 2018-11-23 12:15:28 CET
(In reply to Arvid Requate from comment #18)
> root@master10:~# docker pull
> docker-test.software-univention.de/ucs-appbox-amd64:4.3-2
> 4.3-2: Pulling from ucs-appbox-amd64
> 
> root@master10:~# docker inspect 5184ab36aa84 | grep Created
>         "Created": "2018-11-08T18:33:44.74892795Z",
That *is* the image that I checked, and it does *not* contain the fixed /sbin/init.
Comment 20 Arvid Requate univentionstaff 2018-11-26 15:05:55 CET
Ok, I called Dirk, he explained the confusion to me and we agreed to handle it as you two planned: this bug fixes the Debian package and Bug #48193 fixes and uploads the images. Apparently something in the current process of container generation depends on public repositories. I hope next time we can decouple errata release from image update to speed things up. Also, I should have checked the /sbin/init in the container as part of QA, sorry.
Comment 21 Arvid Requate univentionstaff 2018-11-28 12:10:45 CET
<http://errata.software-univention.de/ucs/4.3/339.html>
Comment 22 Arvid Requate univentionstaff 2019-05-28 18:11:11 CEST
*** Bug 48057 has been marked as a duplicate of this bug. ***
Comment 23 Arvid Requate univentionstaff 2019-05-28 18:11:40 CEST
*** Bug 48058 has been marked as a duplicate of this bug. ***