Bug 46319 - Normal error messages are shown as tracebacks with the 'Inform vendor' option
Normal error messages are shown as tracebacks with the 'Inform vendor' option
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.2-3-errata
Assigned To: Johannes Keiser
Jürn Brodersen
:
: 46227 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-16 16:47 CET by Johannes Keiser
Modified: 2019-02-27 18:05 CET (History)
1 user (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 1: Cosmetic issue or missing function but workaround exists
Who will be affected by this bug?: 3: Will affect average number of installed domains
How will those affected feel about the bug?: 1: Nuisance – not a big deal but noticeable
User Pain: 0.017
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling
Max CVSS v3 score:


Attachments
old_new_error_message (36.88 KB, image/png)
2018-02-16 16:47 CET, Johannes Keiser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Keiser univentionstaff 2018-02-16 16:47:42 CET
Created attachment 9395 [details]
old_new_error_message

Error messages that were previously just a message for the user are now shown
like tracebacks are, with the option to inform the vendor.

See Screenshot
Comment 1 Johannes Keiser univentionstaff 2018-02-23 13:55:17 CET
4.2-3:
univention-management-console (9.0.80-92)
9eaa28d Bug #46319: Fix display of errors without traceback
2c791ad Bug #46319: Debian changelog entry
2f2e9f0 Bug #46319: YAML entry
11436fa Bug #46319: YAML - update version

4.3 merge
univention-management-console (10.0.3-5)
fe6f9bd Bug #46319: Fix display of errors without traceback
cf3c710 Bug #46319: Debian changelog entry
Comment 2 Jürn Brodersen univentionstaff 2018-03-02 16:41:27 CET
What I tested
Messages are not shown as tracebacks anymore -> OK
YAML -> OK

-> Verified
Comment 3 Philipp Hahn univentionstaff 2018-04-04 16:17:36 CEST
<http://errata.software-univention.de/ucs/4.2/317.html>
Comment 4 Florian Best univentionstaff 2019-02-27 14:00:01 CET
*** Bug 46227 has been marked as a duplicate of this bug. ***