Bug 49034 - Update to Samba 4.10.0 final
Update to Samba 4.10.0 final
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 4.4
Other Linux
: P5 enhancement (vote)
: UCS 4.4-0-errata
Assigned To: Arvid Requate
Felix Botner
:
Depends on: 48084
Blocks: 48426 48752 46643
  Show dependency treegraph
 
Reported: 2019-03-19 11:43 CET by Arvid Requate
Modified: 2019-04-08 17:34 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Feature Request
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2019-03-19 11:43:05 CET
Samba 4.10.0 final has been released:

https://www.samba.org/samba/history/samba-4.10.0.html

https://wiki.samba.org/index.php/Samba_4.10_Features_added/changed




+++ This bug was initially created as a clone of Bug #48084 +++
Comment 1 Arvid Requate univentionstaff 2019-03-22 11:10:57 CET
Imported and built:

* talloc 2.1.16
* tevent 0.9.39
* tdb    1.3.18
* ldb    2:1.5.4
* samba  2:4.10.0

Re-built: univention-db-modules

SVN commits:
* I just incorporated all existing 04_symbols.patch into the respective source packages:

* talloc: r18298 r18299
* tevent: r18515 r18516 
* tdb:    r18518
* ldb:    r18520
* samba:  r18522

72e3768a49 | Advisories
Comment 2 Arvid Requate univentionstaff 2019-03-22 11:11:45 CET
*** Bug 49025 has been marked as a duplicate of this bug. ***
Comment 3 Felix Botner univentionstaff 2019-03-25 08:53:27 CET
[2019-03-22 13:44:30.932205] ldb: WARNING: module version mismatch in ../modules/univention_ldb_log.c : ldb_version=1.5.4 module_version=1.5.3
[2019-03-22 13:44:30.932223] ldb: WARNING: module version mismatch in ../modules/univention_samaccountname_ldap_check.c : ldb_version=1.5.4 module_version=1.5.3

we should fix this warning, it confuses the tests
Comment 4 Arvid Requate univentionstaff 2019-03-25 19:31:18 CET
I've rebuilt the univention-ldb-modules package last friday, so I guess they were not up to date yet during the test run.
Comment 5 Felix Botner univentionstaff 2019-04-03 11:30:11 CEST
OK - installation samba 4.10

OK, will be verified with bug #49025