Bug 48084 - Samba 4.10.0
Samba 4.10.0
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba4
UCS 4.4
Other Linux
: P5 enhancement (vote)
: UCS 4.4
Assigned To: Arvid Requate
Stefan Gohmann
: interim-3
: 38748 45128 48656 (view as bug list)
Depends on: 47842 48085 48142
Blocks: 48752 48824 48826 49034
  Show dependency treegraph
 
Reported: 2018-10-30 15:49 CET by Arvid Requate
Modified: 2019-05-15 13:32 CEST (History)
4 users (show)

See Also:
What kind of report is it?: Feature Request
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2018-10-30 15:49:58 CET

    
Comment 1 Stefan Gohmann univentionstaff 2018-11-06 07:42:22 CET
The next UCS version should ship Samba 4.9.
Comment 2 Arvid Requate univentionstaff 2018-11-07 17:43:15 CET
Packages updated and built in release-scope ucs_4.3-0-samba-4.9.
Comment 3 Arvid Requate univentionstaff 2018-12-06 19:44:06 CET
*** Bug 45128 has been marked as a duplicate of this bug. ***
Comment 4 Arvid Requate univentionstaff 2018-12-06 19:53:36 CET
*** Bug 38748 has been marked as a duplicate of this bug. ***
Comment 5 Felix Botner univentionstaff 2018-12-14 10:30:01 CET
This patch is disbaled

90_bug45982-samba-tool-dbcheck-continue-if-modify-fails.quilt.DISABLED

and this one is missing

97_Bug-47583-make-samba-tool-ntacl-sysvolcheck-show-the-file-path-in-error-message.quilt

Is this OK?
Comment 6 Arvid Requate univentionstaff 2018-12-14 11:49:33 CET
Thanks! I had disabled

90_bug45982-samba-tool-dbcheck-continue-if-modify-fails.quilt.DISABLED

because the original issue for this workaround has been fixed upstream. But probably it's better to keep it. I've reactivated it.

This other one is missing because it had been created after I fetched 4.9.1. I've merged it and the neccessary reordering of patches:

97_Bug-47583-make-samba-tool-ntacl-sysvolcheck-show-the-file-path-in-error-message.quilt

Package build process is running.
Comment 7 Felix Botner univentionstaff 2018-12-17 11:52:19 CET
samba can't be installed in 4.4-0

-> apt-get -s install samba-libs

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 samba-libs : Hängt ab von: libtracker-sparql-1.0-0 (>= 0.10.0) ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

seems that libtracker-sparql-1.0-0 is missing (unmaintained)
Comment 8 Arvid Requate univentionstaff 2018-12-17 19:29:15 CET
I've recalculated the maintenance status and updated changelog-4.4-0.xml.
Comment 9 Felix Botner univentionstaff 2018-12-18 09:58:20 CET
still can't install samba

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 samba-libs : Hängt ab von: libtracker-sparql-1.0-0 (>= 0.10.0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pa
Comment 10 Arvid Requate univentionstaff 2018-12-18 20:33:39 CET
Ok, I've also copied the following source packages from 4.3-0 to 4.4-0 maintained because libtracker-sparql-1.0-0 depends on corresponding binary packages:

* exempi
* libiptcdata
* enca
* snowball

Manual update test from updates-test was successful now.
Comment 11 Felix Botner univentionstaff 2019-01-03 16:01:51 CET
Installation works, test look good.

please add a note about the reindex step during the update in release-notes-4.4-0-en/de.xml "Notes about the update"
Comment 13 Arvid Requate univentionstaff 2019-01-24 13:08:43 CET
Upstream Samba 4.9 seems to have changed something in the python provision code regarding the paths:

In UCs 4.3 Samba 4.7 created /var/lib/samba/private/named.conf.update during initial provision, but in Samba 4.9 the path changed to

/var/lib/samba/bind-dns/named.conf.update

We need to adjust the UCR template for /etc/bind/named.conf.samba4 to include the new path.
Comment 14 Felix Botner univentionstaff 2019-01-24 17:51:23 CET
(In reply to Arvid Requate from comment #13)
> Upstream Samba 4.9 seems to have changed something in the python provision
> code regarding the paths:
> 
> In UCs 4.3 Samba 4.7 created /var/lib/samba/private/named.conf.update during
> initial provision, but in Samba 4.9 the path changed to
> 
> /var/lib/samba/bind-dns/named.conf.update
> 
> We need to adjust the UCR template for /etc/bind/named.conf.samba4 to
> include the new path.

fixed in univention-bind with 5700e5546e023eb6a621f8405ea75c0711e8e20c
Comment 15 Felix Botner univentionstaff 2019-02-01 10:34:12 CET
since the last built, samba can't be installed

-> apt-get -s install samba-common samba
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 samba : Hängt ab von: samba-common (= 2:4.7.8-1A~4.3.0.201811201337) aber 2:4.9.3-1A~4.4.0.201901291012 soll installiert werden
         Hängt ab von: samba-common-bin (= 2:4.7.8-1A~4.3.0.201811201337) soll aber nicht installiert werden
         Empfiehlt: attr soll aber nicht installiert werden
         Empfiehlt: samba-dsdb-modules soll aber nicht installiert werden
         Empfiehlt: samba-vfs-modules soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Comment 16 Arvid Requate univentionstaff 2019-02-04 11:01:32 CET
The amd64 package build aborted,


dh_install --sourcedir=/var/build/temp/tmp.x9fyZvMdkt/pbuilder/samba-4.9.3/debian/tmp --list-missing --fail-missing
dh_install: usr/lib/x86_64-linux-gnu/samba/libaesni-intel.so.0 exists in /var/build/temp/tmp.x9fyZvMdkt/pbuilder/samba-4.9.3/debian/tmp but is not installed to anywhere
dh_install: missing files, aborting


no clue yet why this install line in debian/samba-libs.install doesn't work:

[any-amd64] usr/lib/*/samba/libaesni-intel.so.0
Comment 17 Arvid Requate univentionstaff 2019-02-04 18:38:28 CET
ok, I fixed the missing library.
Comment 18 Arvid Requate univentionstaff 2019-02-14 23:04:58 CET
*** Bug 48656 has been marked as a duplicate of this bug. ***
Comment 19 Arvid Requate univentionstaff 2019-02-18 20:04:20 CET
Samba 4.10rc2 has been packaged and built. It's based on ldb 1.5.3 currently.
Comment 20 Arvid Requate univentionstaff 2019-02-26 15:16:03 CET
UCS 4.4 changelog updated.
Comment 21 Stefan Gohmann univentionstaff 2019-02-26 20:07:59 CET
Changelog: OK

Basic tests: OK (Windows Join, Samba Join, Memberserver, DRS replication, DNS)

Upgrade: OK, i was able to update Samba, mixed environment was successful as well.

Patches:  OK

ucs-test: OK, sections samba, samba4 and samba-common were successful on master, backup, salve and member in my test environment.
Comment 22 Florian Best univentionstaff 2019-03-12 13:40:31 CET
UCS 4.4 has been released:
 https://docs.software-univention.de/release-notes-4.4-0-en.html
 https://docs.software-univention.de/release-notes-4.4-0-de.html

If this error occurs again, please use "Clone This Bug".