Bug 24727 - Textanpassungen in den UMC-Modulen #2
Textanpassungen in den UMC-Modulen #2
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.0
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Florian Best
Dirk Wiesenthal
: interim-2
: 21518 23685 24242 24870 31284 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 16:03 CET by Jascha Geerds
Modified: 2013-11-19 06:42 CET (History)
7 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Cleanup, Typo/text changes
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jascha Geerds univentionstaff 2011-11-18 16:03:48 CET
Da Bug #24536 nun geschlossen ist, geht es hier weiter:

Benutzerverwaltung:
Titel -> Anrede
Comment 1 Moritz Muehlenhoff univentionstaff 2011-11-22 16:45:47 CET
Benutzerverwaltung:

Samba Privilegien -> Samba-Privilegien
Samba Anmeldezeitraum -> Samba-Anmeldezeitraum
E-Mail-Adresse -> E-Mail-Adresse(n) (Multivalue)
Telefonnummer -> Telefonnummer(n) (Multivalue)
Comment 2 Moritz Muehlenhoff univentionstaff 2011-11-22 17:07:15 CET
Benutzerverwaltung:

Windows Terminalserver -> Windows-Terminalserver

Client Konfiguration übernehmen für das Startprogramm > Client-Konfiguration übernehmen für das Startprogramm

Windows Terminalserver Profilpfad -> Windows-Terminalserver-Profilpfad

Standardmäßig der Client Hauptdrucker -> Standard-Drucker des zugreifenden Clients als Standard-Drucker verwenden
Comment 3 Moritz Muehlenhoff univentionstaff 2011-11-23 11:34:21 CET
Benutzerverwaltung:

jpeg photo -> Picture of the user (JPEG format)

Samba User Login Times -> Permitted times for Windows logins

Gruppen-ID > Gruppen-ID der primären Gruppe (analog auf Englisch)
Comment 4 Moritz Muehlenhoff univentionstaff 2011-11-25 12:49:48 CET
Automatische Ermittlung der LDAP Konfiguration -> Automatische Ermittlung der LDAP-Konfiguration
Comment 5 Moritz Muehlenhoff univentionstaff 2011-11-28 11:20:50 CET
Online-Update:

Component Name -> Component name
Comment 6 Moritz Muehlenhoff univentionstaff 2011-11-28 11:32:01 CET
Online Update -> Online update (Modulname)
Comment 7 Moritz Muehlenhoff univentionstaff 2011-11-28 14:49:56 CET
DHCP:

First Address -> First address
Last Address -> Last address
Comment 8 Alexander Kläser univentionstaff 2011-12-02 18:34:25 CET
Noch offene Anpassungen aus Bug 24536:

Updater-Modul
* In online-update-modul sollte es im deutschen "Repository-Server" und
"Repository-Prefix" heissen (statt wie jetzt mit Leerzeichen)

System Setup
* Netzwerk: DHCP-Abfrage statt DHCP query

Benutzerverwaltung:
* Titel -> Anrede
Comment 9 Lukas Walter univentionstaff 2011-12-14 16:56:01 CET
Anlegen einer "DHCP: lease time" policy -> unschöne Kommatas in den Tooltips bei englischer Sprachausgabe.

"Lease time used, if the client does not request a specific expiration time"
sollte besser
"Lease time used if the client does not request a specific expiration time"
lauten.

"Maximum lease time, that the server will accept if asked for"
sollte besser
"Maximum lease time that the server will accept if asked for"
lauten.
Comment 10 Lukas Walter univentionstaff 2011-12-14 17:03:12 CET
(In reply to comment #9)
> Anlegen einer "DHCP: lease time" policy -> unschöne Kommatas in den Tooltips
> bei englischer Sprachausgabe.
> 
> "Lease time used, if the client does not request a specific expiration time"
> sollte besser
> "Lease time used if the client does not request a specific expiration time"
> lauten.
> 
> "Maximum lease time, that the server will accept if asked for"
> sollte besser
> "Maximum lease time that the server will accept if asked for"
> lauten.

Im Deutschen ist die Kommasetzung ebenso unschön. Ferner die Formulierungen insgesamt.

"Lease-Zeit, wenn der Client nicht eine bestimmte Ablaufzeit erbittet"
sollte besser
"Lease-Zeit wenn der Client keine bestimmte Ablaufzeit erbittet"
lauten.

"Maximale Lease-Zeit, die der Server akzeptiert, wenn er danach gefragt wird"
sollte besser
"Maximale Lease-Zeit die der Server akzeptiert wenn er danach gefragt wird"
lauten.
Comment 11 Alexander Kläser univentionstaff 2011-12-15 13:55:33 CET
Aus Bug 21518:

"Einstellungen: Erweitertes Attribut", Reiter Allgemein, englisch:
"Default long description" statt "Default Long Description"

"Einstellungen: Erweitertes Attribut", Reiter UDM web, englisch:
"Tab name" statt "Tab Name"

"Einstellungen: Erweitertes Attribut", Reiter UDM web, englisch:
"Advanced tab" -> "Tab with advanced settings"

"Einstellungen: Erweitertes Attribut", Reiter UDM General, englisch:
"Needed Module" -> "Needed module"

"Einstellungen: Erweitertes Attribut", Reiter Datentyp, englisch:
"Default Value" -> "Default value"

"Einstellungen: Erweitertes Attribut", Reiter Datentyp, englisch:
"Multivalue" -> "Multi value"

"Einstellungen: Erweitertes Attribut", Reiter Datentyp, englisch:
"May change" -> "Editable after creation"

"Einstellungen: Erweitertes Attribut", Reiter LDAP, englisch:
"Object Class" -> "Object class"

"Einstellungen: Erweitertes Attribut", Reiter LDAP, englisch:
"Delete Object Class" -> "Delete object class"
Comment 12 Alexander Kläser univentionstaff 2011-12-15 13:56:22 CET
*** Bug 21518 has been marked as a duplicate of this bug. ***
Comment 13 Florian Best univentionstaff 2013-07-09 12:12:43 CEST
(In reply to Alexander Kläser from comment #8)
> Updater-Modul
> * In online-update-modul sollte es im deutschen "Repository-Server" und
> "Repository-Prefix" heissen (statt wie jetzt mit Leerzeichen)
not existing anymore

(In reply to Moritz Muehlenhoff from comment #5)
> Online-Update:
> 
> Component Name -> Component name
not existing anymore

All other changes have been done
univention-directory-manager-modules (9.0.9-1)
univention-updater (9.0.3-1)
univention-system-setup (7.0.19-1)
Comment 14 Florian Best univentionstaff 2013-07-09 12:15:10 CEST
*** Bug 31284 has been marked as a duplicate of this bug. ***
Comment 15 Florian Best univentionstaff 2013-07-09 12:15:16 CEST
*** Bug 23685 has been marked as a duplicate of this bug. ***
Comment 16 Florian Best univentionstaff 2013-07-09 12:15:23 CEST
*** Bug 24242 has been marked as a duplicate of this bug. ***
Comment 17 Florian Best univentionstaff 2013-07-09 12:15:29 CEST
*** Bug 24870 has been marked as a duplicate of this bug. ***
Comment 18 Florian Best univentionstaff 2013-07-09 12:16:13 CEST
Please also QA the Bugs marked as duplicate.
Comment 19 Florian Best univentionstaff 2013-07-09 13:11:59 CEST
Also:

univention-ad-connector (7.0.19-1)
univention-management-console-module-udm (4.0.5-1)
Comment 20 Alexander Kläser univentionstaff 2013-07-30 15:16:41 CEST
Changelog → OK

(In reply to Jascha Geerds from comment #0)
> Da Bug #24536 nun geschlossen ist, geht es hier weiter:
> 
> Benutzerverwaltung:
> Titel -> Anrede

OK

(In reply to Moritz Muehlenhoff from comment #1)
> Benutzerverwaltung:
> 
> Samba Privilegien -> Samba-Privilegien
> Samba Anmeldezeitraum -> Samba-Anmeldezeitraum
> E-Mail-Adresse -> E-Mail-Adresse(n) (Multivalue)
> Telefonnummer -> Telefonnummer(n) (Multivalue)

OK

(In reply to Moritz Muehlenhoff from comment #2)
> Benutzerverwaltung:
> 
> Windows Terminalserver -> Windows-Terminalserver
> 
> Client Konfiguration übernehmen für das Startprogramm > Client-Konfiguration
> übernehmen für das Startprogramm
> 
> Windows Terminalserver Profilpfad -> Windows-Terminalserver-Profilpfad
> 
> Standardmäßig der Client Hauptdrucker -> Standard-Drucker des zugreifenden
> Clients als Standard-Drucker verwenden

OK

(In reply to Moritz Muehlenhoff from comment #3)
> Benutzerverwaltung:
> 
> jpeg photo -> Picture of the user (JPEG format)
> 
> Samba User Login Times -> Permitted times for Windows logins
> 
> Gruppen-ID > Gruppen-ID der primären Gruppe (analog auf Englisch)

OK

(In reply to Moritz Muehlenhoff from comment #4)
> Automatische Ermittlung der LDAP Konfiguration -> Automatische Ermittlung
> der LDAP-Konfiguration

OK

(In reply to Moritz Muehlenhoff from comment #5)
> Online-Update:
> 
> Component Name -> Component name

Now in the App center (the component grid)
→ REOPEN

(In reply to Moritz Muehlenhoff from comment #6)
> Online Update -> Online update (Modulname)

Please rename the module "Online update" to:
  [de] "Software-Aktualisierung"
  [en] "Software update"
"Online Software-Update" is incorrect in German. The descriptions will be revised via Bug 32022.

→ REOPEN

(In reply to Moritz Muehlenhoff from comment #7)
> DHCP:
> 
> First Address -> First address
> Last Address -> Last address

OK

(In reply to Alexander Kläser from comment #8)
> Noch offene Anpassungen aus Bug 24536:
> 
> Updater-Modul
> * In online-update-modul sollte es im deutschen "Repository-Server" und
> "Repository-Prefix" heissen (statt wie jetzt mit Leerzeichen)
> 
> System Setup
> * Netzwerk: DHCP-Abfrage statt DHCP query
> 
> Benutzerverwaltung:
> * Titel -> Anrede

OK

(In reply to Lukas Walter from comment #9)
> Anlegen einer "DHCP: lease time" policy -> unschöne Kommatas in den Tooltips
> bei englischer Sprachausgabe.
> 
> "Lease time used, if the client does not request a specific expiration time"
> sollte besser
> "Lease time used if the client does not request a specific expiration time"
> lauten.
> 
> "Maximum lease time, that the server will accept if asked for"
> sollte besser
> "Maximum lease time that the server will accept if asked for"
> lauten.

OK

(In reply to Lukas Walter from comment #10)
> Im Deutschen ist die Kommasetzung ebenso unschön. Ferner die Formulierungen
> insgesamt.
> 
> "Lease-Zeit, wenn der Client nicht eine bestimmte Ablaufzeit erbittet"
> sollte besser
> "Lease-Zeit wenn der Client keine bestimmte Ablaufzeit erbittet"
> lauten.
> 
> "Maximale Lease-Zeit, die der Server akzeptiert, wenn er danach gefragt wird"
> sollte besser
> "Maximale Lease-Zeit die der Server akzeptiert wenn er danach gefragt wird"
> lauten.

Hier ist die Kommsetzung allerdings korrekt.
Änderungen wurden nicht übernommen, also → OK.

(In reply to Alexander Kläser from comment #11)
> Aus Bug 21518:
> 
> "Einstellungen: Erweitertes Attribut", Reiter Allgemein, englisch:
> "Default long description" statt "Default Long Description"
> 
> "Einstellungen: Erweitertes Attribut", Reiter UDM web, englisch:
> "Tab name" statt "Tab Name"
> 
> "Einstellungen: Erweitertes Attribut", Reiter UDM web, englisch:
> "Advanced tab" -> "Tab with advanced settings"
> 
> "Einstellungen: Erweitertes Attribut", Reiter UDM General, englisch:
> "Needed Module" -> "Needed module"
> 
> "Einstellungen: Erweitertes Attribut", Reiter Datentyp, englisch:
> "Default Value" -> "Default value"
> 
> "Einstellungen: Erweitertes Attribut", Reiter Datentyp, englisch:
> "Multivalue" -> "Multi value"
> 
> "Einstellungen: Erweitertes Attribut", Reiter Datentyp, englisch:
> "May change" -> "Editable after creation"
> 
> "Einstellungen: Erweitertes Attribut", Reiter LDAP, englisch:
> "Object Class" -> "Object class"
> 
> "Einstellungen: Erweitertes Attribut", Reiter LDAP, englisch:
> "Delete Object Class" -> "Delete object class"

OK

(In reply to Florian Best from comment #14)
> *** Bug 31284 has been marked as a duplicate of this bug. ***

OK

(In reply to Florian Best from comment #15)
> *** Bug 23685 has been marked as a duplicate of this bug. ***

OK

(In reply to Florian Best from comment #16)
> *** Bug 24242 has been marked as a duplicate of this bug. ***

OK

(In reply to Florian Best from comment #17)
> *** Bug 24870 has been marked as a duplicate of this bug. ***

OK
Comment 21 Florian Best univentionstaff 2013-08-07 12:26:50 CEST
(In reply to Alexander Kläser from comment #20)
> (In reply to Moritz Muehlenhoff from comment #5)
> > Online-Update:
> > 
> > Component Name -> Component name
> 
> Now in the App center (the component grid)
> → REOPEN
univention-management-console-module-appcenter (3.0.13-1)

> (In reply to Moritz Muehlenhoff from comment #6)
> > Online Update -> Online update (Modulname)
> 
> Please rename the module "Online update" to:
>   [de] "Software-Aktualisierung"
>   [en] "Software update"
> "Online Software-Update" is incorrect in German. The descriptions will be
> revised via Bug 32022.
> 
> → REOPEN
Modulename was adapted, description untouched.
univention-updater (9.0.8-1)
Comment 22 Alexander Kläser univentionstaff 2013-08-07 17:17:45 CEST
(In reply to Florian Best from comment #21)
> (In reply to Alexander Kläser from comment #20)
> > (In reply to Moritz Muehlenhoff from comment #5)
> > > Online-Update:
> > > 
> > > Component Name -> Component name
> > 
> > Now in the App center (the component grid)
> > → REOPEN
> univention-management-console-module-appcenter (3.0.13-1)

OK

> > (In reply to Moritz Muehlenhoff from comment #6)
> > > Online Update -> Online update (Modulname)
> > 
> > Please rename the module "Online update" to:
> >   [de] "Software-Aktualisierung"
> >   [en] "Software update"
> > "Online Software-Update" is incorrect in German. The descriptions will be
> > revised via Bug 32022.
> > 
> > → REOPEN
> Modulename was adapted, description untouched.
> univention-updater (9.0.8-1)

OK
Comment 23 Moritz Muehlenhoff univentionstaff 2013-09-20 08:10:46 CEST
(In reply to Alexander Kläser from comment #20)

> Please rename the module "Online update" to:
>   [de] "Software-Aktualisierung"
>   [en] "Software update"
> "Online Software-Update" is incorrect in German. The descriptions will be
> revised via Bug 32022.
> 
> → REOPEN

If a system is not up-to-date, a warning message is displayed when logging into the UMC:

Note: An update for UCS is available. Please visit Online Update Module to install the updates.

It also needs to be adapted to the new name.
Comment 24 Moritz Muehlenhoff univentionstaff 2013-09-20 08:17:53 CEST
(In reply to Florian Best from comment #13)
> (In reply to Alexander Kläser from comment #8)
> > Updater-Modul
> > * In online-update-modul sollte es im deutschen "Repository-Server" und
> > "Repository-Prefix" heissen (statt wie jetzt mit Leerzeichen)
> not existing anymore

Doch, die gibt es noch: Die Dialoge sind jetzt im Tab "Repository-Einstellungen" des App Centers".

Es sollte aber besser "Repository-Präfix" heissen.
Comment 25 Florian Best univentionstaff 2013-09-20 08:39:48 CEST
(In reply to Moritz Muehlenhoff from comment #23)
> (In reply to Alexander Kläser from comment #20)
> 
> > Please rename the module "Online update" to:
> >   [de] "Software-Aktualisierung"
> >   [en] "Software update"
> > "Online Software-Update" is incorrect in German. The descriptions will be
> > revised via Bug 32022.
> > 
> > → REOPEN
> 
> If a system is not up-to-date, a warning message is displayed when logging
> into the UMC:
> 
> Note: An update for UCS is available. Please visit Online Update Module to
> install the updates.
> 
> It also needs to be adapted to the new name.
Now generic for the links to Join module, Software-Update module and Reboot module.
univention-management-console-frontend (3.0.77-1) 
* Bug #24727: display referred module names generic
Comment 26 Florian Best univentionstaff 2013-09-20 08:54:00 CEST
(In reply to Moritz Muehlenhoff from comment #24)
> (In reply to Florian Best from comment #13)
> > (In reply to Alexander Kläser from comment #8)
> > > Updater-Modul
> > > * In online-update-modul sollte es im deutschen "Repository-Server" und
> > > "Repository-Prefix" heissen (statt wie jetzt mit Leerzeichen)
> > not existing anymore
> 
> Doch, die gibt es noch: Die Dialoge sind jetzt im Tab
> "Repository-Einstellungen" des App Centers".
> 
> Es sollte aber besser "Repository-Präfix" heissen.
fixed.

univention-management-console-module-appcenter (3.0.35-1) 
* Bug #24727: adapt german wording

univention-join (6.0.7-1)
 * Bug #24727: don't hardcode "setup" module name
Comment 27 Dirk Wiesenthal univentionstaff 2013-09-24 14:28:41 CEST
(In reply to Florian Best from comment #26)
> univention-join (6.0.7-1)
>  * Bug #24727: don't hardcode "setup" module name

Broken, but very good idea.

May I ask you to add a function to umc-frontend (app.js ?) and use it at least here? This is done manually in join, frontend, appcenter, updater. app.js knows best how the module is called (and if it exists!).

  linkToModule: function(moduleName, /*String?*/ moduleFlavor, /*String?*/ linkName)
Comment 28 Dirk Wiesenthal univentionstaff 2013-09-24 14:58:51 CEST
(In reply to Moritz Muehlenhoff from comment #1)
> E-Mail-Adresse -> E-Mail-Adresse(n) (Multivalue)
> Telefonnummer -> Telefonnummer(n) (Multivalue)

Dann aber bitte auch:
Telefonnummer(n) Festnetz
Telefonnummer(n) Mobil
Rufnummer(n) Pager
Comment 29 Florian Best univentionstaff 2013-09-26 09:31:19 CEST
(In reply to Dirk Wiesenthal from comment #28)
> (In reply to Moritz Muehlenhoff from comment #1)
> > E-Mail-Adresse -> E-Mail-Adresse(n) (Multivalue)
> > Telefonnummer -> Telefonnummer(n) (Multivalue)
> 
> Dann aber bitte auch:
> Telefonnummer(n) Festnetz
> Telefonnummer(n) Mobil
> Rufnummer(n) Pager
OK, univention-directory-manager-modules (9.0.38-1)

(In reply to Dirk Wiesenthal from comment #27)
> (In reply to Florian Best from comment #26)
> > univention-join (6.0.7-1)
> >  * Bug #24727: don't hardcode "setup" module name
> 
> Broken, but very good idea.
> 
> May I ask you to add a function to umc-frontend (app.js ?) and use it at
> least here? This is done manually in join, frontend, appcenter, updater.
> app.js knows best how the module is called (and if it exists!).
> 
>   linkToModule: function(moduleName, /*String?*/ moduleFlavor, /*String?*/
> linkName)

univention-join (6.0.8-1) 
* Bug #24727: use app.linkToModule for links to other UMC modules

univention-management-console-frontend (3.0.81-1) 
* Bug #24727: implement app.linkToModule for links to other UMC
modules

univention-management-console-frontend (3.0.82-1) 
* Bug #24727: use app.linkToModule for links to other UMC modules
Comment 30 Moritz Muehlenhoff univentionstaff 2013-09-26 10:01:38 CEST
When updating the documentation I noticed another typo:

In the users module in the "Contact" tab, the group needs to be labelled "Private" instead of "Privat".
Comment 31 Dirk Wiesenthal univentionstaff 2013-09-26 17:23:49 CEST
app.linkToModule adds a period at the end of the link
app.linkToModule does not handle ("udm", "navigation") correct: Name is "User module"
app.linkToModule does not handle ("fantasy") correct: Name is "fantasy module" and link is not working. Either throw, or (preferably, because we rarely throw anything) return null
Comment 32 Dirk Wiesenthal univentionstaff 2013-09-26 17:32:40 CEST
Software update module was renamed in German. Now the hint says:
  Es kann über das Software-Aktualisierung-Modul im System eingespielt werden.

Sounds awkward. Maybe:
  Es kann über das Modul "Software-Aktualisierung" im System eingespielt werden.

(generic change for linkToModule)
Comment 33 Florian Best univentionstaff 2013-09-30 10:17:43 CEST
univention-directory-manager-modules (9.0.39-1) 
* Bug #24727: fix typo in english translation

univention-join (6.0.9-1)
* Bug #24727: use app.linkToModule for links to other UMC modules

univention-management-console-frontend (3.0.83-1)
* Bug #24727: fix app.linkToModule
Comment 34 Dirk Wiesenthal univentionstaff 2013-09-30 15:04:54 CEST
Ok, found inconsistencies go into another bug.
Comment 35 Stefan Gohmann univentionstaff 2013-11-19 06:42:43 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".