Bug 30629 - No Key ID request on memberserver
No Key ID request on memberserver
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Dirk Wiesenthal
Felix Botner
: interim-3
: 32116 (view as bug list)
Depends on: 32389
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-01 15:05 CET by Janis Meybohm
Modified: 2013-11-19 06:41 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Meybohm univentionstaff 2013-03-01 15:05:34 CET
If customer starts the App Center for the first time on an memberserver, the installation of Apps is not possible.

The following message is shown to the customer:
--
UCS License Key: For the installation of this application an updated UCS license key with a so-called key identification (Key ID) is required. You need to have access to the Univention Directory Manager (UDM) module to fully use the App Center.
--

Customers don't read this message as it appears as a part of the App description, it should be presented in a separate dialog.
Apart from this, the message is not helpful. There are now hints for the user what he could do to get an license with a Key ID. The meaning of the sentence "You need to have access to the Univention Directory Manager (UDM) module to fully use the App Center." is clear to someone who knows the technical background of reading the license object from LDAP etc. but for the customer it is useless.

The "new" message should guide the user threw the steps of acquiring a license with key id. It should clearly state stat clicking the "install" button on a DC-Master/DC-Backup is necessary to get the key id and that no App is actually installed during this procedure.
Comment 1 Dirk Wiesenthal univentionstaff 2013-07-16 15:38:03 CEST
Fixed in
  univention-management-console-module-appcenter 3.0.7-1.151.201307161528

If UDM does not exist it is either because of not being on DC Master or because of permissions.

Not Master:
  You need to request and install a new license in order to use the Univention App Center. To do this please log in on %(host)s. Open the App Center there and click on "%(app)s" and "%(action)s". The process will not start, instead you will be guided through the steps of installing a license. After that you can "%(action)s" "%(app)s" here on this system.

Permission:
  You need to request and install a new license in order to use the Univention App Center. To do this please log in as %s and repeat the steps taken until this dialog. You will be guided through the installation.
Comment 2 Dirk Wiesenthal univentionstaff 2013-07-17 12:38:21 CEST
Bug #31991 changes the "workflow" to request a new license. Adjust the text accordingly when this has been done.
Comment 3 Ingo Steuwer univentionstaff 2013-07-29 15:44:15 CEST
maybe Bug #32116 can be fixed with this one / is a duplicate
Comment 4 Dirk Wiesenthal univentionstaff 2013-07-29 15:58:49 CEST
*** Bug 32116 has been marked as a duplicate of this bug. ***
Comment 5 Dirk Wiesenthal univentionstaff 2013-09-13 13:02:35 CEST
Adjusted the text in
  univention-management-console-module-appcenter 3.0.32-1.190.201309131257

(only "Not Master" changed, only middle part)

  You need to request and install a new license in order to use the Univention App Center.
  To do this please log in on %(host)s as an administrator. Click on the gear-wheel symbol in the top right line of the screen and choose "License". There you can request the new license.
  After that you can "%(action)s" "%(app)s" here on this system.
Comment 6 Felix Botner univentionstaff 2013-09-19 17:05:06 CEST
> There you can request the new license.

we should also mention the name of the "i want a new licence"-buttonn, "

something like

and choose "License" ...  go to the bottom of the dialog and click "Request updated license key with ..."
Comment 7 Felix Botner univentionstaff 2013-09-19 17:06:10 CEST
Maybe we could use the new UMC sso feature here to simplify the procedure ...
Comment 8 Dirk Wiesenthal univentionstaff 2013-09-20 12:22:24 CEST
Will have to be adjusted, Bug#32389 will change the behaviour once again. Tagging interim-3
Comment 9 Dirk Wiesenthal univentionstaff 2013-10-18 18:24:26 CEST
Just changed the name of the dialog from "License" to "Activation of UCS" (see Bug#32389). Used SSO if UDM is not accessible, host is not master and username is "Administrator". Otherwise I cannot be sure (although it is likely) that the user who has access to the App Center, also has access to UDM on the master. And if not, logging in immediately and not seeing the dialog is really confusing.

Better hope for the user to have read "log in as an administrator at %(host)s".

But again, I think this scenario is not very likely to happen at all.

=> means "most likely"
Not activated license => FFPU => Only one admin: "Administrator" => Only one user installs apps: "Administrator"
Comment 10 Dirk Wiesenthal univentionstaff 2013-10-21 17:25:26 CEST
As discussed, it is more intuitive to switch back to the App Details after any solution button (like "Request new license") is clicked. Otherwise one activates UCS but the error message is still displayed (until one manually clicks on "Cancel" and then on "Install" again). Also holds for other problems like unmet dependencies, not joined, etc.

  univention-management-console-module-appcenter 3.0.45-1.204.201310211718
Comment 11 Felix Botner univentionstaff 2013-10-22 10:05:30 CEST
(In reply to Dirk Wiesenthal from comment #10)
> As discussed, it is more intuitive to switch back to the App Details after
> any solution button (like "Request new license") is clicked. Otherwise one
> activates UCS but the error message is still displayed (until one manually
> clicks on "Cancel" and then on "Install" again). Also holds for other
> problems like unmet dependencies, not joined, etc.
> 
>   univention-management-console-module-appcenter 3.0.45-1.204.201310211718


On a member system i tried to install an app. I got the license error and clicked "Neue Lizenz anfordern". Then i installed a proper license on the master.
Back again on the member system i closed the "install the license" dialog by clicking "OK". Now on the apps overview page i tried to install the app a second time but again he tells me "Fortfahren nicht möglich, Für die Installation dieser Applikation ist ein aktueller UCS-Lizenzschlüssel mit ...".

After "Neue Lizenz anfordern" and "OK" on the member i can finally install the app.
Comment 12 Dirk Wiesenthal univentionstaff 2013-10-22 15:36:59 CEST
univention-management-console-module-appcenter 3.0.46-1.205.201310221528
Comment 13 Felix Botner univentionstaff 2013-10-22 17:31:02 CEST
OK - works fine on master, slave, member
OK - Changelog
Comment 14 Stefan Gohmann univentionstaff 2013-11-19 06:41:21 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".