Bug 32328 - Licence status of App Center apps is not clear
Licence status of App Center apps is not clear
Status: RESOLVED DUPLICATE of bug 40428
Product: UCS
Classification: Unclassified
Component: App Center
UCS 3.0
Other Linux
: P5 normal (vote)
: UCS 3.2-x
Assigned To: Bugzilla Mailingliste
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 11:22 CEST by Moritz Muehlenhoff
Modified: 2016-04-19 14:35 CEST (History)
5 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2013-08-23 11:22:45 CEST
During one of the technical training it was remarked that the App Center provides no information on the license status: Does an app need to be licensed, is it free of charge (e.g. Asterisk4UCS) or is it included in the UCS license?

E.g. one of the participants knew that different Zarafa license flavour exists (premium/pure web users), but the App Center dialogue doesn't tell what kind of Zarafa license is needed and what is provided free of charge.
Comment 1 Dirk Wiesenthal univentionstaff 2013-11-19 16:23:02 CET
Apps may ship LICENSE_AGREEMENT. In case of Zarafa this file should make clear what license is used. If this is the only problem, it is a bug against the Zarafa app.

What the UMC module could do: Provide a button to re-read the license.
Comment 2 Alexander Kläser univentionstaff 2015-05-22 11:41:53 CEST
Also mentioned at Ticket#2015051321000257.
Here the user mentioned that it would be helpful to see license as well as price information along with usage conditions, e.g., how many users can be used for free/non-commercially, community edition etc.

(In reply to Dirk Wiesenthal from comment #1)
> Apps may ship LICENSE_AGREEMENT. In case of Zarafa this file should make
> clear what license is used. If this is the only problem, it is a bug against
> the Zarafa app.
> 
> What the UMC module could do: Provide a button to re-read the license.

This would be Bug 37617, AFAIS.
Comment 3 Florian Best univentionstaff 2016-04-19 08:12:24 CEST
So is this fixed by Bug #40428 or are there still open points? What should be the goal of this bug?
Comment 4 Dirk Wiesenthal univentionstaff 2016-04-19 09:34:05 CEST
Yes, fixed in Bug#40428

*** This bug has been marked as a duplicate of bug 40428 ***
Comment 5 Florian Best univentionstaff 2016-04-19 09:41:33 CEST
(In reply to Dirk Wiesenthal from comment #4)
> Yes, fixed in Bug#40428
> 
> *** This bug has been marked as a duplicate of bug 40428 ***
comment 2 contained that it would be useful to show 
"""
as well as price information along with usage conditions, e.g., how many users can be used for free/non-commercially, community edition etc.
"""
Comment 6 Nico Gulden univentionstaff 2016-04-19 14:35:31 CEST
(In reply to Florian Best from comment #5)
> (In reply to Dirk Wiesenthal from comment #4)
> > Yes, fixed in Bug#40428
> > 
> > *** This bug has been marked as a duplicate of bug 40428 ***
> comment 2 contained that it would be useful to show 
> """
> as well as price information along with usage conditions, e.g., how many
> users can be used for free/non-commercially, community edition etc.
> """

Prices and usage conditions are more of a business question and should not belong into the App Center. They belong to the transaction platform and should be presentated there.