Bug 37617 - Users should be able to view app LICENSE_AGREEMENT
Users should be able to view app LICENSE_AGREEMENT
Status: CLOSED DUPLICATE of bug 40428
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.1-1-errata
Assigned To: Dirk Wiesenthal
Florian Best
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-26 10:07 CET by Nico Gulden
Modified: 2016-03-08 16:06 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Gulden univentionstaff 2015-01-26 10:07:22 CET
Some apps have a LICENSE_AGREEMENT file. The content is shown before the app is installed in the App Center and the user has to confirm it or the app will not be installed.

There is no possibility in the App Center to view the LICENSE_AGREEMENT after the app is installed. The user cannot see again, what he has confirmed.

For every app that has the LICENSE_AGREEMENT and that is installed through the App Center, the user should be able to view the agreement after the installation.

Apps that are not installed, but have the LICENSE_AGREEMENT, may not offer a possibility to show it, unless the user starts the installation process. That's the current behaviour and should not be changed.
Comment 1 Dirk Wiesenthal univentionstaff 2016-03-04 23:02:45 CET
Should be fixed along with Bug#40428

*** This bug has been marked as a duplicate of bug 40428 ***
Comment 2 Florian Best univentionstaff 2016-03-07 06:54:43 CET
Yes, works.