Bug 40428 - Add licence categories to the App Center
Add licence categories to the App Center
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1-1-errata
Assigned To: Dirk Wiesenthal
Florian Best
:
: 32328 37617 (view as bug list)
Depends on:
Blocks: 40941 40872
  Show dependency treegraph
 
Reported: 2016-01-14 10:45 CET by Nico Gulden
Modified: 2016-04-19 09:34 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Gulden univentionstaff 2016-01-14 10:45:50 CET
Except in 1-2 cases, the apps in the App Center do not provide information about the licensing and commercial use model. The users can install the apps very easily, but they are confused and don't know the conditions for the usage of the app. In an increasing number of cases, the users contact Univention and ask.

Users currently have to visit the app provider's website to answer this question. Even worse are missing information about the evaluation restrictions like free trial for 30 days or free trial for 5 users. This information cannot be found in the app description or even on the app provider's website.

A research over all apps in the App Center showed that not all app providers publish the information. Furthermore, this information is not asked from the app provider and explicitly displayed on the App detail page.


A new attribute should be added to the App Center meta data the provides a combined information about the evaluation restrictions and the commercial use. It should be shown in the App Center and the App Catalog. The attribute should consist of the following options:
1. Free commercial use
2. Free commercial use and some functions are subject to costs
3. Liable to Costs with free trial
4. Liable to Costs without Free Trial

A more detailed proposal can be found here: https://metod.knut.univention.de/owncloud/index.php/s/tDLRGgTwrVPnOQt

See also the discussion in the forum: http://forum.univention.de/viewtopic.php?f=67&t=4678&p=18109
Comment 1 Dirk Wiesenthal univentionstaff 2016-03-04 23:02:45 CET
*** Bug 37617 has been marked as a duplicate of this bug. ***
Comment 2 Dirk Wiesenthal univentionstaff 2016-03-04 23:57:03 CET
See http://appcenter-test.software-univention.de/meta-inf/license_types.ini

ini file needs to specify
License=free

Also adds a "read" link to the LICENSE_AGREEMENT (would be bad manner to hide it if it is present), see Bug#37617. Always adds this link, not only when installed.

If no License= and no LICENSE_AGREEMENT, shows:
  The App does not provide any information about the license. Please contact the App provider for further details.

This will be the case for most of the Apps at the moment. We may want to add the License= attribute before this fix is released
Comment 3 Stefan Gohmann univentionstaff 2016-03-07 05:53:20 CET
The Jenkins tests failed, for example:

[2016-03-06 21:01:27.902381]Downloading "https://backup092.autotest092.local/meta-inf/4.1/index.json.gz"...
[2016-03-06 21:01:27.915444]Downloading "https://backup092.autotest092.local/meta-inf/categories.ini"...
[2016-03-06 21:01:27.931940]Downloading "https://backup092.autotest092.local/meta-inf/rating.ini"...
[2016-03-06 21:01:27.948397]Downloading "https://backup092.autotest092.local/meta-inf/license_types.ini"...
(2016-03-06 21:01:27.951763)Konnte https://backup092.autotest092.local/meta-inf/license_types.ini nicht herunterladen. Das deutet auf ein Problem auf dem App Center-Server hin. Bitte versuchen Sie es später noch einmal.
[2016-03-06 21:01:28.013248]Cleanup after exception: <class 'dockertest.UCSTest_DockerApp_UpdateFailed'> 

http://jenkins.knut.univention.de:8080/job/UCS-4.1/job/UCS-4.1-1/job/Autotest%20MultiEnv/SambaVersion=s3,Systemrolle=backup/26/testReport/junit/80_docker/40_app_install_4_0-3/test/
Comment 4 Florian Best univentionstaff 2016-03-07 06:50:39 CET
If you click on "Read" to read the license agreement a pop up pops up. This pop up has a button "Contiune" - which is irritating.
Comment 5 Florian Best univentionstaff 2016-03-07 06:59:59 CET
Please relabel into "Read license agreement" instead of just "Read".
Comment 6 Dirk Wiesenthal univentionstaff 2016-03-07 12:29:24 CET
(In reply to Stefan Gohmann from comment #3)
> The Jenkins tests failed, for example:
> 

license_types.ini copied to appcenter


(In reply to Florian Best from comment #4)
> If you click on "Read" to read the license agreement a pop up pops up. This
> pop up has a button "Contiune" - which is irritating.

Changed to "Close"

(In reply to Florian Best from comment #5)
> Please relabel into "Read license agreement" instead of just "Read".

Done

Also, checking for empty license type. In this case nothing is shown (instead of 'The App does not provide ... '). This may be used for the first days until the App providers define their respective license type.

See http://appcenter-test.software-univention.de/meta-inf/license_types.ini [empty].

License=emtpy will hide it unless a LICENSE_AGREEMENT is there to be read.
Comment 7 Florian Best univentionstaff 2016-03-07 14:01:19 CET
(In reply to Dirk Wiesenthal from comment #6)
> (In reply to Stefan Gohmann from comment #3)
> > The Jenkins tests failed, for example:
> > 
> 
> license_types.ini copied to appcenter
OK, but let's see the test cases tomorrow.

> (In reply to Florian Best from comment #4)
> > If you click on "Read" to read the license agreement a pop up pops up. This
> > pop up has a button "Contiune" - which is irritating.
> 
> Changed to "Close"
OK
> (In reply to Florian Best from comment #5)
> > Please relabel into "Read license agreement" instead of just "Read".
> 
> Done
OK
> Also, checking for empty license type. In this case nothing is shown
> (instead of 'The App does not provide ... '). This may be used for the first
> days until the App providers define their respective license type.
> 
> See http://appcenter-test.software-univention.de/meta-inf/license_types.ini
> [empty].
> 
> License=emtpy will hide it unless a LICENSE_AGREEMENT is there to be read.
REOPEN: This doesn't work. (Also If i fix your typo: License=emtpy / License=empty).
Comment 8 Stefan Gohmann univentionstaff 2016-03-08 06:04:56 CET
(In reply to Dirk Wiesenthal from comment #6)
> (In reply to Stefan Gohmann from comment #3)
> > The Jenkins tests failed, for example:
> > 
> 
> license_types.ini copied to appcenter

If the file license_types.ini is mandatory, you need to adjust the test Appcenter class in ucs-test/tests/80_docker/dockertest.py. During the tests, a temporary App Center is created.

I think it makes also sense to create tests for this issue.
Comment 9 Dirk Wiesenthal univentionstaff 2016-03-08 12:47:27 CET
(In reply to Stefan Gohmann from comment #8)
> If the file license_types.ini is mandatory, you need to adjust the test
> Appcenter class in ucs-test/tests/80_docker/dockertest.py. During the tests,
> a temporary App Center is created.
> 
> I think it makes also sense to create tests for this issue.

Fixed in ucs-test. I have created Bug#40855 for the test.

(In reply to Florian Best from comment #7)
> REOPEN: This doesn't work. (Also If i fix your typo: License=emtpy /
> License=empty).

Please re-check. It works for me.
Comment 10 Florian Best univentionstaff 2016-03-08 13:33:12 CET
(In reply to Dirk Wiesenthal from comment #9)
> (In reply to Stefan Gohmann from comment #8)
> > If the file license_types.ini is mandatory, you need to adjust the test
> > Appcenter class in ucs-test/tests/80_docker/dockertest.py. During the tests,
> > a temporary App Center is created.
> > 
> > I think it makes also sense to create tests for this issue.
> 
> Fixed in ucs-test. I have created Bug#40855 for the test.
OK

> (In reply to Florian Best from comment #7)
> > REOPEN: This doesn't work. (Also If i fix your typo: License=emtpy /
> > License=empty).
> 
> Please re-check. It works for me.
OK

YAML: OK
Comment 11 Stefan Gohmann univentionstaff 2016-03-09 07:07:59 CET
(In reply to Nico Gulden from comment #0)
> A new attribute should be added to the App Center meta data the provides a
> combined information about the evaluation restrictions and the commercial
> use. It should be shown in the App Center and the App Catalog. The attribute
> should consist of the following options:
> 1. Free commercial use
> 2. Free commercial use and some functions are subject to costs
> 3. Liable to Costs with free trial
> 4. Liable to Costs without Free Trial

Nico used the types in his communication with the ISVs. We have now other licenses types / texts in the license_types.ini file. Can we adjust the types in the license_types.ini file?
Comment 12 Florian Best univentionstaff 2016-03-09 07:20:47 CET
(In reply to Stefan Gohmann from comment #11)
> Can we adjust the
> types in the license_types.ini file?
Yes, this is always possible without having to change the appcenter package.
Comment 13 Dirk Wiesenthal univentionstaff 2016-03-09 14:52:59 CET
The texts can be adjusted after the release of this update. Currently, the ini file looks like this:
  http://appcenter-test.software-univention.de/meta-inf/license_types.ini

It will be updated as soon as possible. Same holds for ini files.
Comment 14 Janek Walkenhorst univentionstaff 2016-03-09 15:52:21 CET
<http://errata.software-univention.de/ucs/4.1/127.html>
Comment 15 Dirk Wiesenthal univentionstaff 2016-04-19 09:34:05 CEST
*** Bug 32328 has been marked as a duplicate of this bug. ***