Bug 35264 - Migrate mail packages to UCS 4
Migrate mail packages to UCS 4
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Mail
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Felix Botner
Janek Walkenhorst
: interim-3
: 35718 (view as bug list)
Depends on:
Blocks: 35525 35888 36577
  Show dependency treegraph
 
Reported: 2014-07-06 16:27 CEST by Stefan Gohmann
Modified: 2014-11-26 06:53 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-07-06 16:27:01 CEST
The following packages should be migrated to UCS 4:
 univention-antivir-mail
 univention-fetchmail
 univention-mail-canonical-maps
 univention-mail-cyrus
 univention-mail-cyrus-murder
 univention-mail-postfix
 univention-postgrey
 univention-spamassassin

Please consider the package migration list:

https://hutten.knut.univention.de/mediawiki/index.php/UCS-4.0_Univention_Package_Update
Comment 1 Janek Walkenhorst univentionstaff 2014-08-15 15:20:07 CEST
(In reply to Stefan Gohmann from comment #0)
>  univention-fetchmail
The patches for "fetchmail" have been migrated too.
Comment 2 Stefan Gohmann univentionstaff 2014-08-25 08:32:18 CEST
I've added a changelog for all migrated packages: r52983
Comment 3 Felix Botner univentionstaff 2014-08-27 11:41:51 CEST
(1)
please also migrate services/univention-sasl (required by univention-mail-server, univention-mail-cyrus ...)

(2)

maybe we can drop program_directory in main.cf

-> /etc/init.d/postfix stop
[....] Stopping Postfix Mail Transport Agent: postfix/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: program_directory=/usr/lib/postfix
. ok

->  /etc/init.d/postfix start
[....] Starting Postfix Mail Transport Agent: postfixpostconf: warning: /etc/postfix/main.cf: unused parameter: program_directory=/usr/lib/postfix
postconf: warning: /etc/postfix/main.cf: unused parameter: program_directory=/usr/lib/postfix
postconf: warning: /etc/postfix/main.cf: unused parameter: program_directory=/usr/lib/postfix
postconf: warning: /etc/postfix/main.cf: unused parameter: program_directory=/usr/lib/postfix
postconf: warning: /etc/postfix/main.cf: unused parameter: program_directory=/usr/lib/postfix
postconf: warning: /etc/postfix/main.cf: unused parameter: program_directory=/usr/lib/postfix
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: program_directory=/usr/lib/postfix
...
Comment 4 Stefan Gohmann univentionstaff 2014-09-04 16:45:39 CEST
*** Bug 35718 has been marked as a duplicate of this bug. ***
Comment 5 Felix Botner univentionstaff 2014-10-02 10:18:48 CEST
migrated services/univention-sasl to 4.0

cyrus:

added a ucr template for /etc/default/cyrus-imapd to univention-mail-cyrus and the disbaled 60_default.patch patch for cyrus-imapd-2.4 (for a proper installation of cyrus without univention-mail-cyrus).

postfix:

changed permissions of /etc/postfix/ldap* templates (owner root). Moved /etc/postfix/listfilter.secret to /etc. "postfix check" now runs without warning.

removed "program_directory = /usr/lib/postfix" from postfix main.cf
Comment 6 Stefan Gohmann univentionstaff 2014-10-19 19:52:47 CEST
Move all unfinished MS1 and MS2 bugs to RC.
Comment 7 Felix Botner univentionstaff 2014-10-20 11:24:04 CEST
added PidFile to freshclam.conf
Comment 8 Felix Botner univentionstaff 2014-10-21 17:49:27 CEST
removed retired variables $sa_spam_modifies_subj and $sa_timeout from /etc/amavis/conf.d/60-univention
Comment 9 Janek Walkenhorst univentionstaff 2014-11-11 16:56:50 CET
(In reply to Felix Botner from comment #5)
> migrated services/univention-sasl to 4.0
OK

> cyrus:
> 
> added a ucr template for /etc/default/cyrus-imapd to univention-mail-cyrus
> and the disbaled 60_default.patch patch for cyrus-imapd-2.4 (for a proper
> installation of cyrus without univention-mail-cyrus).
OK

> postfix:
> 
> changed permissions of /etc/postfix/ldap* templates (owner root).
Changed OK, but the permissions are not changed if the config file exists during UCR commit.

> Moved
> /etc/postfix/listfilter.secret to /etc. "postfix check" now runs without
> warning.
OK

> removed "program_directory = /usr/lib/postfix" from postfix main.cf
OK

(In reply to Felix Botner from comment #7)
> added PidFile to freshclam.conf
OK

(In reply to Felix Botner from comment #8)
> removed retired variables $sa_spam_modifies_subj and $sa_timeout from
> /etc/amavis/conf.d/60-univention
OK
Comment 10 Janek Walkenhorst univentionstaff 2014-11-11 17:11:11 CET
(In reply to Janek Walkenhorst from comment #9)
> > postfix:
> > 
> > changed permissions of /etc/postfix/ldap* templates (owner root).
> Changed OK, but the permissions are not changed if the config file exists
> during UCR commit.
This is the expected behavior of UCR. Thus an explicit chown is required.
→ Bug #36577
Comment 11 Stefan Gohmann univentionstaff 2014-11-26 06:53:56 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".