Bug 35267 - Migrate more base packages to UCS 4
Migrate more base packages to UCS 4
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Janek Walkenhorst
Felix Botner
: interim-1
: 35419 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-06 16:43 CEST by Stefan Gohmann
Modified: 2014-11-26 06:55 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-07-06 16:43:51 CEST
The following packages should be migrated to UCS 4:

> pam-runasroot
> pam-univentionmailcyrus
> univention-bootsplash
> univention-debmirror
> univention-doc
> univention-heimdal
> univention-passwd-cache
> univention-passwd-store
> univention-system-setup
> univention-updater


Please consider the package migration list:

https://hutten.knut.univention.de/mediawiki/index.php/UCS-4.0_Univention_Package_Update
Comment 1 Florian Best univentionstaff 2014-07-16 14:24:45 CEST
FYI: I migrated univention-system-setup for Bug #35145. The conffiles should be OK.
-			if p.name == 'python2.6' and '/usr/share/univention-system-setup/univention-system-setup' in p.cmdline:
+			if p.name == 'python2.7' and '/usr/share/univention-system-setup/univention-system-setup' in p.cmdline:
→ this change should also be OK as the new processes will run with python2.7.

Not built because the built will currently fail due to Bug #34484 → Will probably be fixed tomorrow.
Comment 2 Florian Best univentionstaff 2014-07-17 10:51:21 CEST
I removed the dependencies and the build dependency on univention-installer-modules as this doesn't exists anymore in UCS 4.0 (univention-installer has been removed). So far the package builds, so I guess the dependency is only of cosmetic nature/history reasons.
Comment 3 Florian Best univentionstaff 2014-07-17 12:19:40 CEST
The univention-installer-modules dependency was there because of the software components which are loaded from the appcenter directly now.
Comment 4 Alexander Kläser univentionstaff 2014-07-19 12:59:54 CEST
(In reply to Florian Best from comment #3)
> The univention-installer-modules dependency was there because of the
> software components which are loaded from the appcenter directly now.

Not quite correct. System setup also uses the following parts from univention-installer-modules:

  /lib/univention-installer/locale/all-kmaps
  /lib/univention-installer/dhclient-script-wrapper
  /lib/univention-installer/locale/languagelist
  /lib/univention-installer/locale/short-list

Probably they should be moved over to system setup (at least that would be the easiest way... and at least as a first step). Not sure, whether it would be possible to use information from the debian installer instead.
Comment 5 Alexander Kläser univentionstaff 2014-07-19 13:03:17 CEST
I forgot to mention, as well:

  /lib/univention-installer/locale/timezone
  /lib/univention-installer/locale/default-kmaps
  /lib/univention-installer/locale/country_codes
  /lib/univention-installer/locale/countrycode2timezone

That should be all.
Comment 6 Sönke Schwardt-Krummrich univentionstaff 2014-07-21 10:29:28 CEST
*** Bug 35419 has been marked as a duplicate of this bug. ***
Comment 7 Florian Best univentionstaff 2014-07-21 15:26:03 CEST
(In reply to Alexander Kläser from comment #5)
I moved the required components into univention-system-setup (svn r
52009).
Comment 8 Florian Best univentionstaff 2014-07-22 10:29:55 CEST
univention-system-setup-boot depends on firefox-{en,de} which will maybe replaced by iceweasel (→ Bug #35266). The dependency have to be adapted then.
Comment 9 Stefan Gohmann univentionstaff 2014-07-23 12:38:48 CEST
(In reply to Florian Best from comment #8)
> univention-system-setup-boot depends on firefox-{en,de} which will maybe
> replaced by iceweasel (→ Bug #35266). The dependency have to be adapted then.

I've changed the dependency and I've also removed the dependency to univention-server-master: r52103
Comment 10 Janek Walkenhorst univentionstaff 2014-08-14 18:55:04 CEST
(In reply to Stefan Gohmann from comment #0)
> The following packages should be migrated to UCS 4:
> > pam-runasroot
> > pam-univentionmailcyrus
> > univention-bootsplash
> > univention-debmirror
> > univention-doc
> > univention-heimdal
> > univention-passwd-cache
> > univention-passwd-store
> > univention-system-setup
> > univention-updater
Done.
Comment 11 Stefan Gohmann univentionstaff 2014-08-25 08:31:51 CEST
I've added a changelog for all migrated packages: r52983
Comment 12 Felix Botner univentionstaff 2014-09-02 10:25:42 CEST
OK - pam-runasroot
OK - pam-univentionmailcyrus
OK - univention-bootsplash
OK - univention-debmirror
OK - univention-doc
OK - univention-heimdal
OK - univention-passwd-cache
OK - univention-passwd-store
OK - univention-system-setup
OK - univention-updater

OK - Changelog
Comment 13 Stefan Gohmann univentionstaff 2014-11-26 06:55:58 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".