Bug 36260 - Show hint for printer module if no printserver is configured in the domain
Show hint for printer module if no printserver is configured in the domain
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Printers
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Dirk Wiesenthal
Alexander Kramer
: interim-3
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-22 07:56 CEST by Stefan Gohmann
Modified: 2014-11-26 06:54 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-10-22 07:56:22 CEST
Please add a warning to the printer module that shows the printserver app should be installed first.

Don't consider the other modules like mail, dhcp ...

+++ This bug was initially created as a clone of Bug #32313 +++
Comment 1 Florian Best univentionstaff 2014-10-22 11:11:38 CEST
We could also hide the flavor until the module is installed.
Comment 2 Dirk Wiesenthal univentionstaff 2014-10-28 17:55:41 CET
Added a warning in
  univention-management-console-module-udm 5.1.16-2.497.201410281736
Comment 3 Stefan Gohmann univentionstaff 2014-10-30 07:07:53 CET
The warning looks really good. The App Center link redirects to the Package Management instead of the App Center.
Comment 4 Dirk Wiesenthal univentionstaff 2014-10-31 00:23:22 CET
Do you have a system where this happens? I get redirected to the App Center (CUPS already loaded)
Comment 5 Stefan Gohmann univentionstaff 2014-10-31 06:07:51 CET
(In reply to Dirk Wiesenthal from comment #4)
> Do you have a system where this happens? I get redirected to the App Center
> (CUPS already loaded)

No, I've already installed a printserver on my test systems. I'm not sure but I think it was a plain UCS 4.0 installation.
Comment 6 Dirk Wiesenthal univentionstaff 2014-11-03 09:31:39 CET
Should be fixed now. See Bug#36385 for this specific issue.
Comment 7 Alexander Kramer univentionstaff 2014-11-04 10:09:05 CET
OK - Changelog

OK - Firefox
OK - Chromium
OK - IE 9/10/11

Also tested it in Chromium with emulated mobile devices:
OK - Google Nexus 4
OK - Google Nexus 7
OK - Samsung Galaxy SIII
Comment 8 Stefan Gohmann univentionstaff 2014-11-26 06:54:54 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".