Bug 37030 - Show all blocking components
Show all blocking components
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Update - univention-updater
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-4-errata
Assigned To: Philipp Hahn
Felix Botner
:
Depends on:
Blocks: 37029 37328 37349 37364
  Show dependency treegraph
 
Reported: 2014-11-26 08:47 CET by Stefan Gohmann
Modified: 2014-12-17 12:53 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-11-26 08:47:29 CET
Currently, we show only one blocked component. We should show all components at once.

root@master301:~# univention-upgrade

Starting univention-upgrade. Current UCS version is 3.2-4 errata241

Checking for local repository:                          none
Checking for release updates:                          An update to UCS 4.0 without the component '7i4ucs-123_20140811' is not possible because the component '7i4ucs-123_20140811' is marked as required.
 none
Checking for package updates:                           none
An update to UCS 4.0 without the component '7i4ucs-123_20140811' is not possible because the component '7i4ucs-123_20140811' is marked as required.
root@master301:~#
Comment 1 Philipp Hahn univentionstaff 2014-12-01 15:33:12 CET
This change will cascade into UMC, as UMC currently also only handles the first falling component and does further processing by using the name of the missing component: ./umc/js/updater/UpdatesPage.js → release_update_blocking_component
Comment 2 Philipp Hahn univentionstaff 2014-12-01 16:28:08 CET
r56358 | Bug #37030 Updater: Show all blocking components
r56359 | Bug #37030 Updater: Show all blocking components

Package: univention-updater
Version: 10.0.51-3.1341.201412011614
Branch: ucs_4.0-0
Scope: errata4.0-0

Package: ucs-test
Version: 5.0.66-2.879.201412011620
Branch: ucs_4.0-0
Scope: errata4.0-0

Update localhost repository testing errors...................................... Test failed
Update localhost repository with unmaintained................................... Test failed
Test the correct behavior of univention-updater-check........................... Test failed
Update localhost repository at max version...................................... Test failed
Update localhost component with current version blocked......................... Test failed
Update localhost component with multiple scripts................................ Test failed
Update localhost with component authentication failure.......................... Test failed
Comment 3 Philipp Hahn univentionstaff 2014-12-02 18:33:42 CET
(In reply to Philipp Hahn from comment #2)
> ...................................... Test failed
This was caused by unsigned APT repositories being used while testing.

r56389 | Bug #37030: Show all blocking components 3.2-4
r56388 | Bug #37030: Show all blocking components 4.0-0
 Fix errors
 Add test case: 09_updater/49component-version-current-dep2

Successful build
Package: univention-updater
Version: 10.0.51-4.1344.201412021821
Branch: ucs_4.0-0
Scope: errata4.0-0

Package: ucs-test
Version: 5.0.66-3.882.201412021829
Branch: ucs_4.0-0
Scope: errata4.0-0

Package: univention-updater
Version: 9.0.44-7.1343.201412021821
Branch: ucs_3.2-0
Scope: errata3.2-4

Package: ucs-test
Version: 4.0.186-4.881.201412021826
Branch: ucs_3.2-0
Scope: errata3.2-4


r56386 | Bug #37030 Updater: Show all blocking components YAML
r56390 | Bug #37030: Show all blocking components YAML
 2014-12-01-univention-updater.yaml
Comment 4 Philipp Hahn univentionstaff 2014-12-03 08:58:40 CET
r56393 | Bug #37030 Updater: Show all blocking components 3.2-4
r56392 | Bug #37030 Updater: Show all blocking components 4.0-0
 Fix set() not supporting indexing

Package: univention-updater
Version: 10.0.51-5.1346.201412030844
Branch: ucs_4.0-0
Scope: errata4.0-0

Package: univention-updater
Version: 9.0.44-8.1345.201412030844
Branch: ucs_3.2-0
Scope: errata3.2-4

r56394 | Bug #36971 USS,Bug #37030 updater: YAML updates
Comment 5 Felix Botner univentionstaff 2014-12-15 12:50:58 CET
The updater now logs all missing components but stills asks me if i want to update ()

-> univention-upgrade 

Starting univention-upgrade. Current UCS version is 3.2-4 errata248

Checking for local repository:                          none
Checking for release updates:                          The update to UCS 4.0 is blocked because the component 'three' is marked as required.
The update to UCS 4.0 is blocked because the component 'two' is marked as required.
The update to UCS 4.0 is blocked because the component 'one' is marked as required.
 found: UCS 4.0-0

Do you want to update to 4.0-0 [Y|n]?


# old updater
-> univention-upgrade 

Starting univention-upgrade. Current UCS version is 3.2-4 errata248

Checking for local repository:                          none
Checking for release updates:                          An update to UCS 4.0 without the component 'three' is not possible because the component 'three' is marked as required.
 none
Checking for package updates:                           none
An update to UCS 4.0 without the component 'three' is not possible because the component 'three' is marked as required.
Setting update/available
Comment 6 Philipp Hahn univentionstaff 2014-12-15 15:37:58 CET
(In reply to Felix Botner from comment #5)
> The updater now logs all missing components but stills asks me if i want to
> update ()

r56839 | Bug #37349 Updater: Show all blocking components

Package: univention-updater
Version: 9.0.44-14.1357.201412151526
Branch: ucs_3.2-0
Scope: errata3.2-4
Comment 7 Felix Botner univentionstaff 2014-12-15 15:50:46 CET
OK 

-> univention-upgrade 

Starting univention-upgrade. Current UCS version is 3.2-4 errata248

Checking for local repository:                          none
Checking for release updates:                          The update to UCS 4.0 is blocked because the components 'two', 'one' are marked as required.
 none
Checking for package updates:                           none
The update to UCS 4.0 is blocked because the components 'two', 'one' are marked as required.
Setting update/available

OK - update still works

OK - YAML
Comment 8 Philipp Hahn univentionstaff 2014-12-16 13:00:14 CET
r56887 | Bug #37030 Updater: Show all blocking components

Package: univention-updater
Version: 9.0.44-17.1363.201412161250
Branch: ucs_3.2-0
Scope: errata3.2-4

r56889 | Bug #37030,37349: Show all blocking components YAML
Comment 9 Moritz Muehlenhoff univentionstaff 2014-12-17 12:53:51 CET
http://errata.univention.de/ucs/3.2/253.html