Bug 37349 - Show all blocking components - 4.0
Show all blocking components - 4.0
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Update - univention-updater
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-0-errata
Assigned To: Philipp Hahn
Stefan Gohmann
:
Depends on: 37030
Blocks: 37029 37328 37364
  Show dependency treegraph
 
Reported: 2014-12-15 15:22 CET by Philipp Hahn
Modified: 2015-01-29 11:46 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-12-15 15:22:00 CET
+++ This bug was initially created as a clone of Bug #37030 +++

Currently, we show only one blocked component. We should show all components at once.

root@master301:~# univention-upgrade

Starting univention-upgrade. Current UCS version is 3.2-4 errata241

Checking for local repository:                          none
Checking for release updates:                          An update to UCS 4.0 without the component '7i4ucs-123_20140811' is not possible because the component '7i4ucs-123_20140811' is marked as required.
 none
Checking for package updates:                           none
An update to UCS 4.0 without the component '7i4ucs-123_20140811' is not possible because the component '7i4ucs-123_20140811' is marked as required.
root@master301:~#
Comment 1 Philipp Hahn univentionstaff 2014-12-15 15:38:46 CET
r56392 | Bug #37030 Updater: Show all blocking components 4.0-0
 Fix set() not supporting indexing
r56838 | Bug #37349 Updater: Show all blocking components

Package: univention-updater
Version: 10.0.51-11.1358.201412151526
Branch: ucs_4.0-0
Scope: errata4.0-0
Comment 2 Stefan Gohmann univentionstaff 2014-12-16 06:08:13 CET
I'm not sure if the bug is the cause. A lot of updater test cases failed last night:
 http://jenkins.knut.univention.de:8080/job/UCS-4.0/job/UCS-4.0-0/job/Autotest%20MultiEnv/SambaVersion=s3,Systemrolle=master/94/
Comment 3 Philipp Hahn univentionstaff 2014-12-16 13:00:17 CET
r56888 | Bug #337349Updater: Show all blocking components

Package: univention-updater
Version: 10.0.51-14.1364.201412161253
Branch: ucs_4.0-0
Scope: errata4.0-0

r56889 | Bug #37030,37349: Show all blocking components YAML

(In reply to Stefan Gohmann from comment #2)
> I'm not sure if the bug is the cause. A lot of updater test cases failed
> last night:

28errors got confused by the more detailed error message. The test restored proxy/http, but without a commit on /etc/apt/apt.conf.d/80proxy all subsequent test were still using the mis-configured proxy from that test and failed.
Comment 4 Stefan Gohmann univentionstaff 2015-01-27 08:10:24 CET
YAML: OK

Code review: OK

Tests: OK
Comment 5 Janek Walkenhorst univentionstaff 2015-01-29 11:46:56 CET
<http://errata.univention.de/ucs/4.0/53.html>