Bug 40505 - INVALID_CREDENTIALS in computerroom/schools
INVALID_CREDENTIALS in computerroom/schools
Status: RESOLVED DUPLICATE of bug 44382
Product: UCS@school
Classification: Unclassified
Component: UMC - Computer room
UCS@school 4.0
Other Linux
: P5 normal (vote)
: UCS@school 4.1.x
Assigned To: UCS@school maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-27 09:49 CET by Florian Best
Modified: 2017-08-28 12:50 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-01-27 09:49:54 CET
Die Ausführung des Kommandos computerroom/schools ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 283, in execute
    function(self, request)
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 114, in wrapper_func
    connections[USER_READ], po = get_user_connection(bind=__bind_callback, write=False)
  File "%PY2.7%/univention/management/console/ldap.py", line 90, in get_user_connection
    return connection()
  File "%PY2.7%/univention/management/console/ldap.py", line 132, in _decorated
    kwargs[loarg], kwargs[poarg] = lo, po = getter()
  File "%PY2.7%/univention/management/console/ldap.py", line 123, in getter
    conn = connection()
  File "%PY2.7%/univention/management/console/ldap.py", line 52, in connection
    bind(lo)
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 412, in bind_user_connection
    return super(SchoolBaseModule, self).bind_user_connection(lo)
  File "%PY2.7%/univention/management/console/base.py", line 349, in bind_user_connection
    lo.lo.bind(self._user_dn, self._password)
  File "%PY2.7%/univention/uldap.py", line 190, in bind
    self.lo.simple_bind_s(self.binddn, self.__encode_pwd(self.bindpw))
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 879, in simple_bind_s
    res = self._apply_method_s(SimpleLDAPObject.simple_bind_s,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 860, in _apply_method_s
    return func(self,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 215, in simple_bind_s
    resp_type, resp_data, resp_msgid, resp_ctrls = self.result3(msgid,all=1,timeout=self.timeout)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 476, in result3
    resp_ctrl_classes=resp_ctrl_classes
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 483, in result4
    ldap_result = self._ldap_call(self._l.result4,msgid,all,timeout,add_ctrls,add_intermediates,add_extop)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 106, in _ldap_call
    result = func(*args,**kwargs)
INVALID_CREDENTIALS: {'desc': 'Invalid credentials'}


Remark:
Logged in as Administrator, changed the password through the Users module. Without logging out and relogging in, I opened the computer room module. The above Python traceback comes
up.

UCS 4.1, latest errata. UCS@school 4.1v4

Version:
4.1-0 errata60 (Vahr)
Comment 1 Florian Best univentionstaff 2017-08-28 12:50:45 CEST

*** This bug has been marked as a duplicate of bug 44382 ***