Bug 42370 - INVALID_CREDENTIALS in schoolusers/groups
INVALID_CREDENTIALS in schoolusers/groups
Status: CLOSED DUPLICATE of bug 44382
Product: UCS@school
Classification: Unclassified
Component: UMC - Classes / Teachers / Workgroup assignment
UCS@school 4.1 R2
Other Linux
: P5 normal (vote)
: UCS@school 4.1 R2 v16
Assigned To: Florian Best
Sönke Schwardt-Krummrich
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-13 12:37 CEST by Florian Best
Modified: 2017-12-21 12:25 CET (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 3: Simply Wrong: The implementation doesn't match the docu
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.086
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017050921000387
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2016-09-13 12:37:47 CEST
Reported by two different school customers, 4.1-2 errata211 (Vahr).

Die Ausführung des Kommandos schoolusers/groups teacher ist fehlgeschlagen:

INVALID_CREDENTIALS: {'desc': 'Invalid credentials'}
result = func(*args,**kwargs)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 106, in
_ldap_call
ldap_result =
self._ldap_call(self._l.result4,msgid,all,timeout,add_ctrls,add_intermediates,add_extop)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 483, in
result4
resp_ctrl_classes=resp_ctrl_classes
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 476, in
result3
resp_type, resp_data, resp_msgid, resp_ctrls =
self.result3(msgid,all=1,timeout=self.timeout)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 215, in
simple_bind_s
return func(self,*args,**kwargs)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 860, in
_apply_method_s
res = self._apply_method_s(SimpleLDAPObject.simple_bind_s,*args,**kwargs)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 879, in
simple_bind_s
self.lo.simple_bind_s(self.binddn, self.__encode_pwd(self.bindpw))
File "/usr/lib/pymodules/python2.7/univention/uldap.py", line 163, in bind
lo.lo.bind(self._user_dn, self._password)
File "/usr/lib/pymodules/pytho

Execution of command 'schoolusers/groups student' has failed:

INVALID_CREDENTIALS: {'desc': 'Invalid credentials'}
result = func(*args,**kwargs)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 106, in
_ldap_call
ldap_result =
self._ldap_call(self._l.result4,msgid,all,timeout,add_ctrls,add_intermediates,add_extop)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 483, in
result4
resp_ctrl_classes=resp_ctrl_classes
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 476, in
result3
resp_type, resp_data, resp_msgid, resp_ctrls =
self.result3(msgid,all=1,timeout=self.timeout)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 215, in
simple_bind_s
return func(self,*args,**kwargs)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 860, in
_apply_method_s
res = self._apply_method_s(SimpleLDAPObject.simple_bind_s,*args,**kwargs)
File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 879, in
simple_bind_s
self.lo.simple_bind_s(self.binddn, self.__encode_pwd(self.bindpw))
File "/usr/lib/pymodules/python2.7/univention/uldap.py", line 163, in bind
lo.lo.bind(self._user_dn, self._password)
File
"/usr/lib/pymodules/python2.7/univention/management/console/base.py",
line 349, in bind_user_connection
return super(SchoolBaseModule, self).bind_user_connection(lo)
File "/usr/lib/pymodules/python2.7/ucsschool/lib/schoolldap.py", line
412, in bind_user_connection
bind(lo)
File
"/usr/lib/pymodules/python2.7/univention/management/console/ldap.py",
line 52, in connection
conn = connection()
File
"/usr/lib/pymodules/python2.7/univention/management/console/ldap.py",
line 123, in getter
kwargs[loarg], kwargs[poarg] = lo, po = getter()
File
"/usr/lib/pymodules/python2.7/univention/management/console/ldap.py",
line 132, in _decorated
return connection()
File
"/usr/lib/pymodules/python2.7/univention/management/console/ldap.py",
line 90, in get_user_connection
connections[USER_READ], po = get_user_connection(bind=__bind_callback,
write=False)
File "/usr/lib/pymodules/python2.7/ucsschool/lib/schoolldap.py", line
114, in wrapper_func
function(self, request)
File
"/usr/lib/pymodules/python2.7/univention/management/console/base.py",
line 283, in execute
Traceback (most recent call last):
Comment 1 Florian Best univentionstaff 2016-09-15 14:01:46 CEST
Reported again, 4.1-2 errata211 (Vahr)
Comment 2 Florian Best univentionstaff 2016-09-15 14:03:46 CEST
Guten Tag
1) anmelden, Passwort ändern
2) anzeigen der Schülerin
3) Fehlermeldung
Die Konsole funktioniert seit ein paar Tagen nicht mehr.
Comment 3 Sönke Schwardt-Krummrich univentionstaff 2017-04-28 12:33:05 CEST
We're currently unable to reproduce this issue.
Comment 4 Florian Best univentionstaff 2017-05-09 15:04:32 CEST
(In reply to Sönke Schwardt-Krummrich from comment #3)
> We're currently unable to reproduce this issue.
Wouldn't the flag NEEDMOREINFO better then?

Well, I can reproduce this:
UCS@school + AD Member mode causes this and similar tracebacks very often.
Maybe the AD Server has a limit on LDAP binds?

But I assume this is not a UCS@school related problem. Maybe we should handle this error for all UMC modules and display some error message and redirect to the login dialog? A relogin doesn't solve the problem in my case :-/
Comment 5 Florian Best univentionstaff 2017-08-28 12:51:27 CEST

*** This bug has been marked as a duplicate of bug 44382 ***
Comment 6 Sönke Schwardt-Krummrich univentionstaff 2017-12-11 22:08:08 CET
Yes, a duplicate
Comment 7 Sönke Schwardt-Krummrich univentionstaff 2017-12-21 12:25:13 CET
UCS@school 4.1 R2 v16 has been released.

http://docs.software-univention.de/changelog-ucsschool-4.1R2v16-de.html

If this error occurs again, please clone this bug.