Bug 45223 - INVALID_CREDENTIALS in schoolwizards
INVALID_CREDENTIALS in schoolwizards
Status: RESOLVED DUPLICATE of bug 44382
Product: UCS@school
Classification: Unclassified
Component: UMC - Wizards
UCS@school 4.2
Other Linux
: P5 normal (vote)
: ---
Assigned To: UCS@school maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-21 11:24 CEST by Florian Best
Modified: 2017-10-13 12:36 CEST (History)
0 users

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017081921000344, 2017082421000558
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-08-21 11:24:38 CEST
Version: 4.2-1 errata139 (Lesum) - UCS@school 4.2 v2

Die Ausführung des Kommandos schoolwizards/computers/add schoolwizards/computers ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 249, in execute
    function.__func__(self, request, *args, **kwargs)
  File "%PY2.7%/univention/management/console/modules/schoolwizards/__init__.py", line 122, in _decorated
    ret = func(self, request, *a, **kw)
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 123, in wrapper_func
    kwargs[USER_WRITE], po = get_user_connection(bind=__bind_callback, write=True)
  File "%PY2.7%/univention/management/console/ldap.py", line 94, in get_user_connection
    return connection()
  File "%PY2.7%/univention/management/console/ldap.py", line 140, in _decorated
    kwargs[loarg], kwargs[poarg] = lo, po = getter()
  File "%PY2.7%/univention/management/console/ldap.py", line 130, in getter
    conn = connection()
  File "%PY2.7%/univention/management/console/ldap.py", line 53, in connection
    bind(lo)
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 384, in bind_user_connection
    return super(SchoolBaseModule, self).bind_user_connection(lo)
  File "%PY2.7%/univention/management/console/base.py", line 355, in bind_user_connection
    lo.lo.bind(self._user_dn, self._password)
  File "%PY2.7%/univention/uldap.py", line 165, in bind
    self.lo.simple_bind_s(self.binddn, self.__encode_pwd(self.bindpw))
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 879, in simple_bind_s
    res = self._apply_method_s(SimpleLDAPObject.simple_bind_s,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 860, in _apply_method_s
    return func(self,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 215, in simple_bind_s
    resp_type, resp_data, resp_msgid, resp_ctrls = self.result3(msgid,all=1,timeout=self.timeout)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 476, in result3
    resp_ctrl_classes=resp_ctrl_classes
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 483, in result4
    ldap_result = self._ldap_call(self._l.result4,msgid,all,timeout,add_ctrls,add_intermediates,add_extop)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 106, in _ldap_call
    result = func(*args,**kwargs)
INVALID_CREDENTIALS: {'desc': 'Invalid credentials'}
Comment 1 Florian Best univentionstaff 2017-08-28 12:51:59 CEST

*** This bug has been marked as a duplicate of bug 44382 ***
Comment 2 Florian Best univentionstaff 2017-10-13 12:36:43 CEST
Version: 4.2-1 errata144 (Lesum) - UCS@school 4.2 v2

Remark: Hier die fehlermeldung mit "invalid credentials"
Sie kam beim öffnen der Schulen