Bug 38854 - INVALID_CREDENTIALS in schoolgroups/put
INVALID_CREDENTIALS in schoolgroups/put
Status: RESOLVED DUPLICATE of bug 44382
Product: UCS@school
Classification: Unclassified
Component: UMC - Classes / Teachers / Workgroup assignment
UCS@school 4.0 R2
Other Linux
: P5 normal (vote)
: UCS@school 4.0.x
Assigned To: UCS@school maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-08 09:12 CEST by Florian Best
Modified: 2017-08-28 12:50 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017082121000349
Bug group (optional): Error handling, External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2015-07-08 09:12:01 CEST
We received the following traceback, 4.0-2 errata215 (Walle)

Die Ausführung des Kommandos schoolgroups/put teacher ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 282, in execute
    function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 188, in _response
    return function(self, request)
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 186, in wrapper_func
    connections = get_ldap_connections( _connection_types )
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 137, in get_ldap_connections
    lo, pos = udm_uldap.getMachineConnection( ldap_master = True )
  File "%PY2.7%/univention/admin/uldap.py", line 75, in getMachineConnection
    lo=univention.uldap.getMachineConnection(start_tls, decode_ignorelist=decode_ignorelist, ldap_master=ldap_master)
  File "%PY2.7%/univention/uldap.py", line 101, in getMachineConnection
    lo=access(host=ucr['ldap/master'], port=port, base=ucr['ldap/base'], binddn=ucr['ldap/hostdn'], bindpw=bindpw, start_tls=start_tls, decode_ignorelist=decode_ignorelist,
reconnect=reconnect)
  File "%PY2.7%/univention/uldap.py", line 177, in __init__
    self.__open(ca_certfile)
  File "%PY2.7%/univention/uldap.py", line 219, in __open
    self.lo.simple_bind_s(self.binddn, self.__encode_pwd(self.bindpw))
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 879, in simple_bind_s
    res = self._apply_method_s(SimpleLDAPObject.simple_bind_s,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 860, in _apply_method_s
    return func(self,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 215, in simple_bind_s
    resp_type, resp_data, resp_msgid, resp_ctrls = self.result3(msgid,all=1,timeout=self.timeout)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 476, in result3
    resp_ctrl_classes=resp_ctrl_classes
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 483, in result4
    ldap_result = self._ldap_call(self._l.result4,msgid,all,timeout,add_ctrls,add_intermediates,add_extop)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 106, in _ldap_call
    result = func(*args,**kwargs)
INVALID_CREDENTIALS: {'desc': 'Invalid credentials'}
Comment 1 Florian Best univentionstaff 2017-08-21 14:33:55 CEST
Version: 4.2-1 errata139 (Lesum) - UCS@school 4.2 v2

Remark: UMC Lehrer zuordnen geöffnet BÄNG

Die Ausführung des Kommandos schoolgroups/schools class ist fehlgeschlagen:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 249, in execute
    function.__func__(self, request, *args, **kwargs)
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 125, in wrapper_func
    kwargs[USER_READ], po = get_user_connection(bind=__bind_callback, write=False)
  File "%PY2.7%/univention/management/console/ldap.py", line 94, in get_user_connection
    return connection()
  File "%PY2.7%/univention/management/console/ldap.py", line 140, in _decorated
    kwargs[loarg], kwargs[poarg] = lo, po = getter()
  File "%PY2.7%/univention/management/console/ldap.py", line 130, in getter
    conn = connection()
  File "%PY2.7%/univention/management/console/ldap.py", line 53, in connection
    bind(lo)
  File "%PY2.7%/ucsschool/lib/schoolldap.py", line 384, in bind_user_connection
    return super(SchoolBaseModule, self).bind_user_connection(lo)
  File "%PY2.7%/univention/management/console/base.py", line 355, in bind_user_connection
    lo.lo.bind(self._user_dn, self._password)
  File "%PY2.7%/univention/uldap.py", line 165, in bind
    self.lo.simple_bind_s(self.binddn, self.__encode_pwd(self.bindpw))
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 879, in simple_bind_s
    res = self._apply_method_s(SimpleLDAPObject.simple_bind_s,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 860, in _apply_method_s
    return func(self,*args,**kwargs)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 215, in simple_bind_s
    resp_type, resp_data, resp_msgid, resp_ctrls = self.result3(msgid,all=1,timeout=self.timeout)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 476, in result3
    resp_ctrl_classes=resp_ctrl_classes
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 483, in result4
    ldap_result = self._ldap_call(self._l.result4,msgid,all,timeout,add_ctrls,add_intermediates,add_extop)
  File "/usr/lib/python2.7/dist-packages/ldap/ldapobject.py", line 106, in _ldap_call
    result = func(*args,**kwargs)
INVALID_CREDENTIALS: {'desc': 'Invalid credentials'}
Comment 2 Florian Best univentionstaff 2017-08-28 12:50:29 CEST

*** This bug has been marked as a duplicate of bug 44382 ***