Bug 45206 - System setup crashes with OSError: [Errno 12] Cannot allocate memory
System setup crashes with OSError: [Errno 12] Cannot allocate memory
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: System setup
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.3-1-errata
Assigned To: Richard Ulmer
Erik Damrose
:
: 42684 46660 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-15 11:26 CEST by Florian Best
Modified: 2018-08-22 14:26 CEST (History)
3 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 6: Setup Problem: Issue for the setup process
Who will be affected by this bug?: 1: Will affect a very few installed domains
How will those affected feel about the bug?: 3: A User would likely not purchase the product
User Pain: 0.103
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2017080821000311, 2017080821000338
Bug group (optional): External feedback
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2017-08-15 11:26:14 CEST
Version: 4.1-4 errata360 (Vahr)

Execution of command 'setup/keymap/save wizard' has failed:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 281, in execute
    function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/setup/__init__.py", line 165, in save_keymap
    subprocess.call(['/usr/bin/setxkbmap', '-display', ':0', '-layout', layout])
  File "/usr/lib/python2.7/subprocess.py", line 493, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1153, in _execute_child
    self.pid = os.fork()
OSError: [Errno 12] Cannot allocate memory

Version: 4.1-4 errata360 (Vahr)

Execution of command 'setup/net/apply wizard' has failed:

Traceback (most recent call last):
  File "%PY2.7%/univention/management/console/base.py", line 281, in execute
    function(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 318, in _response
    result = _multi_response(self, request)
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 462, in _response
    return list(function(self, iterator, *nones))
  File "%PY2.7%/univention/management/console/modules/decorators.py", line 284, in _fake_func
    yield function(self, *args)
  File "%PY2.7%/univention/management/console/modules/setup/__init__.py", line 645, in net_apply
    util.run_networkscrips()
  File "%PY2.7%/univention/management/console/modules/setup/util.py", line 295, in run_networkscrips
    subprocess.call(CMD_DISABLE_EXEC, stdout=f, stderr=f)
  File "/usr/lib/python2.7/subprocess.py", line 493, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1153, in _execute_child
    self.pid = os.fork()
OSError: [Errno 12] Cannot allocate memory
Comment 1 Arvid Requate univentionstaff 2018-07-04 12:43:32 CEST
*** Bug 46660 has been marked as a duplicate of this bug. ***
Comment 2 Arvid Requate univentionstaff 2018-07-04 12:57:29 CEST
*** Bug 42684 has been marked as a duplicate of this bug. ***
Comment 3 Richard Ulmer univentionstaff 2018-08-06 14:36:09 CEST
The required memory for UCS was previously 512MiB. When I tried installing a domain controller master with all components with 512MiB memory (and 512MiB swap) the oom killer killed firefox during the installation (see Bug #42684 ).

When running the same installation with 1024MiB memory (and 1024MiB swap) I did not encounter any problems.

Thus I raised the requirement to 1024MiB. Please reopen this bug, if you encounter any problems using 1024MiB of memory.

univention-system-setup (11.0.5-17)
43b8e4899988 | Bug #45206: Merge branch 'rulmer/45206' into 4.3-1
80b87eb6ebc6 | Bug #45206: Raise required RAM to 1GiB
8b0802d6ce16 | Bug #45206: Raise recommended memory in system setup

10699bb11e63 | Bug #45206: Update required RAM in the manual

univention-system-setup.yaml
ea86b3011ce5 | Bug #45206: Update yaml file
Comment 4 Erik Damrose univentionstaff 2018-08-20 18:03:15 CEST
The addition of 10% 'margin' on top of the reported available memory is a bit hacky, but works with our current memory range of about 1GiB. With more RAM available, these 10% will be quite large, and the kernel will probably not consume such amounts of it. But its ok for now.

OK: Works with 1024MiB, warning shows with 900MiB
OK: Can still continue and override warning
OK: yaml
Verified
Comment 5 Arvid Requate univentionstaff 2018-08-22 14:26:17 CEST
<http://errata.software-univention.de/ucs/4.3/214.html>