Bug 30943 - Review UCR variable descriptions for base packages
Review UCR variable descriptions for base packages
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 3.0
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Moritz Muehlenhoff
Philipp Hahn
: interim-2
: 19300 24445 29575 (view as bug list)
Depends on:
Blocks: 33425 45822
  Show dependency treegraph
 
Reported: 2013-03-28 14:36 CET by Moritz Muehlenhoff
Modified: 2017-12-06 10:26 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Bug #30943: base/: QA fixes for UCRV descriptions (116.83 KB, patch)
2013-09-18 13:24 CEST, Philipp Hahn
Details | Diff
UCRV QA (63.12 KB, patch)
2013-09-20 09:57 CEST, Philipp Hahn
Details | Diff
Duplicate nscd/autostart description (2.85 KB, patch)
2013-09-20 10:15 CEST, Philipp Hahn
Details | Diff
More fixes (7.25 KB, patch)
2013-09-23 16:27 CEST, Philipp Hahn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2013-03-28 14:36:31 CET
The UCR variable descriptions for the packages in base/ should be reviewed:

- Are descriptions missing?
- Are they comprehensible and self-contained?
- Are the syntactical options obvious for the user?
- Quality of the English translation

./univention-pam/debian/univention-pam.univention-config-registry-variables
./univention-firewall/debian/univention-firewall.univention-config-registry-variables
./univention-base-files/debian/univention-base-files.univention-config-registry-variables
./univention-bootsplash/debian/univention-bootsplash.univention-config-registry-variables
./univention-updater/debian/univention-updater.univention-config-registry-variables
./univention-quota/debian/univention-quota.univention-config-registry-variables
./univention-system-setup/debian/univention-system-setup-boot.univention-config-registry-variables
./univention-system-setup/debian/univention-system-setup.univention-config-registry-variables
./univention-server/debian/univention-role-server-common.univention-config-registry-variables
./univention-heimdal/debian/univention-heimdal-kdc.univention-config-registry-variables
./univention-heimdal/debian/univention-heimdal-common.univention-config-registry-variables
./univention-lib/debian/python-univention-lib.univention-config-registry-variables
./univention-network-manager/debian/univention-ifplugd.univention-config-registry-variables
./univention-network-manager/debian/univention-network-common.univention-config-registry-variables
./univention-initrd/debian/univention-initrd.univention-config-registry-variables
./univention-skel/debian/univention-skel.univention-config-registry-variables
./univention-printclient/debian/univention-printclient.univention-config-registry-variables
./univention-ssl/debian/univention-ssl.univention-config-registry-variables
./univention-maintenance/debian/univention-maintenance.univention-config-registry-variables
./univention-grub/debian/univention-grub.univention-config-registry-variables
Comment 1 Moritz Muehlenhoff univentionstaff 2013-05-30 14:07:40 CEST
*** Bug 19300 has been marked as a duplicate of this bug. ***
Comment 2 Moritz Muehlenhoff univentionstaff 2013-05-31 10:45:53 CEST
We will not ship a UCS 3.1-2 release; the next UCS release will be UCS 3.2.

As such, this bug is moved to the new target milestone.
Comment 3 Moritz Muehlenhoff univentionstaff 2013-07-02 15:44:51 CEST
*** Bug 24445 has been marked as a duplicate of this bug. ***
Comment 4 Moritz Muehlenhoff univentionstaff 2013-09-05 08:10:29 CEST
*** Bug 29575 has been marked as a duplicate of this bug. ***
Comment 5 Moritz Muehlenhoff univentionstaff 2013-09-09 14:20:35 CEST
The UCR variable descriptions for the following packages have been revised:

univention-ssl
univention-base-files
univention-firewall
univention-heimdal
univention-initrd
univention-system-setup
univention-updater
univention-network-manager
univention-bootsplash
univention-maintenance
univention-grub
univention-lib
univention-pam
univention-printclient
univention-server
univention-quota
univention-skel
univention-passwd-store
Comment 6 Philipp Hahn univentionstaff 2013-09-18 13:23:14 CEST
FAIL: r43568,43548 univention-ssl
FAIL: r43769,43799,43805 univention-base-files
FAIL: r43719,43657 univention-firewall
FAIL: r43685,43604,43575 univention-heimdal
FAIL: r41927 univention-initrd
FAIL: r43683,43573 univention-system-setup
FAIL: r43730,43787 univention-updater
OK: r43788 univention-network-manager
OK: r41408 univention-bootsplash
OK: r41409 univention-maintenance
OK: r43571,43546,42341 univention-grub
OK: r41724 univention-lib
FAIL: r41475 univention-pam
FAIL: r41405 univention-printclient
OK: r41430 univention-server
OK: r41407 univention-quota
FAIL: r41404,41479 univention-skel
FAIL: r41403 univention-passwd-store
Comment 7 Philipp Hahn univentionstaff 2013-09-18 13:24:00 CEST
Created attachment 5438 [details]
Bug #30943: base/: QA fixes for UCRV descriptions

$ diffstat ~/BUG/30943_ucrv-base.diff
 univention-base-files/debian/univention-base-files.univention-config-registry-variables          |  116 +++++-----
 univention-firewall/debian/univention-firewall.univention-config-registry-variables              |   16 -
 univention-grub/debian/univention-grub.univention-config-registry-variables                      |   34 +-
 univention-heimdal/debian/univention-heimdal-common.univention-config-registry-variables         |   36 +--
 univention-initrd/debian/univention-initrd.univention-config-registry-variables                  |   12 -
 univention-lib/debian/python-univention-lib.univention-config-registry-variables                 |    2 
 univention-maintenance/debian/univention-maintenance.univention-config-registry-variables        |    4 
 univention-network-manager/debian/univention-ifplugd.univention-config-registry-variables        |    4 
 univention-network-manager/debian/univention-network-common.univention-config-registry-variables |    8 
 univention-pam/debian/univention-pam.univention-config-registry-variables                        |   54 ++--
 univention-passwd-store/debian/univention-passwd-store.univention-config-registry-variables      |    4 
 univention-printclient/debian/univention-printclient.univention-config-registry-variables        |    4 
 univention-quota/debian/univention-quota.univention-config-registry-variables                    |    1 
 univention-skel/debian/univention-skel.univention-config-registry-variables                      |    8 
 univention-ssl/debian/univention-ssl.univention-config-registry-variables                        |   10 
 univention-system-setup/debian/univention-system-setup-boot.univention-config-registry-variables |    8 
 univention-system-setup/debian/univention-system-setup.univention-config-registry-variables      |   10 
 univention-updater/debian/univention-updater.univention-config-registry-variables                |   61 ++---
 18 files changed, 195 insertions(+), 197 deletions(-)
Comment 8 Moritz Muehlenhoff univentionstaff 2013-09-19 11:14:18 CEST
I've applied your patch with some modifications and fixed some additional typos, please rebase:

- In some cases Cron is used as a proper noun and capitalised.

- I only used Type=bool for variables accessed using is_true()/is_false(), otherwise the UCR templates should be updated.

- We use refer to the initial ramdisk as the initrd in the documentation, so I kept the same in the UCR variable decriptions.
Comment 9 Philipp Hahn univentionstaff 2013-09-19 13:33:55 CEST
(In reply to Moritz Muehlenhoff from comment #8)
> - In some cases Cron is used as a proper noun and capitalised.

OK. Bug #32640

> - I only used Type=bool for variables accessed using is_true()/is_false(),
> otherwise the UCR templates should be updated.

OK. I still prefer bool as a hint to the user, but okay, as the allowed values are documented.
(If someone is going to fix it, it's a lot easier to find for UCRV marked as type=bool NOT using is_true/false() then searching for every UCRV again, which is marked as type=str but really is a Boolean. Bug #8768)h

> - We use refer to the initial ramdisk as the initrd in the documentation, so
> I kept the same in the UCR variable decriptions.
OK: Bug #26772

OK: r44205-44211,44212-44220
OK: git show `git svn find-rev r44205` | lsdiff --strip 5 | cut -d/ -f1 | while read f; do sed -ne 's/Package: //p' "$f/debian/control"; done | ssh 10.200.17.37 LC_ALL=C xargs apt-cache policy | sed -ne 's/^  Candidate: //p' | sort -u | grep -v 20130919
Comment 10 Philipp Hahn univentionstaff 2013-09-20 09:57:22 CEST
Use amount of before singular things you cannot measure.
Use quantity of before singular or plural things you can measure.
Use number of before plural things you can measure.
Comment 11 Philipp Hahn univentionstaff 2013-09-20 09:57:54 CEST
Created attachment 5452 [details]
UCRV QA
Comment 12 Philipp Hahn univentionstaff 2013-09-20 10:15:27 CEST
Created attachment 5453 [details]
Duplicate nscd/autostart description
Comment 13 Philipp Hahn univentionstaff 2013-09-20 10:16:42 CEST
(In reply to Philipp Hahn from comment #10)
> Use amount of before singular things you cannot measure.
> Use quantity of before singular or plural things you can measure.
> Use number of before plural things you can measure.

(In reply to Philipp Hahn from comment #11)
> Created attachment 5452 [details]
> UCRV QA

wrong bug → Bug #30946
Comment 14 Moritz Muehlenhoff univentionstaff 2013-09-20 11:29:50 CEST
(In reply to Philipp Hahn from comment #12)
> Created attachment 5453 [details]
> Duplicate nscd/autostart description

Merged and rebuild.
Comment 15 Philipp Hahn univentionstaff 2013-09-20 13:46:10 CEST
OK: r44272 | Bug #30943
OK: # dpkg-query -W univention-pam
univention-pam  7.0.2-1.219.201309201128
Comment 16 Philipp Hahn univentionstaff 2013-09-20 14:13:56 CEST
Added forgotten Type=str for ipv6/gateway.
> # univention-install-config-registry-info 
> Incomplete entries in variable definition univention-base-files.univention-config-registry-variables
>   ipv6/gateway:
>     type

r44291 | Bug #30943: Fix missing type for UCRV
univention-base-files_3.0.3-5.148.201309201404
Comment 17 Philipp Hahn univentionstaff 2013-09-23 16:27:39 CEST
Created attachment 5459 [details]
More fixes
Comment 18 Philipp Hahn univentionstaff 2013-09-23 16:27:51 CEST
can can → but can
Comment 19 Moritz Muehlenhoff univentionstaff 2013-09-24 09:02:58 CEST
(In reply to Philipp Hahn from comment #17)
> Created attachment 5459 [details]
> More fixes

Merged and built.
Comment 20 Philipp Hahn univentionstaff 2013-09-24 09:44:13 CEST
OK: r44362,44363
OK: LC_ALL=C apt-cache policy univention-base-files univention-heimdal-kdc | grep Candidate
Comment 21 Philipp Hahn univentionstaff 2013-10-30 17:42:50 CET
Bug #33027:
@ base/univention-base-files/debian/univention-base-files.univention-config-registry-variables
-[cron/*/time]
+[cron/*/command]
Comment 22 Stefan Gohmann univentionstaff 2013-11-19 06:43:40 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".