Bug 31699 - Revise UMC overview site
Revise UMC overview site
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.1
Other Linux
: P5 enhancement (vote)
: UCS 3.2
Assigned To: Alexander Kläser
Dirk Wiesenthal
: interim-1
: 10084 30230 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 07:52 CEST by Stefan Gohmann
Modified: 2013-11-19 06:43 CET (History)
7 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Release Goal
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-06-11 07:52:52 CEST
The UMC overview site is not very clear if a lot of UMC modules are available for example with many installed apps or with UCS@school.
Comment 1 Alexander Kläser univentionstaff 2013-07-05 09:35:48 CEST
The current work in progress has been checked in and the package built.
Comment 2 Alexander Kläser univentionstaff 2013-07-19 12:35:48 CEST
The overview site has been discussed and iteratively adapted along with the representations of entries in the App center module. Both listings are displayed in the same manner.

Open points that need to be done:
* Adding/removing favorites fails currently sometimes
* Module descriptions still need to be adapted → Bug 32022
* Icons need to be displayed steadily in the App center module, in the UMC overview only on :hover (and without transparency)
* Context menus are missing foar adding/removing favorites
Comment 3 Alexander Kläser univentionstaff 2013-07-19 12:36:16 CEST
(In reply to Alexander Kläser from comment #2)
> ...
> * Context menus are missing foar adding/removing favorites

See Bug 32023 for this point.
Comment 4 Alexander Kläser univentionstaff 2013-07-22 12:22:32 CEST
*** Bug 10084 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Kläser univentionstaff 2013-07-22 12:22:51 CEST
(In reply to Alexander Kläser from comment #4)
> *** Bug 10084 has been marked as a duplicate of this bug. ***

→ bitte den Link noch ergänzen
Comment 6 Alexander Kläser univentionstaff 2013-07-24 11:08:20 CEST
(In reply to Alexander Kläser from comment #2)
> ...
> * Module descriptions still need to be adapted → Bug 32022

… and Bug 32048
Comment 7 Dirk Wiesenthal univentionstaff 2013-07-25 14:24:50 CEST
Clicking on "Search term" does not focus on the input but the div overlay.
Comment 8 Alexander Kläser univentionstaff 2013-07-26 15:38:10 CEST
(In reply to Alexander Kläser from comment #5)
> > *** Bug 10084 has been marked as a duplicate of this bug. ***
> → bitte den Link noch ergänzen

Done.

(In reply to Alexander Kläser from comment #2)
> ...
> * Icons need to be displayed steadily in the App center module, in the UMC
> overview only on :hover (and without transparency)

Done.

(In reply to Dirk Wiesenthal from comment #7)
> Clicking on "Search term" does not focus on the input but the div overlay.

Good hint! Fixed.

(In reply to Alexander Kläser from comment #2)
> ...
> * Adding/removing favorites fails currently sometimes

Fixed along with Bug 32023.


 univention-management-console-frontend (3.0.39-1) unstable; urgency=low
 .
   * Bug #31699: added link to UCS start site, added re-focus after click on
     link search categories, conditional include of piwik menu item, only show
     checkbox for hardware statistics in startup dialog
Comment 9 Dirk Wiesenthal univentionstaff 2013-07-30 13:50:28 CEST
(In reply to Alexander Kläser from comment #8)
> (In reply to Dirk Wiesenthal from comment #7)
> > Clicking on "Search term" does not focus on the input but the div overlay.
> 
> Good hint! Fixed.

This was not fixed. "Search term" is a div lying over the search input. It shall resemble the HTML5 placeholder. But clicking directly on "Search term" focuses on the div (which does nothing) instead of the search input itself.
Comment 10 Alexander Kläser univentionstaff 2013-07-30 13:57:31 CEST
(In reply to Dirk Wiesenthal from comment #9)
> (In reply to Alexander Kläser from comment #8)
> > (In reply to Dirk Wiesenthal from comment #7)
> > > Clicking on "Search term" does not focus on the input but the div overlay.
> > 
> > Good hint! Fixed.
> 
> This was not fixed. "Search term" is a div lying over the search input. It
> shall resemble the HTML5 placeholder. But clicking directly on "Search term"
> focuses on the div (which does nothing) instead of the search input itself.

Thanks! Fixed.

 univention-management-console-frontend (3.0.45-1) unstable; urgency=low
 .
   * Bug #31699: fixed focus with inline label in TextBox
Comment 11 Alexander Kläser univentionstaff 2013-08-05 14:38:10 CEST
Sorting of modules within categories should be done by priority (as for UCS 3.1).
Comment 12 Erik Damrose univentionstaff 2013-08-05 15:17:21 CEST
> Open points that need to be done:
> * Adding/removing favorites fails currently sometimes

Today with the current version i could not add or remove favorites. The options were not present in the contextmenu.
Comment 13 Florian Best univentionstaff 2013-08-05 16:10:57 CEST
(In reply to Erik Damrose from comment #12)
> > Open points that need to be done:
> > * Adding/removing favorites fails currently sometimes
> 
> Today with the current version i could not add or remove favorites. The
> options were not present in the contextmenu.
Are you logged in as root (non LDAP-user)? Do you have a LDAP connection (== is slapd running)?
Comment 14 Erik Damrose univentionstaff 2013-08-05 16:14:25 CEST
> Are you logged in as root (non LDAP-user)? Do you have a LDAP connection (==
> is slapd running)?
LDAP server is running and i am logged in as Administrator
Comment 15 Alexander Kläser univentionstaff 2013-08-05 17:14:16 CEST
(In reply to Alexander Kläser from comment #11)
> Sorting of modules within categories should be done by priority (as for UCS
> 3.1).

Added sorting according to module priority.

(In reply to Erik Damrose from comment #12)
> > Open points that need to be done:
> > * Adding/removing favorites fails currently sometimes
> 
> Today with the current version i could not add or remove favorites. The
> options were not present in the contextmenu.

Fixed. 

@QA: I could reproduce the problem with the following steps:
(1) Log in at UMC
(2) Restart UMC server → invalidates session
(3) Reload browser tab → first trial to read favorite settings fails
(4) Log in a second time → favorites would be deactivated due to failure in (3)


 univention-management-console-frontend (3.0.51-1) unstable; urgency=low
 .
   * Bug #31699: sort modules by their priority, fixed problems with disabling
     favorites
Comment 16 Philipp Hahn univentionstaff 2013-08-13 15:55:10 CEST
It's no longer possible to close the region containing the Favorites.
The two column layout has the additional draw back, that more scrolling is needed.
The search is nice; a key shortcut to go directly to the search text would improve the usability.
Comment 17 Dirk Wiesenthal univentionstaff 2013-08-22 12:27:13 CEST
Touch: When writing a search term and then tapping on one category, the term "search term" does not reoccur.

When touching a lot of categories, the grey background stays on one of them all the time (mostly the first category touched).
Comment 18 Alexander Kläser univentionstaff 2013-08-22 18:18:59 CEST
(In reply to Philipp Hahn from comment #16)
> It's no longer possible to close the region containing the Favorites.
> The two column layout has the additional draw back, that more scrolling is
> needed.

Yes, the layout was consciously chosen as a more adequate (and more verbose) way for especially novel users (see also Bug 32145 in this context).

> The search is nice; a key shortcut to go directly to the search text would
> improve the usability.

Good idea, I created Bug 32320 for this.

(In reply to Dirk Wiesenthal from comment #17)
> Touch: When writing a search term and then tapping on one category, the term
> "search term" does not reoccur.
> 
> When touching a lot of categories, the grey background stays on one of them
> all the time (mostly the first category touched).

Good hint! I added this to Bug 32319.
Comment 19 Dirk Wiesenthal univentionstaff 2013-08-23 16:23:00 CEST
Okay, looks beautiful, changelog exists. Remaining issues outsourced.
Comment 20 Alexander Kläser univentionstaff 2013-09-11 12:57:08 CEST
*** Bug 30230 has been marked as a duplicate of this bug. ***
Comment 21 Stefan Gohmann univentionstaff 2013-11-19 06:43:03 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".