Bug 35654 - Revise UMC design
Revise UMC design
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Alexander Kläser
Florian Best
: interim-3
: 24940 26265 29068 responsive-design 30972 31704 32755 32823 32890 32987 33147 33242 33563 33863 (view as bug list)
Depends on:
Blocks: 36095 36291 37730
  Show dependency treegraph
 
Reported: 2014-08-20 09:24 CEST by Stefan Gohmann
Modified: 2015-02-09 13:10 CET (History)
6 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Release Goal
Max CVSS v3 score:


Attachments
missing max-height for dialog (97.08 KB, image/png)
2014-11-03 10:58 CET, Florian Best
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-08-20 09:24:17 CEST
The UMC design should be revised with UCS 4.0.
Comment 1 Florian Best univentionstaff 2014-08-27 16:55:23 CEST
A experimental scope for the development has been created: umc-dev
src: dev/branches/ucs-4.0/components/umc-dev/

Package: univention-management-console-frontend
Version: 4.1.0-2.848.201408271644
Branch: ucs_4.0-0
Scope: umc-dev
Comment 2 Florian Best univentionstaff 2014-09-30 11:29:28 CEST
*** Bug 29068 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Kläser univentionstaff 2014-10-06 18:25:36 CEST
Moving towards interim-3, as many design details are still being implemented.
Comment 4 Philipp Hahn univentionstaff 2014-10-22 10:05:15 CEST
r54789 | Bug #35654 USS: fix dpkg --compare-versions
 -if [ dpkg --compare-versions "$2" lt "8.1.6-6" ]; then
 +if dpkg --compare-versions "$2" lt "8.1.6-6"; then
Comment 5 Alexander Kläser univentionstaff 2014-10-24 03:08:25 CEST
All major issues have been addressed, time to set this bug to RESOLVED.
Comment 6 Florian Best univentionstaff 2014-11-03 09:50:40 CET
Please add a changelog entry.
Comment 7 Florian Best univentionstaff 2014-11-03 10:58:58 CET
Created attachment 6280 [details]
missing max-height for dialog

Please decide and move the attachment to Bug 36291.
Comment 8 Florian Best univentionstaff 2014-11-03 11:14:47 CET
The usage statistics menu item contains currently a checkbox which has no effect (after startup wizard):
[x] Enable one-time statistic on hardware configuration.

The activate UCS dialog is currently empty.
Comment 9 Alexander Kläser univentionstaff 2014-11-03 14:25:04 CET
(In reply to Florian Best from comment #6)
> Please add a changelog entry.

r55257 → done

(In reply to Florian Best from comment #7)
> Created attachment 6280 [details]
> missing max-height for dialog
> 
> Please decide and move the attachment to Bug 36291.

→ no blocker as scrolling is possible, added to Bug 36291, comment 23.

(In reply to Florian Best from comment #8)
> The usage statistics menu item contains currently a checkbox which has no
> effect (after startup wizard):
> [x] Enable one-time statistic on hardware configuration.

fixed.

univention-management-console-frontend (4.1.86-1):
Bug #35654:
* remove checkbox of in help dialog of umc/app/FeedbackPage
* adjust some svg graphics for improved display on mobile phones

> The activate UCS dialog is currently empty.

Fixed this. The problem here was the incorrect handling w.r.t. the different value combination for uuid/license as well as ucs/web/license/requested:

bool(uuid/license)
→ no page in startup wizard, no entry in license menu

!bool(uuid/license) && ucs/web/license/requested
→ no page in startup wizard, visible entry in license menu

!bool(uuid/license) && !ucs/web/license/requested
→ visible page in startup wizard, visible entry in license menu


univention-management-console-frontend (4.1.88-1):
Bug #35654:
* always return a configuration object for the ActivationPage with
  additional informative flags
* adjust path to website icon

univention-management-console-module-udm (5.1.22-1):
* Bug #35654: fixed handling of ActivationPage
Comment 10 Alexander Kläser univentionstaff 2014-11-03 17:37:06 CET
I removed the conditional comment for Internet Explorer, as this is no longer supported from IE10 onwards [r55306].

univention-system-setup (8.1.39-1):
* Bug #35654: fixed error noscript error message for Internet Explorer
Comment 11 Florian Best univentionstaff 2014-11-03 20:10:20 CET
*** Bug 31704 has been marked as a duplicate of this bug. ***
Comment 12 Florian Best univentionstaff 2014-11-03 20:11:11 CET
*** Bug 32890 has been marked as a duplicate of this bug. ***
Comment 13 Florian Best univentionstaff 2014-11-03 20:13:00 CET
*** Bug 33147 has been marked as a duplicate of this bug. ***
Comment 14 Florian Best univentionstaff 2014-11-03 20:15:18 CET
*** Bug 26265 has been marked as a duplicate of this bug. ***
Comment 15 Florian Best univentionstaff 2014-11-03 20:16:49 CET
*** Bug 29596 has been marked as a duplicate of this bug. ***
Comment 16 Florian Best univentionstaff 2014-11-03 20:19:23 CET
*** Bug 32755 has been marked as a duplicate of this bug. ***
Comment 17 Florian Best univentionstaff 2014-11-03 20:19:59 CET
*** Bug 32987 has been marked as a duplicate of this bug. ***
Comment 18 Florian Best univentionstaff 2014-11-03 20:21:35 CET
*** Bug 33563 has been marked as a duplicate of this bug. ***
Comment 19 Florian Best univentionstaff 2014-11-03 20:22:24 CET
*** Bug 33242 has been marked as a duplicate of this bug. ***
Comment 20 Florian Best univentionstaff 2014-11-03 20:23:38 CET
*** Bug 33863 has been marked as a duplicate of this bug. ***
Comment 21 Florian Best univentionstaff 2014-11-03 20:26:28 CET
*** Bug 32823 has been marked as a duplicate of this bug. ***
Comment 22 Florian Best univentionstaff 2014-11-03 20:51:17 CET
*** Bug 30972 has been marked as a duplicate of this bug. ***
Comment 23 Alexander Kläser univentionstaff 2014-11-07 12:26:59 CET
*** Bug 24940 has been marked as a duplicate of this bug. ***
Comment 24 Florian Best univentionstaff 2014-11-10 16:58:03 CET
OK, all further details are done via an erratum.
Changelog: OK
Comment 25 Stefan Gohmann univentionstaff 2014-11-26 06:55:59 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".